aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-04-12 23:44:12 +0800
committerswills <swills@FreeBSD.org>2012-04-12 23:44:12 +0800
commitf3d3cc77129f4b4af118f5a100b7999d41dcfbe0 (patch)
tree1b7949eea31674c2a47c8b7b51549b68ede4ab4a
parent69bedc15249887c5b1916c67f7385b5c7f560d16 (diff)
downloadfreebsd-ports-gnome-f3d3cc77129f4b4af118f5a100b7999d41dcfbe0.tar.gz
freebsd-ports-gnome-f3d3cc77129f4b4af118f5a100b7999d41dcfbe0.tar.zst
freebsd-ports-gnome-f3d3cc77129f4b4af118f5a100b7999d41dcfbe0.zip
- Add TEST_DEPENDS
PR: ports/166432 Approved by: maintainer timeout (kuriyama, >2 weeks)
-rw-r--r--www/p5-HTML-Shakan/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/www/p5-HTML-Shakan/Makefile b/www/p5-HTML-Shakan/Makefile
index 8e1b0efa2398..18023abfcb2e 100644
--- a/www/p5-HTML-Shakan/Makefile
+++ b/www/p5-HTML-Shakan/Makefile
@@ -22,7 +22,9 @@ RUN_DEPENDS= \
p5-List-MoreUtils>=0.22:${PORTSDIR}/lang/p5-List-MoreUtils \
p5-Mouse>=0.90,1:${PORTSDIR}/devel/p5-Mouse \
p5-parent>0:${PORTSDIR}/devel/p5-parent
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+TEST_DEPENDS= p5-Test-Requires>=0:${PORTSDIR}/devel/p5-Test-Requires
PERL_MODBUILD= yes
@@ -47,4 +49,10 @@ MAN3= HTML::Shakan.3 \
HTML::Shakan::Widgets::Simple.3 \
HTML::Shakan::Widgets::jQueryUI.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>