aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2002-09-10 03:25:33 +0800
committerknu <knu@FreeBSD.org>2002-09-10 03:25:33 +0800
commitf52b9b49b20ceaf7451c7bd6d4e545c0c6b95880 (patch)
treed2fbd17ce7a43e66ed914ee13ac42664990e6676
parent1b1b004604c732649091e79bcafababc8850d3ea (diff)
downloadfreebsd-ports-gnome-f52b9b49b20ceaf7451c7bd6d4e545c0c6b95880.tar.gz
freebsd-ports-gnome-f52b9b49b20ceaf7451c7bd6d4e545c0c6b95880.tar.zst
freebsd-ports-gnome-f52b9b49b20ceaf7451c7bd6d4e545c0c6b95880.zip
Add gauche-gdbm, a GDBM interface for Gauche.
-rw-r--r--databases/Makefile1
-rw-r--r--databases/gauche-gdbm/Makefile42
-rw-r--r--databases/gauche-gdbm/pkg-comment1
-rw-r--r--databases/gauche-gdbm/pkg-descr4
-rw-r--r--databases/gauche-gdbm/pkg-plist2
5 files changed, 50 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index f9726739033f..5dc9ba600bdf 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -25,6 +25,7 @@
SUBDIR += firebird-devel
SUBDIR += freetds
SUBDIR += gadfly
+ SUBDIR += gauche-gdbm
SUBDIR += gdbm
SUBDIR += gigabase
SUBDIR += gmysql
diff --git a/databases/gauche-gdbm/Makefile b/databases/gauche-gdbm/Makefile
new file mode 100644
index 000000000000..2ce8c96598a7
--- /dev/null
+++ b/databases/gauche-gdbm/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: gauche-gdbm
+# Date created: 9 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdbm
+PORTVERSION= 0.6.2
+CATEGORIES= databases
+MASTER_SITES= # none
+PKGNAMEPREFIX= gauche-
+DISTFILES= # none
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= gosh:${PORTSDIR}/${GAUCHE_PORT} \
+ ${NONEXISTENT}:${PORTSDIR}/${GAUCHE_PORT}:configure
+LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm
+RUN_DEPENDS= gosh:${PORTSDIR}/${GAUCHE_PORT}
+
+GAUCHE_PORT= lang/gauche
+
+WRKSRC= ${WRKDIR}/dbm
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ARGS= GOSH=gosh \
+ OPTFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB= VERSION="${PORTVERSION}" \
+ TARGET="${CONFIGURE_TARGET}"
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+ ${LN} -sf `cd ${PORTSDIR}/${GAUCHE_PORT}; ${MAKE} -V WRKSRC`/ext/dbm ${WRKDIR}/
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/gdbm.scm `gauche-config --syslibdir`/dbm/
+ ${INSTALL_DATA} ${WRKSRC}/gdbm.so `gauche-config --sysarchdir`/
+
+.include <bsd.port.mk>
diff --git a/databases/gauche-gdbm/pkg-comment b/databases/gauche-gdbm/pkg-comment
new file mode 100644
index 000000000000..b6a4378b5119
--- /dev/null
+++ b/databases/gauche-gdbm/pkg-comment
@@ -0,0 +1 @@
+GDBM interface for Gauche
diff --git a/databases/gauche-gdbm/pkg-descr b/databases/gauche-gdbm/pkg-descr
new file mode 100644
index 000000000000..20f0a3179214
--- /dev/null
+++ b/databases/gauche-gdbm/pkg-descr
@@ -0,0 +1,4 @@
+This is a GDBM interface for Gauche.
+
+Author: Shiro Kawai <shiro@acm.org>
+WWW: http://www.shiro.dreamhost.com/scheme/gauche/index.html
diff --git a/databases/gauche-gdbm/pkg-plist b/databases/gauche-gdbm/pkg-plist
new file mode 100644
index 000000000000..ac04a04d8a17
--- /dev/null
+++ b/databases/gauche-gdbm/pkg-plist
@@ -0,0 +1,2 @@
+lib/gauche/%%VERSION%%/%%TARGET%%/gdbm.so
+share/gauche/%%VERSION%%/lib/dbm/gdbm.scm