aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-07 22:48:17 +0800
committermiwi <miwi@FreeBSD.org>2013-02-07 22:48:17 +0800
commitf8ae521649ea288e7d168fc3b16559ad40f45d98 (patch)
tree61e525f22ec74aeecc426728e7cdc14cef1a7371
parent9cde523e749a2c9275ef2d6b4d6234f7c1856e28 (diff)
downloadfreebsd-ports-gnome-f8ae521649ea288e7d168fc3b16559ad40f45d98.tar.gz
freebsd-ports-gnome-f8ae521649ea288e7d168fc3b16559ad40f45d98.tar.zst
freebsd-ports-gnome-f8ae521649ea288e7d168fc3b16559ad40f45d98.zip
- Fix build with clang
- Support PLIST_FILES - Trim header PR: 175035 Submitted by: ports fury
-rw-r--r--games/wmtictactoe/Makefile25
1 files changed, 13 insertions, 12 deletions
diff --git a/games/wmtictactoe/Makefile b/games/wmtictactoe/Makefile
index efc22bed7664..b8c33a958515 100644
--- a/games/wmtictactoe/Makefile
+++ b/games/wmtictactoe/Makefile
@@ -1,27 +1,28 @@
-# New ports collection makefile for: wmtictactoe
-# Date created: 28 Apr 1999
-# Whom: Jim Mock <jim@FreeBSD.org>
-#
+# Created by: Jim Mock <jim@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= wmtictactoe
PORTVERSION= 1.1
PORTREVISION= 3
CATEGORIES= games windowmaker afterstep
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= jim
-DISTNAME= wmtictactoe-1.1-1
+MASTER_SITES= LOCAL/jim
+DISTNAME= ${PORTNAME}-${PORTVERSION}-1
MAINTAINER= ports@FreeBSD.org
-COMMENT= A dockable TicTacToe game for WindowMaker and AfterStep
+COMMENT= Dockable TicTacToe game for WindowMaker and AfterStep
-PLIST_FILES= bin/wmtictactoe
-USE_GMAKE= yes
WRKSRC= ${WRKDIR}/wmtictactoe.app/wmtictactoe
+
USE_XORG= xpm
+USE_GMAKE= yes
+
+PLIST_FILES= bin/wmtictactoe
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|^void .*main|int main|' ${WRKSRC}/wmtictactoe.c
post-install:
- @${ECHO} "===> Run 'wmtictactoe --help' for the available options"
+ @${ECHO_MSG} "===> Run 'wmtictactoe --help' for the available options"
.include <bsd.port.mk>