aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-08 18:59:00 +0800
committeredwin <edwin@FreeBSD.org>2003-09-08 18:59:00 +0800
commitf9e94fc48dc8c116dad246e17ff624d8ce52c189 (patch)
treef475de94ef1d7ed8af16500ec55f739a0e767525
parentb5e10ec8849fd73dfb5d4f9181b444186e99e7e8 (diff)
downloadfreebsd-ports-gnome-f9e94fc48dc8c116dad246e17ff624d8ce52c189.tar.gz
freebsd-ports-gnome-f9e94fc48dc8c116dad246e17ff624d8ce52c189.tar.zst
freebsd-ports-gnome-f9e94fc48dc8c116dad246e17ff624d8ce52c189.zip
[new port] libticalcs: TI calculator library
Libticalcs is part of TiLP, a program to connect a TI calculator to a computer. This lib handles the various calculator types. PR: ports/56136 Submitted by: Tijl Coosemans <tijl@ulyssis.org>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libticalcs/Makefile34
-rw-r--r--devel/libticalcs/distinfo1
-rw-r--r--devel/libticalcs/pkg-descr7
-rw-r--r--devel/libticalcs/pkg-plist21
5 files changed, 64 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d043d34e8911..7d85292f671f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -359,6 +359,7 @@
SUBDIR += libtai
SUBDIR += libtar
SUBDIR += libtecla
+ SUBDIR += libticalcs
SUBDIR += libtifiles
SUBDIR += libtool13
SUBDIR += libtool14
diff --git a/devel/libticalcs/Makefile b/devel/libticalcs/Makefile
new file mode 100644
index 000000000000..235ff60fd756
--- /dev/null
+++ b/devel/libticalcs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: libticalcs
+# Date created: 27 August 2003
+# Whom: Tijl Coosemans <tijl@ulyssis.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libticalcs
+PORTVERSION= 4.5.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= tilp
+
+MAINTAINER= tijl@ulyssis.org
+COMMENT= TI calculator library
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= ticables.10:${PORTSDIR}/comms/libticables \
+ tifiles.5:${PORTSDIR}/devel/libtifiles \
+ intl.4:${PORTSDIR}/devel/gettext
+
+USE_GNOME= glib20
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"\
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= ticalcs-config.1
+
+.include <bsd.port.mk>
diff --git a/devel/libticalcs/distinfo b/devel/libticalcs/distinfo
new file mode 100644
index 000000000000..7147ecd7704e
--- /dev/null
+++ b/devel/libticalcs/distinfo
@@ -0,0 +1 @@
+MD5 (libticalcs-4.5.1.tar.gz) = 3fb8a76fc681f6e7067bac8a98e54ba8
diff --git a/devel/libticalcs/pkg-descr b/devel/libticalcs/pkg-descr
new file mode 100644
index 000000000000..327eb2c6c881
--- /dev/null
+++ b/devel/libticalcs/pkg-descr
@@ -0,0 +1,7 @@
+The libTicalc library is a multi-platform library which handles all
+Texas Instruments calculators through a set of functions.
+
+WWW: http://tilp.info/
+
+- Tijl Coosemans
+tijl@ulyssis.org
diff --git a/devel/libticalcs/pkg-plist b/devel/libticalcs/pkg-plist
new file mode 100644
index 000000000000..01aaf6cc6482
--- /dev/null
+++ b/devel/libticalcs/pkg-plist
@@ -0,0 +1,21 @@
+include/tilp/calc_def.h
+include/tilp/calc_err.h
+include/tilp/calc_int.h
+include/tilp/calc_ver.h
+include/tilp/headers.h
+include/tilp/intl2.h
+include/tilp/keys73.h
+include/tilp/keys83p.h
+include/tilp/keys89.h
+include/tilp/keys92p.h
+include/tilp/pause.h
+include/tilp/ticalcs.h
+include/tilp/tikeys.h
+include/tilp/update.h
+lib/libticalcs-4.la
+lib/libticalcs-4.so
+lib/libticalcs-4.so.5
+libdata/pkgconfig/ticalcs-4.pc
+share/aclocal/ticalcs.m4
+share/locale/fr/LC_MESSAGES/libticalcs.mo
+@unexec rmdir %D/include/tilp 2>/dev/null || true