aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlme <lme@FreeBSD.org>2007-10-27 22:48:16 +0800
committerlme <lme@FreeBSD.org>2007-10-27 22:48:16 +0800
commitfb1a98aaa887d77e780f6c5d5e15eb0d51104a7d (patch)
tree2c69517292a422a883e0be25924cf5852c385447
parent5b42ccf73513a1405df8ba9334eeef207a523a12 (diff)
downloadfreebsd-ports-gnome-fb1a98aaa887d77e780f6c5d5e15eb0d51104a7d.tar.gz
freebsd-ports-gnome-fb1a98aaa887d77e780f6c5d5e15eb0d51104a7d.tar.zst
freebsd-ports-gnome-fb1a98aaa887d77e780f6c5d5e15eb0d51104a7d.zip
- Add FluidSynth support (provides much better MIDI quality than default Adlib emulation)
- Also add FLAC support for consistence - Add --disable-tremor (configure's tremor detection may potentially cause hidden dependency) PR: ports/117306 Submitted by: Dmitry Marakasov <amdmi3 (AT) amdmi3.ru> Approved by: miwi (mentor)
-rw-r--r--games/scummvm/Makefile23
1 files changed, 21 insertions, 2 deletions
diff --git a/games/scummvm/Makefile b/games/scummvm/Makefile
index f9c2baee688b..59bccaf454b2 100644
--- a/games/scummvm/Makefile
+++ b/games/scummvm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= scummvm
PORTVERSION= 0.10.0a
+PORTREVISION= 1
CATEGORIES= games emulators
MASTER_SITES= SF
@@ -21,12 +22,15 @@ USE_SDL= sdl
CONFIGURE_ARGS=--with-sdl-prefix=${LOCALBASE} \
--disable-alsa \
--with-zlib-prefix=/usr \
- --disable-debug
+ --disable-debug \
+ --disable-tremor
CONFIGURE_ENV= CXX="${CXX}"
OPTIONS= VORBIS "Enable Ogg Vorbis support" off \
MAD "Enable mad (MP3) support" on \
- MPEG2 "Enable MPEG2 support (implies VORBIS)" off
+ MPEG2 "Enable MPEG2 support (implies VORBIS)" off \
+ FLAC "Enable FLAC support" off \
+ FLUIDSYNTH "Enable FluidSynth MIDI synthesizer" off
MAN6= scummvm.6
@@ -63,8 +67,23 @@ CONFIGURE_ARGS+=--with-mpeg2-prefix=${LOCALBASE}
CONFIGURE_ARGS+=--disable-mpeg2
.endif
+.if defined(WITH_FLAC)
+LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+CONFIGURE_ARGS+=--with-flac-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-flac
+.endif
+
+.if defined(WITH_FLUIDSYNTH)
+LIB_DEPENDS+= fluidsynth.2:${PORTSDIR}/audio/fluidsynth
+CONFIGURE_ARGS+=--with-fluidsynth-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-fluidsynth
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/-O//' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's/-lfluidsynth/& -pthread/' ${WRKSRC}/configure
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/scummvm ${PREFIX}/bin