aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-10-30 04:41:06 +0800
committerdinoex <dinoex@FreeBSD.org>2011-10-30 04:41:06 +0800
commitfb60d4d56765a2c7a121d38b03a7594794705dee (patch)
treeba118cb587b5b1598f64e8ac1b20183209648b1e
parent3e48fd5170029e5f8a07a76c16a2233872b8f178 (diff)
downloadfreebsd-ports-gnome-fb60d4d56765a2c7a121d38b03a7594794705dee.tar.gz
freebsd-ports-gnome-fb60d4d56765a2c7a121d38b03a7594794705dee.tar.zst
freebsd-ports-gnome-fb60d4d56765a2c7a121d38b03a7594794705dee.zip
- fix build for FreeBSD-9
-rw-r--r--lang/libobjc2/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/lang/libobjc2/Makefile b/lang/libobjc2/Makefile
index 64980871feda..b39349f67722 100644
--- a/lang/libobjc2/Makefile
+++ b/lang/libobjc2/Makefile
@@ -43,7 +43,16 @@ CPPFLAGS+= -DGNUSTEP
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 900000
-BROKEN= does not compile on 9.X
+V:= 42
+_GCC_BUILD_DEPENDS:= gcc${V}
+_GCC_PORT_DEPENDS:= gcc${V}
+CC:= gcc${V}
+CXX:= g++${V}
+CPP:= cpp${V}
+LDFLAGS+= -rpath=${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}
+LDFLAGS+= -L${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}
+BUILD_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
+RUN_DEPENDS+= ${_GCC_PORT_DEPENDS}:${PORTSDIR}/lang/${_GCC_BUILD_DEPENDS}
.endif
.if (${ARCH} == i386) || (${ARCH} == i486)