aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-10-17 21:44:04 +0800
committermat <mat@FreeBSD.org>2013-10-17 21:44:04 +0800
commitfb64371d01d0d8cf488ddb717af3b15b209d72c3 (patch)
treefe277e6f8ab48839f1b34d75cd5fd2f10ed6edde
parent7124356d92300e2a5c4a9f69efefe4f4b12e668e (diff)
downloadfreebsd-ports-gnome-fb64371d01d0d8cf488ddb717af3b15b209d72c3.tar.gz
freebsd-ports-gnome-fb64371d01d0d8cf488ddb717af3b15b209d72c3.tar.zst
freebsd-ports-gnome-fb64371d01d0d8cf488ddb717af3b15b209d72c3.zip
Add p5-Bucardo 4.5.0, asynchronous PostgreSQL replication system.
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Bucardo/Makefile36
-rw-r--r--databases/p5-Bucardo/distinfo2
-rw-r--r--databases/p5-Bucardo/pkg-descr7
-rw-r--r--databases/p5-Bucardo/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 08cec2d58583..bc3b23c6a2fe 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -268,6 +268,7 @@
SUBDIR += p5-BDB
SUBDIR += p5-BSON
SUBDIR += p5-BerkeleyDB
+ SUBDIR += p5-Bucardo
SUBDIR += p5-CDB_File
SUBDIR += p5-CDB_File-Generator
SUBDIR += p5-Cache-BDB
diff --git a/databases/p5-Bucardo/Makefile b/databases/p5-Bucardo/Makefile
new file mode 100644
index 000000000000..fb40dbe775ec
--- /dev/null
+++ b/databases/p5-Bucardo/Makefile
@@ -0,0 +1,36 @@
+# Created by: Mathieu Arnold <mat@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= Bucardo
+PORTVERSION= 4.5.0
+CATEGORIES= databases perl5
+MASTER_SITES= http://bucardo.org/downloads/ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= mat/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Asynchronous PostgreSQL replication system
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= p5-DBI>=1.51:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-Pg>=2.0:${PORTSDIR}/databases/p5-DBD-Pg \
+ p5-DBIx-Safe>=1.2.4:${PORTSDIR}/databases/p5-DBIx-Safe
+RUN_DEPENDS= p5-DBI>=1.51:${PORTSDIR}/databases/p5-DBI \
+ p5-DBD-Pg>=2.0:${PORTSDIR}/databases/p5-DBD-Pg \
+ p5-DBIx-Safe>=1.2.4:${PORTSDIR}/databases/p5-DBIx-Safe
+
+USES= perl5
+USE_PERL5= configure
+
+post-patch:
+ @${REINPLACE_CMD} 's/INSTALL_BASE/DESTDIR/;s/bucardo_ctl.1pm/bucardo_ctl.1/' \
+ ${WRKSRC}/Makefile.PL
+ @${REINPLACE_CMD} 's=/usr/local=${PREFIX}=' ${WRKSRC}/Makefile.PL \
+ ${WRKSRC}/bucardo_ctl ${WRKSRC}/scripts/bucardo_ctl.rc
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/bucardo_ctl.rc ${STAGEDIR}${PREFIX}/etc/rc.d/bucardo
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Bucardo/distinfo b/databases/p5-Bucardo/distinfo
new file mode 100644
index 000000000000..77eeaa7a0b41
--- /dev/null
+++ b/databases/p5-Bucardo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Bucardo-4.5.0.tar.gz) = 15272b196f3c84c99a4662ca440e8a3b8299b8333e92cb43d1edcb14cac6a091
+SIZE (Bucardo-4.5.0.tar.gz) = 192027
diff --git a/databases/p5-Bucardo/pkg-descr b/databases/p5-Bucardo/pkg-descr
new file mode 100644
index 000000000000..476234647059
--- /dev/null
+++ b/databases/p5-Bucardo/pkg-descr
@@ -0,0 +1,7 @@
+Bucardo is an asynchronous PostgreSQL replication system, allowing for both
+multi-master and multi-slave operations. It was developed at Backcountry.com by
+Jon Jensen and Greg Sabino Mullane of End Point Corporation, and is now in use
+at many other organizations. Bucardo is free and open source software released
+under the BSD license.
+
+WWW: http://bucardo.org/wiki/Bucardo
diff --git a/databases/p5-Bucardo/pkg-plist b/databases/p5-Bucardo/pkg-plist
new file mode 100644
index 000000000000..f539a23982e5
--- /dev/null
+++ b/databases/p5-Bucardo/pkg-plist
@@ -0,0 +1,7 @@
+bin/bucardo_ctl
+etc/rc.d/bucardo
+%%PERL5_MAN3%%/Bucardo.3.gz
+%%SITE_PERL%%/Bucardo.pm
+man/man1/bucardo_ctl.1.gz
+share/bucardo/bucardo.schema
+@dirrm share/bucardo