aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2018-09-11 04:29:07 +0800
committersunpoet <sunpoet@FreeBSD.org>2018-09-11 04:29:07 +0800
commitfdb66089825d7414fe1cd9c38e8511fd0e1d3e7f (patch)
treed27ff1a4816b35a142efc49e811cae8e3a3752bf
parent1c256e59f7bd670964c1811a6e1e8a0fd2b5b220 (diff)
downloadfreebsd-ports-gnome-fdb66089825d7414fe1cd9c38e8511fd0e1d3e7f.tar.gz
freebsd-ports-gnome-fdb66089825d7414fe1cd9c38e8511fd0e1d3e7f.tar.zst
freebsd-ports-gnome-fdb66089825d7414fe1cd9c38e8511fd0e1d3e7f.zip
Convert to options target helper
Approved by: portmgr (blanket)
-rw-r--r--security/whatweb/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/whatweb/Makefile b/security/whatweb/Makefile
index 7f2488bde8d1..698c19cdb041 100644
--- a/security/whatweb/Makefile
+++ b/security/whatweb/Makefile
@@ -29,9 +29,6 @@ post-patch:
${WRKSRC}/whatweb
do-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
.for dir in addons lib my-plugins plugin-development plugins plugins-disabled
( cd ${WRKSRC}/${dir} && \
${COPYTREE_SHARE} . ${STAGEDIR}${RUBY_SITELIBDIR}/whatweb/${dir} )
@@ -39,4 +36,8 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/whatweb.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_SCRIPT} ${WRKSRC}/whatweb ${STAGEDIR}${PREFIX}/bin/whatweb
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>