aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-05-31 22:42:33 +0800
committersylvio <sylvio@FreeBSD.org>2010-05-31 22:42:33 +0800
commitfdd7997bd717435d13512b3de06dc38255172e54 (patch)
tree80325803cab5cfc425d36ac4e95cb35bf87202ff
parent2edce1f6c0668f3fcf81132a86624f5cc8709ebf (diff)
downloadfreebsd-ports-gnome-fdd7997bd717435d13512b3de06dc38255172e54.tar.gz
freebsd-ports-gnome-fdd7997bd717435d13512b3de06dc38255172e54.tar.zst
freebsd-ports-gnome-fdd7997bd717435d13512b3de06dc38255172e54.zip
- A small wrapper for AWK interpreter that helps to write
the standalone programs in AWK. It provides MODULES for AWK similar to PERL's "use" command and other powerful features. Dozens of ready to use modules are also provided. WWW: http://sourceforge.net/projects/runawk/ PR: ports/147208 Submitted by: Mikolaj Golub <to.my.trociny@gmail.com>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/runawk/Makefile34
-rw-r--r--devel/runawk/distinfo3
-rw-r--r--devel/runawk/pkg-descr7
-rw-r--r--devel/runawk/pkg-plist40
5 files changed, 85 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cbacc1506eb6..96cddc9adb0e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3055,6 +3055,7 @@
SUBDIR += rubygem-zoom
SUBDIR += rudeconfig
SUBDIR += rudiments
+ SUBDIR += runawk
SUBDIR += rvi
SUBDIR += rvm
SUBDIR += safestr
diff --git a/devel/runawk/Makefile b/devel/runawk/Makefile
new file mode 100644
index 000000000000..916c93633a7e
--- /dev/null
+++ b/devel/runawk/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: runawk
+# Date created: 30 May 2010
+# Whom: Mikolaj Golub <to.my.trociny@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= runawk
+PORTVERSION= 0.21.0
+CATEGORIES= devel
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= to.my.trociny@gmail.com
+COMMENT= Wrapper for AWK interpreter to write standalone programs in AWK
+
+MAN1= runawk.1
+MANCOMPRESSED= yes
+
+MAKE_ENV+= MANDIR=${PREFIX}/man/man NO_OBJ=yes
+
+PORTDOCS= ChangeLog NEWS README TODO
+
+pre-install:
+ @${MKDIR} ${PREFIX}/share/runawk
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/${docs} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/runawk/distinfo b/devel/runawk/distinfo
new file mode 100644
index 000000000000..51b83e137944
--- /dev/null
+++ b/devel/runawk/distinfo
@@ -0,0 +1,3 @@
+MD5 (runawk-0.21.0.tar.gz) = 31656c0203b72b13270119b0b1648a6a
+SHA256 (runawk-0.21.0.tar.gz) = adcbd85df9d3c7fced563a07acb53517195cb7da45a2ee828cb7bd41956090b9
+SIZE (runawk-0.21.0.tar.gz) = 58022
diff --git a/devel/runawk/pkg-descr b/devel/runawk/pkg-descr
new file mode 100644
index 000000000000..97800b88923c
--- /dev/null
+++ b/devel/runawk/pkg-descr
@@ -0,0 +1,7 @@
+A small wrapper for AWK interpreter that helps to write
+the standalone programs in AWK. It provides MODULES for AWK
+similar to PERL's "use" command and other powerful
+features. Dozens of ready to use modules are also provided.
+
+WWW: http://sourceforge.net/projects/runawk/
+Author: Aleksey Cheusov (cheusov at users.sourceforge.net)
diff --git a/devel/runawk/pkg-plist b/devel/runawk/pkg-plist
new file mode 100644
index 000000000000..ae2e70bb76fd
--- /dev/null
+++ b/devel/runawk/pkg-plist
@@ -0,0 +1,40 @@
+bin/runawk
+%%DATADIR%%/CR_in.awk
+%%DATADIR%%/abort.awk
+%%DATADIR%%/abs.awk
+%%DATADIR%%/alt_assert.awk
+%%DATADIR%%/alt_getopt.awk
+%%DATADIR%%/alt_join.awk
+%%DATADIR%%/backslash_in.awk
+%%DATADIR%%/basename.awk
+%%DATADIR%%/braceexpand.awk
+%%DATADIR%%/dirname.awk
+%%DATADIR%%/embed_str.awk
+%%DATADIR%%/exitnow.awk
+%%DATADIR%%/fieldwidths.awk
+%%DATADIR%%/has_prefix.awk
+%%DATADIR%%/has_suffix.awk
+%%DATADIR%%/heapsort.awk
+%%DATADIR%%/init_getopt.awk
+%%DATADIR%%/isnum.awk
+%%DATADIR%%/match_br.awk
+%%DATADIR%%/max.awk
+%%DATADIR%%/min.awk
+%%DATADIR%%/modinfo.awk
+%%DATADIR%%/multisub.awk
+%%DATADIR%%/pow.awk
+%%DATADIR%%/power_getopt.awk
+%%DATADIR%%/quicksort.awk
+%%DATADIR%%/readfile.awk
+%%DATADIR%%/runcmd.awk
+%%DATADIR%%/shquote.awk
+%%DATADIR%%/sort.awk
+%%DATADIR%%/str2regexp.awk
+%%DATADIR%%/tmpfile.awk
+%%DATADIR%%/tokenre.awk
+%%DATADIR%%/trim.awk
+%%DATADIR%%/trim_in.awk
+%%DATADIR%%/xclose.awk
+%%DATADIR%%/xgetline.awk
+%%DATADIR%%/xsystem.awk
+@dirrm %%DATADIR%%