aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2004-11-19 22:11:10 +0800
committerhq <hq@FreeBSD.org>2004-11-19 22:11:10 +0800
commitfe368eab42320401fbe0300bca4b73360c0b2a7f (patch)
tree5a40a9e960362b656c2d7be2c6c134060c39ee9c
parent4832f4edfde113129b5c0aa59bc231d8eae95a01 (diff)
downloadfreebsd-ports-gnome-fe368eab42320401fbe0300bca4b73360c0b2a7f.tar.gz
freebsd-ports-gnome-fe368eab42320401fbe0300bca4b73360c0b2a7f.tar.zst
freebsd-ports-gnome-fe368eab42320401fbe0300bca4b73360c0b2a7f.zip
dnsjava is an implementation of DNS in Java. It supports all defined record
types (including the DNSSEC types), and unknown types. It can be used for queries, zone transfers, and dynamic updates. It includes a cache which can be used by clients, and a minimal implementation of a server. It supports TSIG authenticated messages, partial DNSSEC verification, and EDNS0. dnsjava provides functionality above and beyond that of the InetAddress class. Since it is written in pure Java, dnsjava is fully threadable, and in many cases is faster than using InetAddress. dnsjava provides both high and low level access to DNS. The high level functions perform queries for records of a given name, type, and class, and return an array of records. There is also a clone of InetAddress, which is even simpler. A cache is used to reduce the number of DNS queries sent. The low level functions allow direct manipulation of DNS messages and records, as well as allowing additional resolver properties to be set. WWW: http://www.xbill.org/dnsjava/
-rw-r--r--dns/Makefile1
-rw-r--r--dns/dnsjava/Makefile54
-rw-r--r--dns/dnsjava/distinfo2
-rw-r--r--dns/dnsjava/pkg-descr18
4 files changed, 75 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index 14ae543e0046..b7ffea659022 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -22,6 +22,7 @@
SUBDIR += dnsdoctor
SUBDIR += dnsflood
SUBDIR += dnshijacker
+ SUBDIR += dnsjava
SUBDIR += dnsmasq
SUBDIR += dnsproxy
SUBDIR += dnssecwalker
diff --git a/dns/dnsjava/Makefile b/dns/dnsjava/Makefile
new file mode 100644
index 000000000000..1cb36af0d58e
--- /dev/null
+++ b/dns/dnsjava/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: dnsjava
+# Date created: 2004-11-19
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dnsjava
+PORTVERSION= 1.6.4
+CATEGORIES= dns java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Implementation of DNS in Java
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+
+USE_ANT= yes
+ALL_TARGET= jar
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= docsclean docs
+.endif
+
+SAMPLE_FILES= examples.html USAGE dig.java jnamed.java lookup.java update.java
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar ${SAMPLE_FILES:S,^,%%EXAMPLESDIR%%/,}
+PLIST_DIRS= %%EXAMPLESDIR%%
+.if !defined(NOPORTDOCS)
+OTHERDOCS= README Changelog
+PORTDOCS= apidocs ${OTHERDOCS}
+.endif
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}/..."
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${SAMPLE_FILES:S,^,${WRKSRC}/,} ${EXAMPLESDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}/..."
+ @cd ${WRKSRC}/doc \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/apidocs/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} ${WRKSRC}/doc/{} ${DOCSDIR}/apidocs/{} \;
+ @${INSTALL_DATA} ${OTHERDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/dns/dnsjava/distinfo b/dns/dnsjava/distinfo
new file mode 100644
index 000000000000..06910e53ee01
--- /dev/null
+++ b/dns/dnsjava/distinfo
@@ -0,0 +1,2 @@
+MD5 (dnsjava-1.6.4.tar.gz) = a9ace42685d1715da1419443bd20283a
+SIZE (dnsjava-1.6.4.tar.gz) = 329260
diff --git a/dns/dnsjava/pkg-descr b/dns/dnsjava/pkg-descr
new file mode 100644
index 000000000000..e4303b020c58
--- /dev/null
+++ b/dns/dnsjava/pkg-descr
@@ -0,0 +1,18 @@
+dnsjava is an implementation of DNS in Java. It supports all defined record
+types (including the DNSSEC types), and unknown types. It can be used for
+queries, zone transfers, and dynamic updates. It includes a cache which can be
+used by clients, and a minimal implementation of a server. It supports TSIG
+authenticated messages, partial DNSSEC verification, and EDNS0.
+
+dnsjava provides functionality above and beyond that of the InetAddress class.
+Since it is written in pure Java, dnsjava is fully threadable, and in many
+cases is faster than using InetAddress.
+
+dnsjava provides both high and low level access to DNS. The high level
+functions perform queries for records of a given name, type, and class, and
+return an array of records. There is also a clone of InetAddress, which is even
+simpler. A cache is used to reduce the number of DNS queries sent. The low
+level functions allow direct manipulation of DNS messages and records, as well
+as allowing additional resolver properties to be set.
+
+WWW: http://www.xbill.org/dnsjava/