aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-05-11 00:59:15 +0800
committerkwm <kwm@FreeBSD.org>2013-05-11 00:59:15 +0800
commitfe5d8e5630c64c525214304685a8fc0d3e4018ca (patch)
tree84f33c7157e2eb6e9b287c9cb0888cec8d05b28e
parent00d2ef2129239b39e19d7ddc6882642ad37d27b8 (diff)
downloadfreebsd-ports-gnome-fe5d8e5630c64c525214304685a8fc0d3e4018ca.tar.gz
freebsd-ports-gnome-fe5d8e5630c64c525214304685a8fc0d3e4018ca.tar.zst
freebsd-ports-gnome-fe5d8e5630c64c525214304685a8fc0d3e4018ca.zip
Also add USE_GCC=any as workaround for clang 3.3 crash on i386
-rw-r--r--multimedia/gstreamer1-plugins/Makefile3
-rw-r--r--multimedia/gstreamer1/Makefile2
2 files changed, 5 insertions, 0 deletions
diff --git a/multimedia/gstreamer1-plugins/Makefile b/multimedia/gstreamer1-plugins/Makefile
index b0db5d6574d1..967cb079e6bd 100644
--- a/multimedia/gstreamer1-plugins/Makefile
+++ b/multimedia/gstreamer1-plugins/Makefile
@@ -56,6 +56,9 @@ CFLAGS:= ${CFLAGS} -O2 -Wno-format
CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${EXTRA_LIBS} ${PTHREAD_LIBS}
+# workaround a crash in clang 3.3 crash llvm bug # 15840
+USE_GCC= any
+
DEFAULT_AUDIOSINK?= osssink
DEFAULT_AUDIOSRC?= osssrc
diff --git a/multimedia/gstreamer1/Makefile b/multimedia/gstreamer1/Makefile
index b93971b41351..7c89622f9683 100644
--- a/multimedia/gstreamer1/Makefile
+++ b/multimedia/gstreamer1/Makefile
@@ -19,6 +19,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/GLib-2.0.gir:${PORTSDIR}/devel/gobject-i
CFLAGS:= ${CFLAGS} -O2 -Wno-format
USES= bison gettext pathfix pkgconfig
+# workaround a crash in clang 3.3 crash llvm bug # 15840
+USE_GCC= any
USE_XZ= yes
USE_GMAKE= yes
MAKE_JOBS_SAVE= yes