aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2014-11-22 20:21:33 +0800
committerkuriyama <kuriyama@FreeBSD.org>2014-11-22 20:21:33 +0800
commitfe8caf6704bd1f1e48fc03d939e9ad06083c89b5 (patch)
tree349339c61a275d0c6b2ff417fde5e3a88f8f17f2
parentd421cb0a26372aff87ec7729326983a02aa368a1 (diff)
downloadfreebsd-ports-gnome-fe8caf6704bd1f1e48fc03d939e9ad06083c89b5.tar.gz
freebsd-ports-gnome-fe8caf6704bd1f1e48fc03d939e9ad06083c89b5.tar.zst
freebsd-ports-gnome-fe8caf6704bd1f1e48fc03d939e9ad06083c89b5.zip
- tiny cleanups.
PR: ports/194342 Submitted by: amdmi3@amdmi3.ru
-rw-r--r--databases/tokyocabinet/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/databases/tokyocabinet/Makefile b/databases/tokyocabinet/Makefile
index 6ee364c3e72b..f5f757a3c89e 100644
--- a/databases/tokyocabinet/Makefile
+++ b/databases/tokyocabinet/Makefile
@@ -4,13 +4,15 @@
PORTNAME= tokyocabinet
PORTVERSION= 1.4.48
CATEGORIES= databases
-MASTER_SITES= ${MASTER_SITE_LOCAL} \
+MASTER_SITES= LOCAL/kuriyama \
http://fallabs.com/${PORTNAME}/
-MASTER_SITE_SUBDIR= kuriyama
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Modern implementation of DBM
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
GNU_CONFIGURE= yes
USES= gmake
USE_LDCONFIG= yes
@@ -45,10 +47,10 @@ CONFIGURE_ARGS+= --enable-devel
.if ${PORT_OPTIONS:MFASTEST}
CONFIGURE_ARGS+= --enable-fastest
.endif
-# liblzma on 9-current does not have liblzma.h file.
+# to not confuse with system liblzma
.if ${PORT_OPTIONS:MLZMA}
CONFIGURE_ARGS+= --enable-exlzma
-LIB_DEPENDS+= liblzma.so:${PORTSDIR}/archivers/lzmalib
+LIB_DEPENDS+= liblzma.so.1:${PORTSDIR}/archivers/lzmalib
.else
CONFIGURE_ARGS+= --disable-exlzma
.endif
@@ -86,4 +88,8 @@ post-patch:
-e 's|@datarootdir@|@datarootdir@/doc|' \
${WRKSRC}/Makefile.in
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/* ${STAGEDIR}${PREFIX}/lib/*.so \
+ ${STAGEDIR}${PREFIX}/libexec/tcawmgr.cgi
+
.include <bsd.port.mk>