aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2014-07-08 22:30:27 +0800
committerkoobs <koobs@FreeBSD.org>2014-07-08 22:30:27 +0800
commitffbbbc149469360d2c715b1795e086fae07ed390 (patch)
tree8d5855050db436803beee2ff55011aec690740da
parentead50149153de45c9803c721630dca3c5eec2c45 (diff)
downloadfreebsd-ports-gnome-ffbbbc149469360d2c715b1795e086fae07ed390.tar.gz
freebsd-ports-gnome-ffbbbc149469360d2c715b1795e086fae07ed390.tar.zst
freebsd-ports-gnome-ffbbbc149469360d2c715b1795e086fae07ed390.zip
[NEW] sysutils/bsdploy: Container Management for FreeBSD Jails
BSDploy is a comprehensive tool to provision, configure and maintain FreeBSD jail hosts and jails. Its main design goal is to lower the barrier to repeatable jail setups. * Modular provisioning with plugins for VirtualBox, Amazon EC2 and an achitecture to support more. * Bootstrap complete jail hosts from scratch. * Declarative configuration: All hosts and their properties defined in ploy.conf are automatically exposed to Ansible. * Imperative maintenance: Run Fabric scripts with ploy do JAILNAME TASKNAME and have all of the hosts and their variables in fab.env. * Configure ZFS pools and filesystems with whole-disk-encryption. WWW: http://docs.bsdploy.net/
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/bsdploy/Makefile30
-rw-r--r--sysutils/bsdploy/distinfo2
-rw-r--r--sysutils/bsdploy/pkg-descr15
4 files changed, 48 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 0bc1501059c4..5619f7fd5c54 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -83,6 +83,7 @@
SUBDIR += bsdhwmon
SUBDIR += bsdinfo
SUBDIR += bsdmoted
+ SUBDIR += bsdploy
SUBDIR += bsdstats
SUBDIR += bubblemon-dockapp
SUBDIR += bulk_extractor
diff --git a/sysutils/bsdploy/Makefile b/sysutils/bsdploy/Makefile
new file mode 100644
index 000000000000..3ea0a45dc15a
--- /dev/null
+++ b/sysutils/bsdploy/Makefile
@@ -0,0 +1,30 @@
+# Created by: Kubilay Kocak <koobs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= bsdploy
+DISTVERSION= 1.0b4
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Container Management for FreeBSD Jails
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>0:${PORTSDIR}/devel/py-Jinja2 \
+ ${PYTHON_PKGNAMEPREFIX}liblzma>0:${PORTSDIR}/archivers/py-liblzma \
+ ${PYTHON_PKGNAMEPREFIX}ploy>=1.0.r13:${PORTSDIR}/sysutils/py-ploy \
+ ${PYTHON_PKGNAMEPREFIX}ploy_ansible>=1.0.b7:${PORTSDIR}/sysutils/py-ploy_ansible \
+ ${PYTHON_PKGNAMEPREFIX}ploy_ezjail>=1.0.b9:${PORTSDIR}/sysutils/py-ploy_ezjail \
+ ${PYTHON_PKGNAMEPREFIX}ploy_fabric>=1.0.b5:${PORTSDIR}/sysutils/py-ploy_fabric
+
+OPTIONS_DEFINE= EC2
+OPTIONS_DEFAULT= EC2
+EC2_DESC= Support Amazon Web Services EC2 hosts
+EC2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ploy_ec2>0:${PORTSDIR}/sysutils/py-ploy_ec2
+
+USES= zip
+USE_PYTHON= -2.7
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/bsdploy/distinfo b/sysutils/bsdploy/distinfo
new file mode 100644
index 000000000000..064735564918
--- /dev/null
+++ b/sysutils/bsdploy/distinfo
@@ -0,0 +1,2 @@
+SHA256 (bsdploy-1.0b4.zip) = c4a026bab828768cae4335463a56b7f95c898e5b9df50ae83b077731f3f1f0e2
+SIZE (bsdploy-1.0b4.zip) = 74038
diff --git a/sysutils/bsdploy/pkg-descr b/sysutils/bsdploy/pkg-descr
new file mode 100644
index 000000000000..4ee1068707fa
--- /dev/null
+++ b/sysutils/bsdploy/pkg-descr
@@ -0,0 +1,15 @@
+BSDploy is a comprehensive tool to provision, configure and maintain
+FreeBSD jail hosts and jails.
+
+Its main design goal is to lower the barrier to repeatable jail setups.
+
+ * Modular provisioning with plugins for VirtualBox, Amazon EC2 and
+ an achitecture to support more.
+ * Bootstrap complete jail hosts from scratch.
+ * Declarative configuration: All hosts and their properties defined
+ in ploy.conf are automatically exposed to Ansible.
+ * Imperative maintenance: Run Fabric scripts with ploy do JAILNAME
+ TASKNAME and have all of the hosts and their variables in fab.env.
+ * Configure ZFS pools and filesystems with whole-disk-encryption.
+
+WWW: http://docs.bsdploy.net/