aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2021-05-30 23:28:08 +0800
committerFukang Chen <loader@FreeBSD.org>2021-05-31 11:13:02 +0800
commitc0b8a1a40a6051f4ec185b527cc152be30555730 (patch)
tree7c682fe8cf89c5d37c75239d15717c7384968150
parent7e4ef0e97fa3c20970990a2349d76a78827b614a (diff)
downloadfreebsd-ports-gnome-c0b8a1a40a6051f4ec185b527cc152be30555730.tar.gz
freebsd-ports-gnome-c0b8a1a40a6051f4ec185b527cc152be30555730.tar.zst
freebsd-ports-gnome-c0b8a1a40a6051f4ec185b527cc152be30555730.zip
devel/py-reedsolo: [NEW PORT] Pure-Python Reed Solomon encoder/decoder
A pure-python universal errors-and-erasures Reed-Solomon Codec, based on the wonderful tutorial at wikiversity, written by "Bobmath" and "LRQ3000". WWW: https://github.com/tomerfiliba/reedsolomon Reviewed by: koobs Approved by: koobs (ports, mentor, implicit) Differential Revision: https://reviews.freebsd.org/D30551 MFH: No (Port does not exist in quarterly)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-reedsolo/Makefile28
-rw-r--r--devel/py-reedsolo/distinfo3
-rw-r--r--devel/py-reedsolo/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 982f8efe81c7..055246607c66 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5078,6 +5078,7 @@
SUBDIR += py-readme-renderer
SUBDIR += py-rebulk
SUBDIR += py-rednose
+ SUBDIR += py-reedsolo
SUBDIR += py-remote-pdb
SUBDIR += py-repoze.lru
SUBDIR += py-repoze.sphinx.autointerface
diff --git a/devel/py-reedsolo/Makefile b/devel/py-reedsolo/Makefile
new file mode 100644
index 000000000000..bd5a92166c56
--- /dev/null
+++ b/devel/py-reedsolo/Makefile
@@ -0,0 +1,28 @@
+PORTNAME= reedsolo
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.5.4
+CATEGORIES= devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= loader@FreeBSD.org
+COMMENT= Pure-Python Reed Solomon encoder/decoder
+
+LICENSE= PD
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_GITHUB= yes
+USE_PYTHON= autoplist cython distutils
+
+GH_ACCOUNT= tomerfiliba
+GH_PROJECT= reedsolomon
+TEST_ENV+= PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+do-test:
+ @cd ${TEST_WRKSRC} && \
+ ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER} --with-coverage -d -v
+
+.include <bsd.port.mk>
diff --git a/devel/py-reedsolo/distinfo b/devel/py-reedsolo/distinfo
new file mode 100644
index 000000000000..49824380bdc2
--- /dev/null
+++ b/devel/py-reedsolo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1622099282
+SHA256 (tomerfiliba-reedsolomon-v1.5.4_GH0.tar.gz) = cbe74633d1e3ff0f3b9c44fac06dff3355c622e93d4a0cd85116c909932af665
+SIZE (tomerfiliba-reedsolomon-v1.5.4_GH0.tar.gz) = 283778
diff --git a/devel/py-reedsolo/pkg-descr b/devel/py-reedsolo/pkg-descr
new file mode 100644
index 000000000000..951c414e2788
--- /dev/null
+++ b/devel/py-reedsolo/pkg-descr
@@ -0,0 +1,4 @@
+A pure-python universal errors-and-erasures Reed-Solomon Codec, based on
+the wonderful tutorial at wikiversity, written by "Bobmath" and "LRQ3000".
+
+WWW: https://github.com/tomerfiliba/reedsolomon