aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-11-02 23:56:12 +0800
committerwill <will@FreeBSD.org>2003-11-02 23:56:12 +0800
commit114c4db0ff29c50271cc31a2321873e611c23f3c (patch)
treeb21c0bf8fd0e53ee118e28cc72ee4778388683ad
parenta94db440ea666b33d4b53a3c5d21246e4638fac2 (diff)
downloadfreebsd-ports-gnome-114c4db0ff29c50271cc31a2321873e611c23f3c.tar.gz
freebsd-ports-gnome-114c4db0ff29c50271cc31a2321873e611c23f3c.tar.zst
freebsd-ports-gnome-114c4db0ff29c50271cc31a2321873e611c23f3c.zip
Switch to a more scalable and better method of hacking the pthread stuff
in for -CURRENT (essentially, reinplace). This method was originally believed not to work, but it was simply missing the ltmain.sh fix. This should allow third-party apps to be fixed without needing to put the same snippet everywhere. Not to mention getting rid of the patches.
-rw-r--r--x11/kde3/Makefile.kde18
-rw-r--r--x11/kde4/Makefile.kde18
2 files changed, 14 insertions, 22 deletions
diff --git a/x11/kde3/Makefile.kde b/x11/kde3/Makefile.kde
index 611f52ea17e3..85bdc20e1112 100644
--- a/x11/kde3/Makefile.kde
+++ b/x11/kde3/Makefile.kde
@@ -97,19 +97,15 @@ _NO_KDE_FIXPTHREAD= yes
.endif
.if !defined(_NO_KDE_FIXPTHREAD)
-PTHFIX_DATE?= 2003092201
-MASTER_SITES+= http://www.fruitsalad.org/patches/:kde \
- ${MASTER_SITE_KDE_kde:S,src,FreeBSD/patches,g}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-${PTHFIX_DATE}-configure.tar.bz2:kde
-PATCH_SITES+= http://www.fruitsalad.org/patches/:kde \
- ${MASTER_SITE_KDE_kde:S,src,FreeBSD/patches,g}
-PATCHFILES+= patch-ltmain.sh:kde
USE_REINPLACE= yes
-pre-configure: fix-pedantic
-fix-pedantic:
- @${REINPLACE_CMD} "s,-pedantic,,g" ${WRKSRC}/configure
+pre-configure: kde-fix-configure kde-fix-ltmain.sh
+kde-fix-configure:
+ ${REINPLACE_CMD} "s,-pedantic,,g; \
+ s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+kde-fix-ltmain.sh:
+ ${REINPLACE_CMD} "s, | .*freebsd\*)$$,*),g" ${WRKSRC}/admin/ltmain.sh
.endif
kde-version-check:
diff --git a/x11/kde4/Makefile.kde b/x11/kde4/Makefile.kde
index 611f52ea17e3..85bdc20e1112 100644
--- a/x11/kde4/Makefile.kde
+++ b/x11/kde4/Makefile.kde
@@ -97,19 +97,15 @@ _NO_KDE_FIXPTHREAD= yes
.endif
.if !defined(_NO_KDE_FIXPTHREAD)
-PTHFIX_DATE?= 2003092201
-MASTER_SITES+= http://www.fruitsalad.org/patches/:kde \
- ${MASTER_SITE_KDE_kde:S,src,FreeBSD/patches,g}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}-${PTHFIX_DATE}-configure.tar.bz2:kde
-PATCH_SITES+= http://www.fruitsalad.org/patches/:kde \
- ${MASTER_SITE_KDE_kde:S,src,FreeBSD/patches,g}
-PATCHFILES+= patch-ltmain.sh:kde
USE_REINPLACE= yes
-pre-configure: fix-pedantic
-fix-pedantic:
- @${REINPLACE_CMD} "s,-pedantic,,g" ${WRKSRC}/configure
+pre-configure: kde-fix-configure kde-fix-ltmain.sh
+kde-fix-configure:
+ ${REINPLACE_CMD} "s,-pedantic,,g; \
+ s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+kde-fix-ltmain.sh:
+ ${REINPLACE_CMD} "s, | .*freebsd\*)$$,*),g" ${WRKSRC}/admin/ltmain.sh
.endif
kde-version-check: