aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2005-10-12 02:25:56 +0800
committerlofi <lofi@FreeBSD.org>2005-10-12 02:25:56 +0800
commit125dab80ee97bd58cac554c60b97ea5e7ae3d5db (patch)
tree0e3f25999da2c39b3a17d9a658912e99a15478ea
parent3ac95f9fea178d9b1358acbc262b2f20cf8ee1be (diff)
downloadfreebsd-ports-gnome-125dab80ee97bd58cac554c60b97ea5e7ae3d5db.tar.gz
freebsd-ports-gnome-125dab80ee97bd58cac554c60b97ea5e7ae3d5db.tar.zst
freebsd-ports-gnome-125dab80ee97bd58cac554c60b97ea5e7ae3d5db.zip
Fix build on 4.x
-rw-r--r--audio/nas/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/nas/Makefile b/audio/nas/Makefile
index 2e6a3a80d94e..77760afebfc8 100644
--- a/audio/nas/Makefile
+++ b/audio/nas/Makefile
@@ -20,9 +20,14 @@ INSTALLS_SHLIB= yes
CFLAGS+= -Werror
MAKE_ENV+= COMPRESS_CMD="${COMPRESS_CMD:S/c//}"
+.include <bsd.port.pre.mk>
post-patch:
@${FIND} ${WRKSRC} -name '*.c' | ${XARGS} ${GREP} -lF malloc.h \
| ${XARGS} ${REINPLACE_CMD} -n -e "s|<malloc.h>||" -e t -e p
+.if ${OSVERSION} < 500027
+ @${FIND} ${WRKSRC} | ${XARGS} ${GREP} -lF stdint.h \
+ | ${XARGS} ${REINPLACE_CMD} -e "s|<stdint.h>|<inttypes.h>|g"
+.endif
post-configure:
# Work around shortcomings of the Image.rules et. al:
@@ -35,7 +40,6 @@ post-install:
@${SED} -e 's:/usr/X11R6:${PREFIX}:g' ${PKGMESSAGE}
.include "Makefile.man"
-.include <bsd.port.pre.mk>
.if ${ARCH} == "sparc64"
FPIC= -fPIC