aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2004-12-03 00:21:30 +0800
committerperky <perky@FreeBSD.org>2004-12-03 00:21:30 +0800
commit13c52773cf5ce4b87981c57fe2070712b70d0025 (patch)
tree2d8dba46f872f8f054e0cecb521988111cb318ca
parent0b5125407018265459e0ed746fd9565236a418e7 (diff)
downloadfreebsd-ports-gnome-13c52773cf5ce4b87981c57fe2070712b70d0025.tar.gz
freebsd-ports-gnome-13c52773cf5ce4b87981c57fe2070712b70d0025.tar.zst
freebsd-ports-gnome-13c52773cf5ce4b87981c57fe2070712b70d0025.zip
Fix build on Python 2.4.
Spotted by: kris
-rw-r--r--www/zope/Makefile6
-rw-r--r--www/zope210/Makefile6
-rw-r--r--www/zope211/Makefile6
-rw-r--r--www/zope213/Makefile6
-rw-r--r--www/zope28/Makefile6
-rw-r--r--www/zope29/Makefile6
6 files changed, 24 insertions, 12 deletions
diff --git a/www/zope/Makefile b/www/zope/Makefile
index 1c4a6cdc148d..77be1f829595 100644
--- a/www/zope/Makefile
+++ b/www/zope/Makefile
@@ -17,7 +17,7 @@ COMMENT= An object-based web application platform
BUILD_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_xmlplus/sax/expatreader.py:${PORTSDIR}/textproc/py-xml
-USE_PYTHON= yes
+USE_PYTHON= 2.3-
USE_RC_SUBR= yes
USE_REINPLACE= yes
DIST_SUBDIR= zope
@@ -63,7 +63,9 @@ ISBATCH= ""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\)\(.*"\)$$,\1 2.3.4 \2,g' \
+ @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(TARGET="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(EXENAMES="\).*"$$,\1${PYTHON_VERSION}",g' \
${WRKSRC}/configure
post-install:
diff --git a/www/zope210/Makefile b/www/zope210/Makefile
index 1c4a6cdc148d..77be1f829595 100644
--- a/www/zope210/Makefile
+++ b/www/zope210/Makefile
@@ -17,7 +17,7 @@ COMMENT= An object-based web application platform
BUILD_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_xmlplus/sax/expatreader.py:${PORTSDIR}/textproc/py-xml
-USE_PYTHON= yes
+USE_PYTHON= 2.3-
USE_RC_SUBR= yes
USE_REINPLACE= yes
DIST_SUBDIR= zope
@@ -63,7 +63,9 @@ ISBATCH= ""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\)\(.*"\)$$,\1 2.3.4 \2,g' \
+ @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(TARGET="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(EXENAMES="\).*"$$,\1${PYTHON_VERSION}",g' \
${WRKSRC}/configure
post-install:
diff --git a/www/zope211/Makefile b/www/zope211/Makefile
index 1c4a6cdc148d..77be1f829595 100644
--- a/www/zope211/Makefile
+++ b/www/zope211/Makefile
@@ -17,7 +17,7 @@ COMMENT= An object-based web application platform
BUILD_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_xmlplus/sax/expatreader.py:${PORTSDIR}/textproc/py-xml
-USE_PYTHON= yes
+USE_PYTHON= 2.3-
USE_RC_SUBR= yes
USE_REINPLACE= yes
DIST_SUBDIR= zope
@@ -63,7 +63,9 @@ ISBATCH= ""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\)\(.*"\)$$,\1 2.3.4 \2,g' \
+ @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(TARGET="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(EXENAMES="\).*"$$,\1${PYTHON_VERSION}",g' \
${WRKSRC}/configure
post-install:
diff --git a/www/zope213/Makefile b/www/zope213/Makefile
index 1c4a6cdc148d..77be1f829595 100644
--- a/www/zope213/Makefile
+++ b/www/zope213/Makefile
@@ -17,7 +17,7 @@ COMMENT= An object-based web application platform
BUILD_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_xmlplus/sax/expatreader.py:${PORTSDIR}/textproc/py-xml
-USE_PYTHON= yes
+USE_PYTHON= 2.3-
USE_RC_SUBR= yes
USE_REINPLACE= yes
DIST_SUBDIR= zope
@@ -63,7 +63,9 @@ ISBATCH= ""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\)\(.*"\)$$,\1 2.3.4 \2,g' \
+ @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(TARGET="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(EXENAMES="\).*"$$,\1${PYTHON_VERSION}",g' \
${WRKSRC}/configure
post-install:
diff --git a/www/zope28/Makefile b/www/zope28/Makefile
index 1c4a6cdc148d..77be1f829595 100644
--- a/www/zope28/Makefile
+++ b/www/zope28/Makefile
@@ -17,7 +17,7 @@ COMMENT= An object-based web application platform
BUILD_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_xmlplus/sax/expatreader.py:${PORTSDIR}/textproc/py-xml
-USE_PYTHON= yes
+USE_PYTHON= 2.3-
USE_RC_SUBR= yes
USE_REINPLACE= yes
DIST_SUBDIR= zope
@@ -63,7 +63,9 @@ ISBATCH= ""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\)\(.*"\)$$,\1 2.3.4 \2,g' \
+ @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(TARGET="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(EXENAMES="\).*"$$,\1${PYTHON_VERSION}",g' \
${WRKSRC}/configure
post-install:
diff --git a/www/zope29/Makefile b/www/zope29/Makefile
index 1c4a6cdc148d..77be1f829595 100644
--- a/www/zope29/Makefile
+++ b/www/zope29/Makefile
@@ -17,7 +17,7 @@ COMMENT= An object-based web application platform
BUILD_DEPENDS+= ${LOCALBASE}/lib/${PYTHON_VERSION}/site-packages/_xmlplus/sax/expatreader.py:${PORTSDIR}/textproc/py-xml
-USE_PYTHON= yes
+USE_PYTHON= 2.3-
USE_RC_SUBR= yes
USE_REINPLACE= yes
DIST_SUBDIR= zope
@@ -63,7 +63,9 @@ ISBATCH= ""
.endif
post-patch:
- @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\)\(.*"\)$$,\1 2.3.4 \2,g' \
+ @${REINPLACE_CMD} -e 's,^\(ACCEPTABLE="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(TARGET="\).*"$$,\1${PYTHON_PORTVERSION}",g' \
+ -e 's,^\(EXENAMES="\).*"$$,\1${PYTHON_VERSION}",g' \
${WRKSRC}/configure
post-install: