aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-10-20 16:29:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-10-20 16:29:15 +0800
commit1ed8db2fe561d4038a70141b9529c409752b767b (patch)
tree0f8a91d452b43260a5728dcb106721d5699001cc
parent08d0b9a31637805518d1a82691189008b07e5ea7 (diff)
downloadfreebsd-ports-gnome-1ed8db2fe561d4038a70141b9529c409752b767b.tar.gz
freebsd-ports-gnome-1ed8db2fe561d4038a70141b9529c409752b767b.tar.zst
freebsd-ports-gnome-1ed8db2fe561d4038a70141b9529c409752b767b.zip
- Cosmetic change:
- Reorder knobs - Indent using tabstop=4
-rw-r--r--Mk/Uses/perl5.mk41
1 files changed, 20 insertions, 21 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 25bc9dd66503..51c8f4847c10 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -150,10 +150,10 @@ _USES_POST+= perl5
_INCLUDE_USES_PERL5_POST_MK= yes
PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
- PERL_VER=${PERL_VER} \
- PERL_ARCH=${PERL_ARCH} \
- PERL5_MAN3=lib/perl5/${PERL_VER}/man/man3 \
- SITE_PERL=${SITE_PERL_REL}
+ PERL_VER=${PERL_VER} \
+ PERL_ARCH=${PERL_ARCH} \
+ PERL5_MAN3=lib/perl5/${PERL_VER}/man/man3 \
+ SITE_PERL=${SITE_PERL_REL}
# handle perl5 specific manpages
.for sect in 3
@@ -164,35 +164,34 @@ _MANPAGES+= ${P5MAN${sect}:S%^%${PREFIX}/lib/perl5/${PERL_VER}/man/man${sect}/%}
MANDIRS+= ${PREFIX}/lib/perl5/${PERL_VER}
.if ${_USE_PERL5:Mmodbuild} || ${_USE_PERL5:Mmodbuildtiny}
-_USE_PERL5+= configure
+_USE_PERL5+= configure
+ALL_TARGET?= # empty
+CONFIGURE_ARGS+=--install_path lib="${PREFIX}/${SITE_PERL_REL}" \
+ --install_path arch="${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}" \
+ --install_path script="${PREFIX}/bin" \
+ --install_path bin="${PREFIX}/bin" \
+ --install_path libdoc="${MAN3PREFIX}/man/man3" \
+ --install_path bindoc="${MAN1PREFIX}/man/man1"
CONFIGURE_SCRIPT?= Build.PL
+PL_BUILD?= Build
+.if !defined(NO_STAGE)
+CONFIGURE_ARGS+=--destdir ${STAGEDIR}
+DESTDIRNAME= --destdir
+.endif
.if ${_USE_PERL5:Mmodbuild}
.if ${PORTNAME} != Module-Build
-BUILD_DEPENDS+= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
+BUILD_DEPENDS+= ${SITE_PERL}/Module/Build.pm:${PORTSDIR}/devel/p5-Module-Build
.endif
CONFIGURE_ARGS+=--create_packlist 0
.endif
.if ${_USE_PERL5:Mmodbuildtiny}
.if ${PORTNAME} != Module-Build-Tiny
-BUILD_DEPENDS+= ${SITE_PERL}/Module/Build/Tiny.pm:${PORTSDIR}/devel/p5-Module-Build-Tiny
+BUILD_DEPENDS+= ${SITE_PERL}/Module/Build/Tiny.pm:${PORTSDIR}/devel/p5-Module-Build-Tiny
.endif
CONFIGURE_ARGS+=--create_packlist 1
.endif
-ALL_TARGET?=
-PL_BUILD?= Build
-CONFIGURE_ARGS+= \
- --install_path lib="${PREFIX}/${SITE_PERL_REL}" \
- --install_path arch="${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}" \
- --install_path script="${PREFIX}/bin" \
- --install_path bin="${PREFIX}/bin" \
- --install_path libdoc="${MAN3PREFIX}/man/man3" \
- --install_path bindoc="${MAN1PREFIX}/man/man1"
-.if !defined(NO_STAGE)
-CONFIGURE_ARGS+=--destdir ${STAGEDIR}
-DESTDIRNAME= --destdir
-.endif
.elif ${_USE_PERL5:Mconfigure}
-CONFIGURE_ARGS+= INSTALLDIRS="site"
+CONFIGURE_ARGS+=INSTALLDIRS="site"
.endif # modbuild
.if ${_USE_PERL5:Mconfigure}