aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornork <nork@FreeBSD.org>2007-12-15 19:46:43 +0800
committernork <nork@FreeBSD.org>2007-12-15 19:46:43 +0800
commit216e8753f81ac30f34e90f1e627d8ed3d96b3453 (patch)
tree92036b529c525a1a07e8d9982cf47ddec55e7e66
parentd7709db287aadf4bb06ffdd48b9e0da2b21a2bfd (diff)
downloadfreebsd-ports-gnome-216e8753f81ac30f34e90f1e627d8ed3d96b3453.tar.gz
freebsd-ports-gnome-216e8753f81ac30f34e90f1e627d8ed3d96b3453.tar.zst
freebsd-ports-gnome-216e8753f81ac30f34e90f1e627d8ed3d96b3453.zip
Add laughingman 0.20070610, is a real-time face hijacking program
made by the ultimate hacker Aoi a.k.a. The Laughing Man. Tested by: ume HW leased by: ume Committed at: the Kanto region BUGs joint year-end party 2007 in Akihabara, Tokyo, Japan
-rw-r--r--games/Makefile1
-rw-r--r--games/laughingman/Makefile34
-rw-r--r--games/laughingman/distinfo3
-rw-r--r--games/laughingman/files/Makefile23
-rw-r--r--games/laughingman/files/patch-laugh.cpp13
-rw-r--r--games/laughingman/pkg-descr10
-rw-r--r--games/laughingman/pkg-plist4
7 files changed, 88 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 8dfa5b8b0574..d0312ac82177 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -395,6 +395,7 @@
SUBDIR += ladder
SUBDIR += lapispuzzle
SUBDIR += latrine
+ SUBDIR += laughingman
SUBDIR += lbreakout
SUBDIR += lbreakout2
SUBDIR += ldmud
diff --git a/games/laughingman/Makefile b/games/laughingman/Makefile
new file mode 100644
index 000000000000..52699306e680
--- /dev/null
+++ b/games/laughingman/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: laughingman
+# Date created: 2007-07-13
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= laughingman
+PORTVERSION= 0.20070610
+CATEGORIES= games multimedia graphics
+MASTER_SITES= http://www.masayashi.com/wp-content/uploads/2007/04/
+DISTNAME= LaughingMan_proj
+EXTRACT_SUFX= .lzh
+DIST_SUBDIR= ${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= A real-time face hijacking program made by the ultimate hacker Aoi
+
+LIB_DEPENDS= cv.1:${PORTSDIR}/graphics/opencv
+EXTRACT_DEPENDS=lha:${PORTSDIR}/archivers/lha
+
+EXTRACT_CMD= lha
+EXTRACT_BEFORE_ARGS=xiq2
+EXTRACT_AFTER_ARGS=
+
+NO_WRKSUBDIR= yes
+
+MAKE_ENV+= BINDIR=${PREFIX}/bin \
+ DATADIR=${DATADIR}
+
+post-extract:
+ @${CP} ${FILESDIR}/Makefile ${WRKSRC}
+
+.include <bsd.port.mk>
diff --git a/games/laughingman/distinfo b/games/laughingman/distinfo
new file mode 100644
index 000000000000..e4791862c9d7
--- /dev/null
+++ b/games/laughingman/distinfo
@@ -0,0 +1,3 @@
+MD5 (laughingman/0.20070610/LaughingMan_proj.lzh) = ed252f73542b4ac88d640ebf6373b028
+SHA256 (laughingman/0.20070610/LaughingMan_proj.lzh) = 6d97604d19e2495e328c6681ece3bfdb00d7a17462a0fe78eb94fd7ed1e0c026
+SIZE (laughingman/0.20070610/LaughingMan_proj.lzh) = 127891
diff --git a/games/laughingman/files/Makefile b/games/laughingman/files/Makefile
new file mode 100644
index 000000000000..ffa966231234
--- /dev/null
+++ b/games/laughingman/files/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PROG_CXX= laugh
+SRCS= laugh.cpp
+NO_MAN= yes
+LDADD= -L${LOCALBASE}/lib -lcv -lcxcore -lhighgui
+
+LOCALBASE?= /usr/local
+PREFIX?= ${LOCALBASE}
+BINDIR?= ${PREFIX}/bin
+DATADIR?= ${PREFIX}/share/laughingman
+
+CXXFLAGS+= -DDATADIR=\"${DATADIR}\" -I${LOCALBASE}/include -I${LOCALBASE}/include/opencv
+
+FILES= haarcascade_frontalface_alt.xml laughingman.bmp
+FILESDIR= ${DATADIR}
+
+MKDIR?= mkdir -p
+
+beforeinstall:
+ ${MKDIR} ${FILESDIR}
+
+.include <bsd.prog.mk>
diff --git a/games/laughingman/files/patch-laugh.cpp b/games/laughingman/files/patch-laugh.cpp
new file mode 100644
index 000000000000..af7e97a949ae
--- /dev/null
+++ b/games/laughingman/files/patch-laugh.cpp
@@ -0,0 +1,13 @@
+--- laugh.cpp.orig 2007-02-25 13:36:50.000000000 +0900
++++ laugh.cpp 2007-07-13 01:22:50.000000000 +0900
+@@ -117,8 +117,8 @@
+ IplImage *frame_copy;
+ IplImage *result;
+ char window_name[] = "Catcher in the Rye";
+- const char* cascade_name = "haarcascade_frontalface_alt.xml"; //顔検出用のデータが入ってるXMLファイル
+- char mask_name[]="laughingman.bmp"; //マスク画像
++ const char* cascade_name = DATADIR "/haarcascade_frontalface_alt.xml"; //顔検出用のデータが入ってるXMLファイル
++ char mask_name[]=DATADIR "/laughingman.bmp"; //マスク画像
+
+ //顔検出データを読み込む
+ cascade = (CvHaarClassifierCascade*)cvLoad(cascade_name, 0, 0, 0);
diff --git a/games/laughingman/pkg-descr b/games/laughingman/pkg-descr
new file mode 100644
index 000000000000..c3c24cdf943b
--- /dev/null
+++ b/games/laughingman/pkg-descr
@@ -0,0 +1,10 @@
+The Laughing Man is a real-time face hijacking multiple video streams
+simultaneously made by the ultimate hacker Aoi.
+
+SEE ALSO:
+ http://en.wikipedia.org/wiki/Laughing_Man_%28Ghost_in_the_Shell%29
+
+Sorry, Japanese Only!
+WWW: http://www.masayashi.com/labs/laughing_man/
+ http://www1.bbiq.jp/kougaku/koukaku.html
+ http://www.kokaku-s.com/
diff --git a/games/laughingman/pkg-plist b/games/laughingman/pkg-plist
new file mode 100644
index 000000000000..0a451501a017
--- /dev/null
+++ b/games/laughingman/pkg-plist
@@ -0,0 +1,4 @@
+bin/laugh
+%%DATADIR%%/haarcascade_frontalface_alt.xml
+%%DATADIR%%/laughingman.bmp
+@dirrm %%DATADIR%%