aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2009-01-17 23:42:57 +0800
committerchinsan <chinsan@FreeBSD.org>2009-01-17 23:42:57 +0800
commit27257bb858659f8f512af4229ba0062bdd2cad37 (patch)
tree8b16bafd5bb8a6ce5ca6bb5aab992f62808fafb8
parent407b8ca7d8d2a83019461175509db897e7024570 (diff)
downloadfreebsd-ports-gnome-27257bb858659f8f512af4229ba0062bdd2cad37.tar.gz
freebsd-ports-gnome-27257bb858659f8f512af4229ba0062bdd2cad37.tar.zst
freebsd-ports-gnome-27257bb858659f8f512af4229ba0062bdd2cad37.zip
Add p5-Sane, Perl bindings for the SANE (Scanner Access Now Easy) Project.
This module allows you to access SANE-compatible scanners in a Perlish and object-oriented way, freeing you from the casting and memory management in C, yet remaining very close in spirit to original API. The Sane module allows a Perl developer to use SANE-compatible scanners. Find out more about SANE at http://www.sane-project.org. WWW: http://search.cpan.org/dist/Sane/
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Sane/Makefile26
-rw-r--r--graphics/p5-Sane/distinfo3
-rw-r--r--graphics/p5-Sane/files/patch-Makefile.PL11
-rw-r--r--graphics/p5-Sane/pkg-descr9
-rw-r--r--graphics/p5-Sane/pkg-plist5
6 files changed, 55 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 53b45801a036..668748eb2e52 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -571,6 +571,7 @@
SUBDIR += p5-SVG-Metadata
SUBDIR += p5-SWF-Builder
SUBDIR += p5-SWF-File
+ SUBDIR += p5-Sane
SUBDIR += p5-SpringGraph
SUBDIR += p5-Tk-JPEG-Lite
SUBDIR += p5-VCG
diff --git a/graphics/p5-Sane/Makefile b/graphics/p5-Sane/Makefile
new file mode 100644
index 000000000000..70473005c7a8
--- /dev/null
+++ b/graphics/p5-Sane/Makefile
@@ -0,0 +1,26 @@
+# Ports collection makefile for: Sane
+# Date created: 2009/01/12
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sane
+PORTVERSION= 0.02
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/R/RA/RATCLIFFE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Perl extension for the SANE (Scanner Access Now Easy) Project
+
+BUILD_DEPENDS= ${SITE_PERL}/ExtUtils/Depends.pm:${PORTSDIR}/devel/p5-ExtUtils-Depends \
+ p5-ExtUtils-PkgConfig>=1.03:${PORTSDIR}/devel/p5-ExtUtils-PkgConfig \
+ sane-config:${PORTSDIR}/graphics/sane-backends
+
+PERL_CONFIGURE= YES
+
+MAN3= Sane.3 \
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Sane/distinfo b/graphics/p5-Sane/distinfo
new file mode 100644
index 000000000000..5c7146dc58c6
--- /dev/null
+++ b/graphics/p5-Sane/distinfo
@@ -0,0 +1,3 @@
+MD5 (Sane-0.02.tar.gz) = 03fa0ad2a50e18598d91f197924fb54d
+SHA256 (Sane-0.02.tar.gz) = 8ef815ad55812495dfa29cd3bc58ebe9e5a2de439e0e8fa4f653e99169d5fe19
+SIZE (Sane-0.02.tar.gz) = 38148
diff --git a/graphics/p5-Sane/files/patch-Makefile.PL b/graphics/p5-Sane/files/patch-Makefile.PL
new file mode 100644
index 000000000000..46c0b7f79e09
--- /dev/null
+++ b/graphics/p5-Sane/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.orig 2009-01-17 23:24:51.000000000 +0800
++++ Makefile.PL 2009-01-17 23:25:01.000000000 +0800
+@@ -16,7 +16,7 @@
+ # Can't assume ExtUtils::PkgConfig will return anything useful until
+ # the pkg-config files ship with sane.
+ my $lib = '-lsane';
+-my $inc = '-I. ';
++my $inc = '-I. -I${LOCALBASE}/include';
+ if (eval {
+ %pkgcfg = ExtUtils::PkgConfig->find ('sane-backends >= '. $build_reqs{libsane})
+ }) {
diff --git a/graphics/p5-Sane/pkg-descr b/graphics/p5-Sane/pkg-descr
new file mode 100644
index 000000000000..2e84e974123d
--- /dev/null
+++ b/graphics/p5-Sane/pkg-descr
@@ -0,0 +1,9 @@
+Perl bindings for the SANE (Scanner Access Now Easy) Project. This module
+allows you to access SANE-compatible scanners in a Perlish and
+object-oriented way, freeing you from the casting and memory management in
+C, yet remaining very close in spirit to original API.
+
+The Sane module allows a Perl developer to use SANE-compatible scanners.
+Find out more about SANE at http://www.sane-project.org.
+
+WWW: http://search.cpan.org/dist/Sane/
diff --git a/graphics/p5-Sane/pkg-plist b/graphics/p5-Sane/pkg-plist
new file mode 100644
index 000000000000..e4a46715a33d
--- /dev/null
+++ b/graphics/p5-Sane/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sane/Sane.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sane/Sane.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Sane/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Sane.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Sane