aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlifanov <lifanov@FreeBSD.org>2017-01-22 02:56:58 +0800
committerlifanov <lifanov@FreeBSD.org>2017-01-22 02:56:58 +0800
commit2799633cee1cad72342803bf49b57ba256624c86 (patch)
tree7bca0be91059304bbe774c5b9952e59e5691c78a
parent31d40b7ebad33f26d7885421d0d30d72866246ac (diff)
downloadfreebsd-ports-gnome-2799633cee1cad72342803bf49b57ba256624c86.tar.gz
freebsd-ports-gnome-2799633cee1cad72342803bf49b57ba256624c86.tar.zst
freebsd-ports-gnome-2799633cee1cad72342803bf49b57ba256624c86.zip
add security/openconnect-gui: Graphical Openconnect Client
PR: 212879 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Reviewed by: matthew Approved by: matthew (mentor) Differential Revision: https://reviews.freebsd.org/D9256
-rw-r--r--security/Makefile1
-rw-r--r--security/openconnect-gui/Makefile33
-rw-r--r--security/openconnect-gui/distinfo3
-rw-r--r--security/openconnect-gui/files/patch-src_vpninfo.cpp11
-rw-r--r--security/openconnect-gui/files/patch-src_vpninfo.h11
-rw-r--r--security/openconnect-gui/pkg-descr4
6 files changed, 63 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 66a01cc79f4f..236283d036fa 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -406,6 +406,7 @@
SUBDIR += openca-tools-forked
SUBDIR += opencdk
SUBDIR += openconnect
+ SUBDIR += openconnect-gui
SUBDIR += opencryptoki
SUBDIR += openct
SUBDIR += openiked
diff --git a/security/openconnect-gui/Makefile b/security/openconnect-gui/Makefile
new file mode 100644
index 000000000000..7faf446e7c18
--- /dev/null
+++ b/security/openconnect-gui/Makefile
@@ -0,0 +1,33 @@
+# Created by: Piotr Kubaj <pkubaj@anongoth.pl>
+# $FreeBSD$
+
+PORTNAME= openconnect-gui
+PORTVERSION= 1.4.1
+DISTVERSIONPREFIX=v
+CATEGORIES= security
+
+MAINTAINER= pkubaj@anongoth.pl
+COMMENT= Graphical OpenConnect client
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= openconnect:security/openconnect
+LIB_DEPENDS= libgnutls.so:security/gnutls
+RUN_DEPENDS= openconnect:security/openconnect
+
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME:C/-gui//}
+
+USES= cmake pkgconfig
+USE_QT5= buildtools_build concurrent core gui network qmake_build widgets
+CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=Release
+PLIST_FILES= bin/openconnect-gui
+
+do-install:
+ ${MV} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/openconnect-gui/distinfo b/security/openconnect-gui/distinfo
new file mode 100644
index 000000000000..83d6b5f23d29
--- /dev/null
+++ b/security/openconnect-gui/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1484925231
+SHA256 (openconnect-openconnect-gui-v1.4.1_GH0.tar.gz) = 5f609e10eafc8885699e503c1dca9d9154d18741cfd09c1222d05b8af448c1d1
+SIZE (openconnect-openconnect-gui-v1.4.1_GH0.tar.gz) = 10026785
diff --git a/security/openconnect-gui/files/patch-src_vpninfo.cpp b/security/openconnect-gui/files/patch-src_vpninfo.cpp
new file mode 100644
index 000000000000..90d3897d1374
--- /dev/null
+++ b/security/openconnect-gui/files/patch-src_vpninfo.cpp
@@ -0,0 +1,11 @@
+--- src/vpninfo.cpp.orig 2016-09-21 11:15:03 UTC
++++ src/vpninfo.cpp
+@@ -427,6 +427,8 @@ int VpnInfo::connect()
+ const QString osName{"mac-intel"};
+ #elif defined Q_OS_LINUX
+ const QString osName = QString("linux%1").arg(QSysInfo::buildCpuArchitecture() == "i386" ? "" : "-64").toStdString().c_str();
++#elif defined Q_OS_FREEBSD
++ const QString osName = QString("freebsd%1").arg(QSysInfo::buildCpuArchitecture() == "i386" ? "" : "-64").toStdString().c_str();
+ #else
+ #error Define OS string of other platforms...
+ #endif
diff --git a/security/openconnect-gui/files/patch-src_vpninfo.h b/security/openconnect-gui/files/patch-src_vpninfo.h
new file mode 100644
index 000000000000..707f4ba83c22
--- /dev/null
+++ b/security/openconnect-gui/files/patch-src_vpninfo.h
@@ -0,0 +1,11 @@
+--- src/vpninfo.h.orig 2016-08-28 20:11:26 UTC
++++ src/vpninfo.h
+@@ -23,7 +23,7 @@
+ #ifdef _WIN32
+ #include <winsock2.h>
+ #endif
+-#ifdef __linux__
++#if defined(__linux__) || defined(__FreeBSD__)
+ #define SOCKET int
+ #endif
+
diff --git a/security/openconnect-gui/pkg-descr b/security/openconnect-gui/pkg-descr
new file mode 100644
index 000000000000..fa4f0d764a99
--- /dev/null
+++ b/security/openconnect-gui/pkg-descr
@@ -0,0 +1,4 @@
+This is the GUI client for openconnect VPN. This client is in beta testing
+phase. It cannot be assumed to provide the required security.
+
+WWW: https://github.com/openconnect/openconnect-gui