aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2003-12-11 18:26:07 +0800
committerlinimon <linimon@FreeBSD.org>2003-12-11 18:26:07 +0800
commit3acec7b59cf1d12ef8421453b93a29374f776956 (patch)
tree15b58618c9790eae94be36df600c5aa05f92916f
parent19a5174a62ab0506e1024a25321ac8011ff5b369 (diff)
downloadfreebsd-ports-gnome-3acec7b59cf1d12ef8421453b93a29374f776956.tar.gz
freebsd-ports-gnome-3acec7b59cf1d12ef8421453b93a29374f776956.tar.zst
freebsd-ports-gnome-3acec7b59cf1d12ef8421453b93a29374f776956.zip
Replaces existing code with a version that doesn't slurp the entire file
into memory and supports the newer bzip2 compressed rpms. Also, call it rpm2cpio.pl so that it doesn't conflict with the binary version from archivers/rpm. PR: ports/59980 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de> (maintainer)
-rw-r--r--archivers/rpm2cpio/Makefile21
-rw-r--r--archivers/rpm2cpio/pkg-descr10
-rw-r--r--archivers/rpm2cpio/pkg-plist2
3 files changed, 21 insertions, 12 deletions
diff --git a/archivers/rpm2cpio/Makefile b/archivers/rpm2cpio/Makefile
index fcb450433afd..b66cb88b1d40 100644
--- a/archivers/rpm2cpio/Makefile
+++ b/archivers/rpm2cpio/Makefile
@@ -6,26 +6,27 @@
#
PORTNAME= rpm2cpio
-PORTVERSION= 1.1.20020306
+PORTVERSION= 1.2
CATEGORIES= archivers
-MASTER_SITES= http://www.iagora.com/~espel/
-DISTNAME= ${PORTNAME}
-EXTRACT_SUFX=
+MASTER_SITES= # none
+DISTFILES= # none
MAINTAINER= nox@jelal.kn-bremen.de
COMMENT= Convert .rpm files for extraction with /usr/bin/cpio, needs just perl
NO_WRKSUBDIR= yes
-EXTRACT_CMD= ${CP}
-EXTRACT_BEFORE_ARGS=
-EXTRACT_AFTER_ARGS= .
USE_PERL5= yes
+NO_BUILD= yes
-do-build:
- ${PERL5} -i.bak -p -e "if (1 .. 1) {s-^#!/usr/bin/perl-#!${PERL}-;}" ${WRKDIR}/rpm2cpio
+do-fetch:
+ @${DO_NADA}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ ${PERL5} -p -e "if (1 .. 1) {s-^#!/usr/bin/perl-#!${PERL}-;}" ${FILESDIR}/${PORTNAME} >${WRKDIR}/${PORTNAME}
do-install:
- ${INSTALL_SCRIPT} ${WRKDIR}/rpm2cpio ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}.pl
.include <bsd.port.mk>
diff --git a/archivers/rpm2cpio/pkg-descr b/archivers/rpm2cpio/pkg-descr
index 538443c4ad5c..49c78225d869 100644
--- a/archivers/rpm2cpio/pkg-descr
+++ b/archivers/rpm2cpio/pkg-descr
@@ -9,4 +9,12 @@ in particular, it won't build on the HPsUX box i'm on.
(this one needs just perl)
-WWW: http://www.iagora.com/~espel/
+Updated version by Sergey Babkin that doesn't slurp the entire file
+into memory and supports the newer bzip2 compressed rpms.
+
+BUGS: if the rpm contains more than one cpio file this version
+extracts only the first one. (I don't know how widespread these
+types of rpms are, i haven't yet seen one. If you do, try the
+binary rpm2cpio that comes with the archivers/rpm port.)
+
+Now called rpm2cpio.pl so that it doesn't conflict with the binary one.
diff --git a/archivers/rpm2cpio/pkg-plist b/archivers/rpm2cpio/pkg-plist
index 2a1399eaaa02..3c9537abe021 100644
--- a/archivers/rpm2cpio/pkg-plist
+++ b/archivers/rpm2cpio/pkg-plist
@@ -1 +1 @@
-bin/rpm2cpio
+bin/rpm2cpio.pl