aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-10-08 15:12:58 +0800
committerperky <perky@FreeBSD.org>2002-10-08 15:12:58 +0800
commit3da49d5ac28db6377e268099e7033c577fa8e541 (patch)
tree56a78b4fb6c1f42aef128e6f42d506282a9e0711
parent20803bed4fb246858e0419a9ce4b5739ce85bd60 (diff)
downloadfreebsd-ports-gnome-3da49d5ac28db6377e268099e7033c577fa8e541.tar.gz
freebsd-ports-gnome-3da49d5ac28db6377e268099e7033c577fa8e541.tar.zst
freebsd-ports-gnome-3da49d5ac28db6377e268099e7033c577fa8e541.zip
Add py-id3 1.2,
a Python module for retrieving and setting ID3 tags on MP3 files
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-id3/Makefile22
-rw-r--r--audio/py-id3/distinfo1
-rw-r--r--audio/py-id3/pkg-comment1
-rw-r--r--audio/py-id3/pkg-descr5
-rw-r--r--audio/py-id3/pkg-plist3
6 files changed, 33 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 0a1af9d16d68..f24cae2a4c6a 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -187,6 +187,7 @@
SUBDIR += playmidi
SUBDIR += py-ao
SUBDIR += py-cddb
+ SUBDIR += py-id3
SUBDIR += py-ogg
SUBDIR += py-vorbis
SUBDIR += py-xmms
diff --git a/audio/py-id3/Makefile b/audio/py-id3/Makefile
new file mode 100644
index 000000000000..54f501a0608a
--- /dev/null
+++ b/audio/py-id3/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: py-id3
+# Date created: 8 October 2002
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+
+PORTNAME= id3
+PORTVERSION= 1.2
+CATEGORIES= audio python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= id3-py
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= id3-py_${PORTVERSION}
+
+MAINTAINER= perky@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/id3-py-${PORTVERSION}
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+USE_PYTHON_PREFIX= yes
+
+.include <bsd.port.mk>
diff --git a/audio/py-id3/distinfo b/audio/py-id3/distinfo
new file mode 100644
index 000000000000..98a199ec7c93
--- /dev/null
+++ b/audio/py-id3/distinfo
@@ -0,0 +1 @@
+MD5 (id3-py_1.2.tar.gz) = de0bd6053dda674967dacb6492a90c69
diff --git a/audio/py-id3/pkg-comment b/audio/py-id3/pkg-comment
new file mode 100644
index 000000000000..84d6d1f32472
--- /dev/null
+++ b/audio/py-id3/pkg-comment
@@ -0,0 +1 @@
+Python module for retrieving and setting ID3 tags on MP3 files
diff --git a/audio/py-id3/pkg-descr b/audio/py-id3/pkg-descr
new file mode 100644
index 000000000000..08e479602e49
--- /dev/null
+++ b/audio/py-id3/pkg-descr
@@ -0,0 +1,5 @@
+This module allows one to read and manipulate so-called ID3
+informational tags on MP3 files through an object-oriented
+Python interface.
+
+WWW: http://id3-py.sourceforge.net/
diff --git a/audio/py-id3/pkg-plist b/audio/py-id3/pkg-plist
new file mode 100644
index 000000000000..06e2f4cf6610
--- /dev/null
+++ b/audio/py-id3/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/ID3.py
+%%PYTHON_SITELIBDIR%%/ID3.pyc
+%%PYTHON_SITELIBDIR%%/ID3.pyo