aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2014-07-13 02:03:24 +0800
committernox <nox@FreeBSD.org>2014-07-13 02:03:24 +0800
commit3e73cb269deacda7504a10262f9942344d70eb2e (patch)
tree94877d66450bb1c26ff72b73894330778dc63f97
parenta9fb2b1e20563235105c3f65617f01a4ed0d86c3 (diff)
downloadfreebsd-ports-gnome-3e73cb269deacda7504a10262f9942344d70eb2e.tar.gz
freebsd-ports-gnome-3e73cb269deacda7504a10262f9942344d70eb2e.tar.zst
freebsd-ports-gnome-3e73cb269deacda7504a10262f9942344d70eb2e.zip
- Fix build with MUSEPACK knob.
- Replace another occurence of /usr/local with LOCALBASE. PR: 191836 Submitted by: mikhail.rokhin@gmail.com
-rw-r--r--multimedia/vlc/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 4b826d729c51..207425a17a99 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -117,8 +117,8 @@ DVDNAV_CONFIGURE_ENABLE=dvdnav
FAAD_LIB_DEPENDS= libfaad.so:${PORTSDIR}/audio/faad
FAAD_CONFIGURE_ENABLE= faad
-FAAD_CONFIGURE_ENV= CPPFLAGS_faad="-I/usr/local/include" \
- LIBS_faad="-L/usr/local/lib"
+FAAD_CONFIGURE_ENV= CPPFLAGS_faad="-I${LOCALBASE}/include" \
+ LIBS_faad="-L${LOCALBASE}/lib"
FLAC_LIB_DEPENDS= libFLAC.so:${PORTSDIR}/audio/flac
FLAC_CONFIGURE_ENABLE= flac
@@ -198,6 +198,7 @@ MTP_CONFIGURE_ENABLE= mtp
MUSEPACK_LIB_DEPENDS= libmpcdec.so:${PORTSDIR}/audio/musepack
MUSEPACK_CONFIGURE_ENABLE= mpc
+MUSEPACK_CONFIGURE_ENV= LIBS_mpc="-L${LOCALBASE}/lib -lmpcdec"
NCURSES_USES= ncurses
NCURSES_CONFIGURE_ENV= NCURSES_CFLAGS="-I${NCURSESINC}" \