aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-06-26 14:26:15 +0800
committerkrion <krion@FreeBSD.org>2004-06-26 14:26:15 +0800
commit477d3494b71a858656e111c08c2dd970856f5b18 (patch)
tree45fe593a4c89f9491aeaf73fa964b8c6d1926056
parent5a665011be69eafcf4a00a2a5e10d58753012956 (diff)
downloadfreebsd-ports-gnome-477d3494b71a858656e111c08c2dd970856f5b18.tar.gz
freebsd-ports-gnome-477d3494b71a858656e111c08c2dd970856f5b18.tar.zst
freebsd-ports-gnome-477d3494b71a858656e111c08c2dd970856f5b18.zip
Add swami 0.9.2,
Swami - Sampled Waveforms and And Musical Instruments - is an advanced instrument editor for MIDI music composition and a sampler frontend. Currently SoundFont(r) files can be browsed, edited and saved and new instrument formats are being added in the Swami development version. Swami uses FluidSynth for software synthesis, so almost any sound card can be used. FluidSynth has real time effect control and SoundFont 2.01 modulator support for controlling effects in real time with MIDI. PR: ports/68335 Submitted by: Jean-Yves Lefort <jylefort@brutele.be>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/swami/Makefile44
-rw-r--r--audio/swami/distinfo2
-rw-r--r--audio/swami/files/patch-src::gui::main.c12
-rw-r--r--audio/swami/files/patch-src::plugins::wavetbl_fluidsynth.c11
-rw-r--r--audio/swami/pkg-descr13
-rw-r--r--audio/swami/pkg-plist16
7 files changed, 99 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index f34dae79d456..2eb77679b913 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -347,6 +347,7 @@
SUBDIR += streamtuner-local
SUBDIR += streamtuner-python
SUBDIR += streamtuner-xiph
+ SUBDIR += swami
SUBDIR += sweep
SUBDIR += swhplugins
SUBDIR += taglib
diff --git a/audio/swami/Makefile b/audio/swami/Makefile
new file mode 100644
index 000000000000..6591688fd0df
--- /dev/null
+++ b/audio/swami/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Swami
+# Date created: 25 Jun 2004
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= swami
+PORTVERSION= 0.9.2
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= An advanced instrument editor
+
+LIB_DEPENDS= popt:${PORTSDIR}/devel/popt \
+ png:${PORTSDIR}/graphics/png \
+ fluidsynth:${PORTSDIR}/audio/fluidsynth \
+ sndfile:${PORTSDIR}/audio/libsndfile \
+ audiofile:${PORTSDIR}/audio/libaudiofile
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_LIBTOOL_VER= 14
+USE_GNOME= gnomelibs gnometarget
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|libpng|libpng12|g' ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} \
+ ${WRKSRC}/AUTHORS \
+ ${WRKSRC}/NEWS \
+ ${WRKSRC}/README \
+ ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/swami/distinfo b/audio/swami/distinfo
new file mode 100644
index 000000000000..de3717adda53
--- /dev/null
+++ b/audio/swami/distinfo
@@ -0,0 +1,2 @@
+MD5 (swami-0.9.2.tar.bz2) = 72e981c592165537d86ae37fd21e3933
+SIZE (swami-0.9.2.tar.bz2) = 729688
diff --git a/audio/swami/files/patch-src::gui::main.c b/audio/swami/files/patch-src::gui::main.c
new file mode 100644
index 000000000000..251043185548
--- /dev/null
+++ b/audio/swami/files/patch-src::gui::main.c
@@ -0,0 +1,12 @@
+--- src/gui/main.c.orig Fri Jun 25 17:40:49 2004
++++ src/gui/main.c Fri Jun 25 17:41:12 2004
+@@ -119,6 +119,9 @@
+
+ poptFreeContext (popt_ctx);
+
++ /* keep sound alive */
++ gtk_timeout_add(10, gtk_true, NULL);
++
+ gdk_threads_enter ();
+ gtk_main (); /* kick it in the main GTK loop */
+ gdk_threads_leave ();
diff --git a/audio/swami/files/patch-src::plugins::wavetbl_fluidsynth.c b/audio/swami/files/patch-src::plugins::wavetbl_fluidsynth.c
new file mode 100644
index 000000000000..fb2ef268015c
--- /dev/null
+++ b/audio/swami/files/patch-src::plugins::wavetbl_fluidsynth.c
@@ -0,0 +1,11 @@
+--- src/plugins/wavetbl_fluidsynth.c.orig Fri Jun 25 18:02:19 2004
++++ src/plugins/wavetbl_fluidsynth.c Fri Jun 25 18:03:08 2004
+@@ -154,7 +154,7 @@
+ { "fluidsynth", "audio_type", G_TOKEN_STRING, {""}},
+ { NULL, "audio_device", G_TOKEN_STRING, {""}},
+ { NULL, "audio_bufsize", G_TOKEN_INT, {GINT_TO_POINTER (64)}},
+- { NULL, "audio_bufcount", G_TOKEN_INT, {GINT_TO_POINTER (3)}},
++ { NULL, "audio_bufcount", G_TOKEN_INT, {GINT_TO_POINTER (16)}},
+ { NULL, "midi_type", G_TOKEN_STRING, {""}},
+ { NULL, "midi_device", G_TOKEN_STRING, {""}},
+ { NULL, "master_gain", G_TOKEN_FLOAT, {v_float:0.0}},
diff --git a/audio/swami/pkg-descr b/audio/swami/pkg-descr
new file mode 100644
index 000000000000..3d1809140bf0
--- /dev/null
+++ b/audio/swami/pkg-descr
@@ -0,0 +1,13 @@
+Swami - Sampled Waveforms and And Musical Instruments - is an advanced
+instrument editor for MIDI music composition and a sampler
+frontend. Currently SoundFont(r) files can be browsed, edited and
+saved and new instrument formats are being added in the Swami
+development version. Swami uses FluidSynth for software synthesis, so
+almost any sound card can be used. FluidSynth has real time effect
+control and SoundFont 2.01 modulator support for controlling effects
+in real time with MIDI.
+
+WWW: http://swami.sourceforge.net/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/audio/swami/pkg-plist b/audio/swami/pkg-plist
new file mode 100644
index 000000000000..391e38ffefac
--- /dev/null
+++ b/audio/swami/pkg-plist
@@ -0,0 +1,16 @@
+bin/swami
+lib/swami/samplelib_audiofile.a
+lib/swami/samplelib_audiofile.la
+lib/swami/samplelib_audiofile.so
+lib/swami/samplelib_libsndfile.a
+lib/swami/samplelib_libsndfile.la
+lib/swami/samplelib_libsndfile.so
+lib/swami/wavetbl_fluidsynth.a
+lib/swami/wavetbl_fluidsynth.la
+lib/swami/wavetbl_fluidsynth.so
+share/locale/de/LC_MESSAGES/swami.mo
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+@dirrm lib/swami
+%%PORTDOCS%%@dirrm %%DOCSDIR%%