aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-08-12 03:46:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-08-12 03:46:48 +0800
commit48215a0382fa63896bb1f1de317fa7f75f614a96 (patch)
tree47f05dbd984ccb8d575f9d9e4dc73c9895fbca10
parent15f04e3d8092218530181f31a81c794b0ee18b5e (diff)
downloadfreebsd-ports-gnome-48215a0382fa63896bb1f1de317fa7f75f614a96.tar.gz
freebsd-ports-gnome-48215a0382fa63896bb1f1de317fa7f75f614a96.tar.zst
freebsd-ports-gnome-48215a0382fa63896bb1f1de317fa7f75f614a96.zip
- Fix segfaults due to typo in malloc() invocation
PR: ports/126338 Submitted by: Shota Iwazaki <iwazaki8 at yahoo dot co dot jp> Approved by: Stephen Hurd <shurd at sasktel dot net> (maintainer) Approved by: miwi (mentor implicit)
-rw-r--r--ports-mgmt/pkg_cleanup/Makefile1
-rw-r--r--ports-mgmt/pkg_cleanup/files/pkg_cleanup.c2
2 files changed, 2 insertions, 1 deletions
diff --git a/ports-mgmt/pkg_cleanup/Makefile b/ports-mgmt/pkg_cleanup/Makefile
index 25d22ec83b03..e8ea64828409 100644
--- a/ports-mgmt/pkg_cleanup/Makefile
+++ b/ports-mgmt/pkg_cleanup/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pkg_cleanup
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= ports-mgmt
DISTFILES=
diff --git a/ports-mgmt/pkg_cleanup/files/pkg_cleanup.c b/ports-mgmt/pkg_cleanup/files/pkg_cleanup.c
index 1027557759d3..1f191676ed46 100644
--- a/ports-mgmt/pkg_cleanup/files/pkg_cleanup.c
+++ b/ports-mgmt/pkg_cleanup/files/pkg_cleanup.c
@@ -208,7 +208,7 @@ int remove_ports(void)
pid_t child;
int status;
- args=(char **)malloc(menulen+2 * sizeof(char *));
+ args=(char **)malloc((menulen+2) * sizeof(char *));
if(!args) {
init_dialog();
dialog_msgbox("ERROR", "Can not allocate memory for package list!", 5, 45, TRUE);