aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-07-03 00:09:14 +0800
committermiwi <miwi@FreeBSD.org>2011-07-03 00:09:14 +0800
commit4afbdf37550facd717fd3af491b099376dd9d060 (patch)
tree9835046feec66620ea759bcfd653c1a8cb97331e
parentcc173c7ccbe65842f87dfe0a7ed31b5b4d4202f7 (diff)
downloadfreebsd-ports-gnome-4afbdf37550facd717fd3af491b099376dd9d060.tar.gz
freebsd-ports-gnome-4afbdf37550facd717fd3af491b099376dd9d060.tar.zst
freebsd-ports-gnome-4afbdf37550facd717fd3af491b099376dd9d060.zip
- Update to 2.08
PR: 158482 Submitted by: Ports Fury
-rw-r--r--graphics/ida/Makefile67
-rw-r--r--graphics/ida/distinfo5
-rw-r--r--graphics/ida/pkg-descr3
3 files changed, 54 insertions, 21 deletions
diff --git a/graphics/ida/Makefile b/graphics/ida/Makefile
index 57af30e28152..4d4047307f1a 100644
--- a/graphics/ida/Makefile
+++ b/graphics/ida/Makefile
@@ -6,46 +6,79 @@
#
PORTNAME= ida
-PORTVERSION= 2.07
-PORTREVISION= 5
+PORTVERSION= 2.08
CATEGORIES= graphics
-MASTER_SITES= http://dl.bytesex.org/releases/fbida/
+MASTER_SITES= http://www.kraxel.org/releases/fbida/
DISTNAME= fbida-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Small and fast motif-based image viewer and editor
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff \
- ungif.5:${PORTSDIR}/graphics/libungif \
exif.12:${PORTSDIR}/graphics/libexif
-USE_GMAKE= yes
+OPTIONS= GIF "Enable GIF support" on \
+ PCD "Enable PhotoCD support" off \
+ PNG "Enable PNG support" on \
+ SANE "Enable SANE support" off \
+ TIFF "Enable TIFF support" on \
+ WEBP "Enable WebP suport" off
+
USE_MOTIF= yes
USE_PERL5_BUILD=yes
-USE_ICONV= yes
-WRKSRC= ${WRKDIR}/${DISTNAME:S/_/-/}
+USE_GMAKE= yes
MAKEFILE= ${WRKSRC}/GNUmakefile
-LDLIBS= -liconv
-MAKE_ENV+= LDLIBS="${LDLIBS}"
+MAKE_ARGS= JPEG_VER=80 verbose=yes
MAN1= exiftran.1 ida.1
PORTDOCS= README TODO INSTALL
-
PLIST_FILES= bin/exiftran bin/ida lib/X11/app-defaults/Ida
-post-patch:
- ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/rd/read-png.c
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GIF)
+MAKE_ARGS+= HAVE_LIBUNGIF=no
+.else
+LIB_DEPENDS+= ungif.5:${PORTSDIR}/graphics/libungif
+.endif
+
+.if defined(WITH_PCD)
+LIB_DEPENDS+= pcd:${PORTSDIR}/graphics/libpcd
+.else
+MAKE_ARGS+= HAVE_LIBPCD=no
+.endif
+
+.if defined(WITHOUT_PNG)
+MAKE_ARGS+= HAVE_LIBPNG=no
+.else
+LIB_DEPENDS+= png.6:${PORTSDIR}/graphics/png
+.endif
+
+.if defined(WITH_SANE)
+LIB_DEPENDS+= sane:${PORTSDIR}/graphics/sane-backends
+.else
+MAKE_ARGS+= HAVE_LIBSANE=no
+.endif
+
+.if defined(WITHOUT_TIFF)
+MAKE_ARGS+= HAVE_LIBTIFF=no
+.else
+LIB_DEPENDS+= tiff.4:${PORTSDIR}/graphics/tiff
+.endif
+
+.if defined(WITH_WEBP)
+LIB_DEPENDS+= webp:${PORTSDIR}/graphics/webp
+.else
+MAKE_ARGS+= HAVE_LIBWEBP=no
+.endif
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/exiftran ${PREFIX}/bin
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
.for a in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${a} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/ida/distinfo b/graphics/ida/distinfo
index 41351962fc65..fdf32b3c2635 100644
--- a/graphics/ida/distinfo
+++ b/graphics/ida/distinfo
@@ -1,3 +1,2 @@
-MD5 (fbida-2.07.tar.gz) = 3e05910fb7c1d9b2bd3e272d96db069c
-SHA256 (fbida-2.07.tar.gz) = 6510dee7c4f45cb63094d540e66aa39d53215c59f46944b8bb050c26b71bdb44
-SIZE (fbida-2.07.tar.gz) = 213622
+SHA256 (fbida-2.08.tar.gz) = 298e7f3545e33596a5876f6b9c3da7ef475c2692e5fab0df824fbcd7a489cd80
+SIZE (fbida-2.08.tar.gz) = 241283
diff --git a/graphics/ida/pkg-descr b/graphics/ida/pkg-descr
index 84fa634f4beb..4516ca0acdd2 100644
--- a/graphics/ida/pkg-descr
+++ b/graphics/ida/pkg-descr
@@ -1,4 +1,5 @@
Ida is a small and fast image viewer, motif-based. For people who don't want
the KDE/GNOME overhead. Some basic editing functions are available too.
-WWW: http://linux.bytesex.org/fbida/
+Author: Gerd Knorr <kraxel@bytesex.org>
+WWW: http://www.kraxel.org/blog/linux/fbida/