aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2011-06-21 05:44:47 +0800
committermandree <mandree@FreeBSD.org>2011-06-21 05:44:47 +0800
commit4bc2419e82e24d425adacfbba47449326e5f6dfc (patch)
tree455c70765ca87816df4d185f2cec9a26d6c9340d
parentc507555a98700bf9f9ea107beeff32f73859243c (diff)
downloadfreebsd-ports-gnome-4bc2419e82e24d425adacfbba47449326e5f6dfc.tar.gz
freebsd-ports-gnome-4bc2419e82e24d425adacfbba47449326e5f6dfc.tar.zst
freebsd-ports-gnome-4bc2419e82e24d425adacfbba47449326e5f6dfc.zip
Clang fixes:- patch plugin Makefiles to use ${CC} rather than gcc (found by -exp run);
- silence non-literal format string warnings (non-fix, adds patch-options.c) - fix missing prototype warning (adds patch-route.c, bumps PORTREVISION) - Use full ${MAKE} environment from do-build, for consistency. While here, remove MD5 checksum.
-rw-r--r--security/openvpn20/Makefile9
-rw-r--r--security/openvpn20/distinfo1
-rw-r--r--security/openvpn20/files/patch-options.c29
-rw-r--r--security/openvpn20/files/patch-route.c10
4 files changed, 46 insertions, 3 deletions
diff --git a/security/openvpn20/Makefile b/security/openvpn20/Makefile
index 1d5d79c83eb8..da8cfca37758 100644
--- a/security/openvpn20/Makefile
+++ b/security/openvpn20/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openvpn
PORTVERSION= 2.0.9
+PORTREVISION= 1
CATEGORIES= security net
# MASTER_SITES points to hosts in distinct data centers,
# so just one MASTER_SITES entry should be OK.
@@ -65,13 +66,17 @@ LIB_DEPENDS+= lzo.1:${PORTSDIR}/archivers/lzo
CONFIGURE_ARGS+= --enable-password-save
.endif
+post-patch:
+ ${FIND} ${WRKSRC}/plugin -name Makefile \
+ -exec ${REINPLACE_CMD} 's;gcc;${CC};g' '{}' +
+
post-build:
- cd ${WRKSRC}/plugin/down-root && ${MAKE}
+ cd ${WRKSRC}/plugin/down-root && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS}
cd ${WRKSRC}/plugin/auth-pam && ${CC} ${CPPFLAGS} -I../.. -DDLOPEN_PAM=0 ${CFLAGS} -fPIC -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam
@# self-tests here
.if !defined(WITHOUT_CHECK)
@${ECHO} ; ${ECHO} "### Note that you can skip these lengthy selftests with WITHOUT_CHECK=yes ###" ; ${ECHO}
- cd ${WRKSRC} && ${MAKE} check
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} check
.endif
post-install:
diff --git a/security/openvpn20/distinfo b/security/openvpn20/distinfo
index b73badbf2ff8..f43f42dbf687 100644
--- a/security/openvpn20/distinfo
+++ b/security/openvpn20/distinfo
@@ -1,3 +1,2 @@
-MD5 (openvpn-2.0.9.tar.gz) = 60745008b90b7dbe25fe8337c550fec6
SHA256 (openvpn-2.0.9.tar.gz) = 347c551e7c88affc1f4b7a4b715080253c9298dcc512ed29fe8ca5cd26d015d9
SIZE (openvpn-2.0.9.tar.gz) = 669076
diff --git a/security/openvpn20/files/patch-options.c b/security/openvpn20/files/patch-options.c
new file mode 100644
index 000000000000..4c6181f5c24d
--- /dev/null
+++ b/security/openvpn20/files/patch-options.c
@@ -0,0 +1,29 @@
+--- ./options.c.orig 2011-06-20 23:21:51.000000000 +0200
++++ ./options.c 2011-06-20 23:22:06.000000000 +0200
+@@ -3002,7 +3002,7 @@
+ {
+ if (options->inetd != -1)
+ {
+- msg (msglevel, opterr);
++ msg (msglevel, "%s", opterr);
+ goto err;
+ }
+ else
+@@ -3012,7 +3012,7 @@
+ {
+ if (options->inetd != -1)
+ {
+- msg (msglevel, opterr);
++ msg (msglevel, "%s", opterr);
+ goto err;
+ }
+ else
+@@ -3022,7 +3022,7 @@
+ {
+ if (name != NULL)
+ {
+- msg (msglevel, opterr);
++ msg (msglevel, "%s", opterr);
+ goto err;
+ }
+ name = p[z];
diff --git a/security/openvpn20/files/patch-route.c b/security/openvpn20/files/patch-route.c
new file mode 100644
index 000000000000..243445716b5c
--- /dev/null
+++ b/security/openvpn20/files/patch-route.c
@@ -0,0 +1,10 @@
+--- ./route.c.orig 2006-04-05 08:13:55.000000000 +0200
++++ ./route.c 2011-06-20 23:19:43.000000000 +0200
+@@ -1310,6 +1310,7 @@
+
+ #elif defined(TARGET_FREEBSD)
+
++#include <err.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>