aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2008-06-24 05:44:15 +0800
committerlippe <lippe@FreeBSD.org>2008-06-24 05:44:15 +0800
commit527ebf34ce162dee75a818742202a576ccbbb8e5 (patch)
tree3f878f0a8a46f572d7b3a2972fcbaa262cf81424
parent12f5a20f44b8d4790ad42daf697b2feb6e093a6b (diff)
downloadfreebsd-ports-gnome-527ebf34ce162dee75a818742202a576ccbbb8e5.tar.gz
freebsd-ports-gnome-527ebf34ce162dee75a818742202a576ccbbb8e5.tar.zst
freebsd-ports-gnome-527ebf34ce162dee75a818742202a576ccbbb8e5.zip
Couchdb is a document database server, accessible via a RESTful JSON API. It has an ad-hoc and schema-free with a flat address space. CouchDB is distributed, featuring robust, incremental replication with bi-directional conflict detection and management. It features a table oriented reporting engine that uses Javascript as a query language.
WWW: http://couchdb.org/ PR: ports/118103 Submitted by: Ditesh Shashikant Gathani <ditesh@gathani.org> Approved by: gabor (mentor, implicit)
-rw-r--r--databases/Makefile1
-rw-r--r--databases/couchdb/Makefile31
-rw-r--r--databases/couchdb/distinfo3
-rw-r--r--databases/couchdb/pkg-descr7
-rw-r--r--databases/couchdb/pkg-plist172
5 files changed, 214 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 7522e3f39789..4afb12bd83b4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -14,6 +14,7 @@
SUBDIR += bbdb
SUBDIR += cdb
SUBDIR += clip
+ SUBDIR += couchdb
SUBDIR += courier-authlib-mysql
SUBDIR += courier-authlib-pgsql
SUBDIR += courier-authlib-userdb
diff --git a/databases/couchdb/Makefile b/databases/couchdb/Makefile
new file mode 100644
index 000000000000..037c4500857e
--- /dev/null
+++ b/databases/couchdb/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: couchdb
+# Date created: 17 Nov 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= couchdb
+PORTVERSION= 0.7.0
+CATEGORIES= databases
+MASTER_SITES= http://couchdb.googlecode.com/files/
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= A document database server, accessible via a RESTful JSON API
+
+LIB_DEPENDS= icudata:${PORTSDIR}/devel/icu
+BUILD_DEPENDS= ${LOCALBASE}/lib/erlang/usr/include/erl_driver.h:${PORTSDIR}/lang/erlang
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --with-erlang=${LOCALBASE}/lib/erlang/usr/include \
+ --localstatedir=/var \
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|),Linux|),FreeBSD|g" ${WRKSRC}/src/js/config.mk
+
+MAN1= couchdb.1 couchjs.1
+
+.include <bsd.port.mk>
diff --git a/databases/couchdb/distinfo b/databases/couchdb/distinfo
new file mode 100644
index 000000000000..e492cbfb8577
--- /dev/null
+++ b/databases/couchdb/distinfo
@@ -0,0 +1,3 @@
+MD5 (couchdb-0.7.0.tar.gz) = 2e214874e9063cc178bde7ab0f703b89
+SHA256 (couchdb-0.7.0.tar.gz) = 34311f849512e557e565417fd97a87a8db8cf704956373a83613606e9a545ecd
+SIZE (couchdb-0.7.0.tar.gz) = 1602625
diff --git a/databases/couchdb/pkg-descr b/databases/couchdb/pkg-descr
new file mode 100644
index 000000000000..165d94e05345
--- /dev/null
+++ b/databases/couchdb/pkg-descr
@@ -0,0 +1,7 @@
+Couchdb is a document database server, accessible via a RESTful JSON API. It has
+an ad-hoc and schema-free with a flat address space. CouchDB is distributed,
+featuring robust, incremental replication with bi-directional conflict detection
+and management. It features a table oriented reporting engine that uses
+Javascript as a query language.
+
+WWW: http://couchdb.org/
diff --git a/databases/couchdb/pkg-plist b/databases/couchdb/pkg-plist
new file mode 100644
index 000000000000..2de358dd8caa
--- /dev/null
+++ b/databases/couchdb/pkg-plist
@@ -0,0 +1,172 @@
+bin/couchdb
+bin/couchjs
+%%ETCDIR%%/conf/mime.types
+%%ETCDIR%%/couch.ini
+%%ETCDIR%%/couch_httpd.conf
+etc/default/couchdb
+etc/rc.d/couchdb
+lib/couchdb/bin/_couchjs
+lib/couchdb/erlang/bin/couch.boot
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/cjson.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch.app
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_btree.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_db.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_db_sup.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_db_update_notifier.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_doc.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_event_sup.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_file.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_ft_query.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_log.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_query_servers.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_rep.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_server.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_server_sup.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_stream.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_util.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/couch_view_group.beam
+lib/couchdb/erlang/lib/couch-0.7.0/ebin/mod_couch.beam
+lib/couchdb/erlang/lib/couch-0.7.0/include/couch_db.hrl
+lib/couchdb/erlang/lib/couch-0.7.0/priv/lib/couch_erl_driver.a
+lib/couchdb/erlang/lib/couch-0.7.0/priv/lib/couch_erl_driver.la
+lib/couchdb/erlang/lib/couch-0.7.0/priv/lib/couch_erl_driver.so
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/couch_inets.app
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/ftp.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/ftp_progress.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/ftp_response.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/ftp_sup.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_base_64.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_chunk.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_cookie.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_request.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_response.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_transport.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_uri.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/http_util.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_handler.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_manager.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_request.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_response.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpc_sup.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_acceptor.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_acceptor_sup.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_cgi.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_conf.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_esi.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_example.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_instance_sup.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_manager.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_misc_sup.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_request.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_request_handler.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_response.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_script_env.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_socket.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_sup.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/httpd_util.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/inets.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/inets_app.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/inets_sup.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_actions.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_alias.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth_dets.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth_mnesia.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth_plain.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_auth_server.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_browser.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_cgi.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_dir.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_disk_log.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_esi.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_get.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_head.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_htaccess.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_include.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_log.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_range.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_responsecontrol.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_security.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_security_server.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/mod_trace.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_binary.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_engine.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_file.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_lib.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin/tftp_sup.beam
+lib/couchdb/erlang/lib/couch_inets-4.7.5/include/ftp_internal.hrl
+lib/couchdb/erlang/lib/couch_inets-4.7.5/include/http_internal.hrl
+lib/couchdb/erlang/lib/couch_inets-4.7.5/include/httpc_internal.hrl
+lib/couchdb/erlang/lib/couch_inets-4.7.5/include/httpd.hrl
+lib/couchdb/erlang/lib/couch_inets-4.7.5/include/inets_internal.hrl
+lib/couchdb/erlang/lib/couch_inets-4.7.5/include/mod_auth.hrl
+lib/couchdb/erlang/lib/couch_inets-4.7.5/include/tftp.hrl
+%%DATADIR%%/server/main.js
+%%DATADIR%%/www/browse/database.html
+%%DATADIR%%/www/browse/document.html
+%%DATADIR%%/www/browse/index.html
+%%DATADIR%%/www/couch_tests.html
+%%DATADIR%%/www/favicon.ico
+%%DATADIR%%/www/image/add.gif
+%%DATADIR%%/www/image/apply.gif
+%%DATADIR%%/www/image/bg.png
+%%DATADIR%%/www/image/cancel.gif
+%%DATADIR%%/www/image/delete-mini.gif
+%%DATADIR%%/www/image/delete.gif
+%%DATADIR%%/www/image/hgrad.gif
+%%DATADIR%%/www/image/load.gif
+%%DATADIR%%/www/image/logo.png
+%%DATADIR%%/www/image/path.gif
+%%DATADIR%%/www/image/run-mini.gif
+%%DATADIR%%/www/image/run.gif
+%%DATADIR%%/www/image/running.gif
+%%DATADIR%%/www/image/save.gif
+%%DATADIR%%/www/image/test_failure.gif
+%%DATADIR%%/www/image/test_success.gif
+%%DATADIR%%/www/image/thead.gif
+%%DATADIR%%/www/image/toggle-collapse.gif
+%%DATADIR%%/www/image/toggle-expand.gif
+%%DATADIR%%/www/index.html
+%%DATADIR%%/www/replicator.html
+%%DATADIR%%/www/script/browse.js
+%%DATADIR%%/www/script/couch.js
+%%DATADIR%%/www/script/couch_tests.js
+%%DATADIR%%/www/script/jquery.js
+%%DATADIR%%/www/script/json.js
+%%DATADIR%%/www/script/pprint.js
+%%DATADIR%%/www/script/shell.js
+%%DATADIR%%/www/shell.html
+%%DATADIR%%/www/style/layout.css
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS.gz
+%%PORTDOCS%%%%DOCSDIR%%/BUGS.gz
+%%PORTDOCS%%%%DOCSDIR%%/NEWS.gz
+%%PORTDOCS%%%%DOCSDIR%%/README.gz
+%%PORTDOCS%%%%DOCSDIR%%/THANKS.gz
+%%PORTDOCS%%%%DOCSDIR%%/changelog.gz
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/www/style
+@dirrm %%DATADIR%%/www/script
+@dirrm %%DATADIR%%/www/image
+@dirrm %%DATADIR%%/www/browse
+@dirrm %%DATADIR%%/www
+@dirrm %%DATADIR%%/server
+@dirrm %%DATADIR%%
+@dirrm lib/couchdb/erlang/lib/couch_inets-4.7.5/include
+@dirrm lib/couchdb/erlang/lib/couch_inets-4.7.5/ebin
+@dirrm lib/couchdb/erlang/lib/couch_inets-4.7.5
+@dirrm lib/couchdb/erlang/lib/couch-0.7.0/priv/lib
+@dirrm lib/couchdb/erlang/lib/couch-0.7.0/priv
+@dirrm lib/couchdb/erlang/lib/couch-0.7.0/include
+@dirrm lib/couchdb/erlang/lib/couch-0.7.0/ebin
+@dirrm lib/couchdb/erlang/lib/couch-0.7.0
+@dirrm lib/couchdb/erlang/lib
+@dirrm lib/couchdb/erlang/bin
+@dirrm lib/couchdb/erlang
+@dirrm lib/couchdb/bin
+@dirrm lib/couchdb
+@dirrm etc/default
+@dirrm %%ETCDIR%%/conf
+@dirrm %%ETCDIR%%