aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2006-11-15 04:49:52 +0800
committerstas <stas@FreeBSD.org>2006-11-15 04:49:52 +0800
commit560bd2dfbb08289d921455ba43606182b8a2c27c (patch)
tree918f9fdc0d048eb8efe71e9eceb1db265db82174
parent5bdfcb93f893c9432a1c72a91c6b1a41fed372f7 (diff)
downloadfreebsd-ports-gnome-560bd2dfbb08289d921455ba43606182b8a2c27c.tar.gz
freebsd-ports-gnome-560bd2dfbb08289d921455ba43606182b8a2c27c.tar.zst
freebsd-ports-gnome-560bd2dfbb08289d921455ba43606182b8a2c27c.zip
- Don't links agains threading libraries in case if pthreads support was
disabled. Reported by: Anton Yuzhaninov <citrin@citrin.ru>
-rw-r--r--lang/ruby18/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/lang/ruby18/Makefile b/lang/ruby18/Makefile
index dc13546e8cbd..25d24c70c8dd 100644
--- a/lang/ruby18/Makefile
+++ b/lang/ruby18/Makefile
@@ -42,6 +42,8 @@ OPTIONS= PTHREADS "Enable pthreads support (may break some apps)" off \
PKGNAMESUFFIX= #empty
.if defined(WITH_PTHREADS)
CONFIGURE_ARGS+=--enable-pthread
+CFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}+pthreads
.else
CONFIGURE_ARGS+=--disable-pthread
@@ -81,8 +83,8 @@ EXTRA_PATCHES= ${PATCHDIR}/extrapatch-eval.c
CONFIGURE_ARGS+= --enable-ipv6
.endif
-CONFIGURE_ENV= CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}" \
- LIBS="${LIBS} ${PTHREAD_LIBS}"
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LIBS="${LDFLAGS}"
.if ${RUBY_VER} == ${RUBY_DEFAULT_VER}
MLINKS= ${RUBY_NAME}.1 ruby.1