aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2011-12-09 02:32:10 +0800
committernovel <novel@FreeBSD.org>2011-12-09 02:32:10 +0800
commit56bbea0fc3905e5d678f91bb83b6d0ef03100976 (patch)
tree03873f63403f3262196b16fc248510ee20e27332
parent8aa450f1cf3eeb452ca923f9d5f6048850904a08 (diff)
downloadfreebsd-ports-gnome-56bbea0fc3905e5d678f91bb83b6d0ef03100976.tar.gz
freebsd-ports-gnome-56bbea0fc3905e5d678f91bb83b6d0ef03100976.tar.zst
freebsd-ports-gnome-56bbea0fc3905e5d678f91bb83b6d0ef03100976.zip
Add devel/py-prettytable -- a simple Python library for easily displaying
tabular data in a visually appealing ASCII table format. Feature safe: yes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-prettytable/Makefile23
-rw-r--r--devel/py-prettytable/distinfo2
-rw-r--r--devel/py-prettytable/pkg-descr8
-rw-r--r--devel/py-prettytable/pkg-plist1
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 042599ef778f..a27dbc1650fe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3132,6 +3132,7 @@
SUBDIR += py-polib
SUBDIR += py-pp
SUBDIR += py-pqueue
+ SUBDIR += py-prettytable
SUBDIR += py-prioritized_methods
SUBDIR += py-protobuf
SUBDIR += py-protocols
diff --git a/devel/py-prettytable/Makefile b/devel/py-prettytable/Makefile
new file mode 100644
index 000000000000..69440de69362
--- /dev/null
+++ b/devel/py-prettytable/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: py-prettytable
+# Date created: 2011-12-08
+# Whom: Roman Bogorodskiy <novel@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= prettytable
+PORTVERSION= 0.5
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+MASTER_SITE_SUBDIR=source/P/PrettyTable
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= novel@FreeBSD.org
+COMMENT= Library for displaying tabular data in an ASCII table format
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYDISTUTILS_NOEGGINFO= yes
+PLIST_SUB= VERSION=${PORTVERSION} PYVER=${PYTHON_VERSION:S/python//}
+
+.include <bsd.port.mk>
diff --git a/devel/py-prettytable/distinfo b/devel/py-prettytable/distinfo
new file mode 100644
index 000000000000..afe651a4cb70
--- /dev/null
+++ b/devel/py-prettytable/distinfo
@@ -0,0 +1,2 @@
+SHA256 (prettytable-0.5.tar.gz) = 52dbc76b9fdc53f6386ce9380a93653dbff20717296605449b86a73f426b7d8b
+SIZE (prettytable-0.5.tar.gz) = 6101
diff --git a/devel/py-prettytable/pkg-descr b/devel/py-prettytable/pkg-descr
new file mode 100644
index 000000000000..594ddcad37ec
--- /dev/null
+++ b/devel/py-prettytable/pkg-descr
@@ -0,0 +1,8 @@
+PrettyTable is a simple Python library designed to make it quick and
+easy to represent tabular data in visually appealing ASCII tables.
+It was inspired by the ASCII tables used in the PostgreSQL shell psql.
+PrettyTable allows for selection of which columns are to be printed,
+independent alignment of columns (left or right justified or centred)
+and printing of "sub-tables" by specifying a row range.
+
+WWW: http://pypi.python.org/pypi/PrettyTable
diff --git a/devel/py-prettytable/pkg-plist b/devel/py-prettytable/pkg-plist
new file mode 100644
index 000000000000..c22f898cbdf7
--- /dev/null
+++ b/devel/py-prettytable/pkg-plist
@@ -0,0 +1 @@
+%%PYTHON_SITELIBDIR%%/prettytable-%%VERSION%%-py%%PYVER%%.egg