aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzeising <zeising@FreeBSD.org>2012-07-30 02:26:00 +0800
committerzeising <zeising@FreeBSD.org>2012-07-30 02:26:00 +0800
commit5af749d5c82013c0b838b21891aa1ed45c1d33a5 (patch)
tree5ee8fd1ef51fc559a9ef5cca57a05abf4d5e8a58
parent4546b96d4e37d1baa348cc3b3f8bf62ed908ca0a (diff)
downloadfreebsd-ports-gnome-5af749d5c82013c0b838b21891aa1ed45c1d33a5.tar.gz
freebsd-ports-gnome-5af749d5c82013c0b838b21891aa1ed45c1d33a5.tar.zst
freebsd-ports-gnome-5af749d5c82013c0b838b21891aa1ed45c1d33a5.zip
Fix the build of xorg related ports when the base system is compiled with
clang as system compiler and cpp is clang cpp (as opposed to GNU cpp). This is done by removing the configure test for cpp completely. Using clang cpp will make some manual pages as well as some scripts get slightly wierd whitespace formatting. However, it does not affect the function of the scripts or the instructions in the manual pages. PR: ports/166373 Submitted by: Jakub Lach <jakub_lach@mailplus.pl> (PR) Patch by: me (with ideas from PR and mailing list) Tested by: Jakub Lach <jakub_lach@mailplus.pl>, me Approved by: kwm (mentor) Obtained from: xorg staging area
-rw-r--r--x11-drivers/xf86-video-sis/Makefile4
-rw-r--r--x11-servers/xorg-server/Makefile4
-rw-r--r--x11-toolkits/libXt/Makefile4
-rw-r--r--x11/libX11/Makefile3
-rw-r--r--x11/xinit/Makefile1
5 files changed, 16 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-sis/Makefile b/x11-drivers/xf86-video-sis/Makefile
index 2641c7ceb699..16f7899e94cb 100644
--- a/x11-drivers/xf86-video-sis/Makefile
+++ b/x11-drivers/xf86-video-sis/Makefile
@@ -20,4 +20,8 @@ XORG_CAT= driver
USE_XORG= xf86dgaproto xf86driproto xineramaproto videoproto xf86miscproto xextproto glproto
MAN4= sis.4x
+post-patch:
+ @${REINPLACE_CMD} 's/test.*-traditional.*;/true;/' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/x11-servers/xorg-server/Makefile b/x11-servers/xorg-server/Makefile
index 2e35ac81c929..9ceebe011750 100644
--- a/x11-servers/xorg-server/Makefile
+++ b/x11-servers/xorg-server/Makefile
@@ -148,6 +148,10 @@ pre-everything::
@${ECHO_MSG} "xorg-server_UNSET=SUID in /etc/make.conf."
.endif
+post-patch:
+ @${REINPLACE_CMD} 's/test.*-traditional.*;/true;/' \
+ ${WRKSRC}/configure
+
.if defined(WITH_NEW_XORG)
post-install:
@${MKDIR} ${PREFIX}/share/X11/xorg.conf.d
diff --git a/x11-toolkits/libXt/Makefile b/x11-toolkits/libXt/Makefile
index 0bfe440dec05..129c4d172d38 100644
--- a/x11-toolkits/libXt/Makefile
+++ b/x11-toolkits/libXt/Makefile
@@ -285,4 +285,8 @@ MAN3= MenuPopdown.3 \
XtWindowOfObject.3 \
XtWindowToWidget.3
+post-patch:
+ @${REINPLACE_CMD} 's/test.*-traditional.*;/true;/' \
+ ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/x11/libX11/Makefile b/x11/libX11/Makefile
index 76826561eb99..7b1f2faf3c34 100644
--- a/x11/libX11/Makefile
+++ b/x11/libX11/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/xcb.pc:${PORTSDIR}/x11/libxcb
XORG_CAT= lib
USE_XORG= bigreqsproto xau xcmiscproto xdmcp xextproto xtrans \
kbproto:both inputproto xf86bigfontproto xproto:both
+
CONFIGURE_ARGS+= --datadir=${PREFIX}/lib \
--without-xmlto \
--disable-specs
@@ -30,6 +31,8 @@ CONFIGURE_ENV+= ac_cv_path_PS2PDF=""
.include "${.CURDIR}/manpages"
post-patch:
+ @${REINPLACE_CMD} 's/test.*-traditional.*;/true;/' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} '/^install-data-am:/,/^$$/ \
s/install-specDATA//' ${WRKSRC}/nls/Makefile.in
diff --git a/x11/xinit/Makefile b/x11/xinit/Makefile
index 3bf4fc47fc78..52d388fe3d53 100644
--- a/x11/xinit/Makefile
+++ b/x11/xinit/Makefile
@@ -24,6 +24,7 @@ PLIST_DIRS= lib/X11/xinit
MAN1= startx.1 xinit.1
post-patch:
+ @${REINPLACE_CMD} 's/test.*-traditional.*;/true;/' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|hexdump|/usr/bin/hexdump|' ${WRKSRC}/startx.cpp
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/man/xinit.man