aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornbm <nbm@FreeBSD.org>2003-08-20 02:38:43 +0800
committernbm <nbm@FreeBSD.org>2003-08-20 02:38:43 +0800
commit5b9e87cd0a0f87dd790b67e83310f48c3a02faee (patch)
tree143c05e44ef0e2134b4030aa0b47c69f861b994b
parent159d3293709e4c07a74293a02729c02fb21af52b (diff)
downloadfreebsd-ports-gnome-5b9e87cd0a0f87dd790b67e83310f48c3a02faee.tar.gz
freebsd-ports-gnome-5b9e87cd0a0f87dd790b67e83310f48c3a02faee.tar.zst
freebsd-ports-gnome-5b9e87cd0a0f87dd790b67e83310f48c3a02faee.zip
Update pdmenu to 1.2.81, fix fetching problems.
PR: 53364 Submitted by: Mark Linimon <linimon@lonesome.com>
-rw-r--r--misc/pdmenu/Makefile10
-rw-r--r--misc/pdmenu/distinfo2
-rw-r--r--misc/pdmenu/files/patch-aa58
-rw-r--r--misc/pdmenu/files/patch-ab216
-rw-r--r--misc/pdmenu/files/patch-ac11
-rw-r--r--misc/pdmenu/files/patch-ad11
6 files changed, 145 insertions, 163 deletions
diff --git a/misc/pdmenu/Makefile b/misc/pdmenu/Makefile
index 78ccf641d4e9..635bcbf47c33 100644
--- a/misc/pdmenu/Makefile
+++ b/misc/pdmenu/Makefile
@@ -5,12 +5,11 @@
# $FreeBSD$
PORTNAME= pdmenu
-PORTVERSION= 1.2.65
+PORTVERSION= 1.2.81
CATEGORIES= misc
-# http://kitenet.net is unreachable for a long time now, asked the
-# author and maintaier for a known replacement - edwin 20021227
-MASTER_SITES= http://kitenet.net/programs/code/pdmenu/
+MASTER_SITES= http://kitenet.net/programs/pdmenu/
DISTNAME= pdmenu_${PORTVERSION}
+#BROKEN= "can't find required slang library or library is obsolete"
MAINTAINER= nbm@FreeBSD.org
COMMENT= A simple console menu program
@@ -24,10 +23,13 @@ WRKSRC= ${WRKDIR}/pdmenu
MAN1= pdmenu.1
MAN5= pdmenurc.5
+CC+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
CONFIGURE_ENV= SLANG_LIB_LOC='${PREFIX}/lib' \
SLANG_H_LOC='${PREFIX}/include/slang.h'
pre-install:
${MKDIR} ${PREFIX}/lib/pdmenu
+ ${MKDIR} ${PREFIX}/share/pdmenu
.include <bsd.port.mk>
diff --git a/misc/pdmenu/distinfo b/misc/pdmenu/distinfo
index eaebd684e3a3..d36c81242dfa 100644
--- a/misc/pdmenu/distinfo
+++ b/misc/pdmenu/distinfo
@@ -1 +1 @@
-MD5 (pdmenu_1.2.65.tar.gz) = a48c6bd9de312eb91a4a6715c100e71e
+MD5 (pdmenu_1.2.81.tar.gz) = ca6a00583508358dec358f2561430298
diff --git a/misc/pdmenu/files/patch-aa b/misc/pdmenu/files/patch-aa
deleted file mode 100644
index 5dbf4668ecff..000000000000
--- a/misc/pdmenu/files/patch-aa
+++ /dev/null
@@ -1,58 +0,0 @@
---- configure.in.orig Thu Jan 14 17:49:38 1999
-+++ configure.in Thu Jan 14 17:50:06 1999
-@@ -36,6 +36,27 @@
- rmdir ./test/test2 2>/dev/null
- rmdir ./test 2>/dev/null
-
-+dnl If we cannot find terminfo, link with termcap.
-+Terminfo_Dirs="/usr/lib/terminfo \
-+ /usr/share/lib/terminfo \
-+ /usr/local/lib/terminfo"
-+TERMCAP=yes
-+AC_MSG_CHECKING(for terminfo)
-+for terminfo_dir in $Terminfo_Dirs
-+do
-+ if test -d $terminfo_dir; then
-+ AC_MSG_RESULT(found)
-+ TERMCAP=""
-+ break
-+ fi
-+done
-+if test "$TERMCAP"; then
-+ AC_MSG_RESULT(not found)
-+ AC_CHECK_LIB(termcap,tgetent)
-+ # Note that if this fails, we continue and make probably dies with
-+ # an error. Unless terminfo is hiding somewhere else..
-+fi
-+
- dnl Let the user specify an alternate location for the libs.
- dnl I have to add this to CFLAGS, instead of to LIBS, to placate
- dnl some compiler that wanted -L before -l .
-@@ -96,27 +117,6 @@
- fi
- else
- AC_MSG_WARN(pdmenu will be built without GPM mouse support.)
--fi
--
--dnl If we cannot find terminfo, link with termcap.
--Terminfo_Dirs="/usr/lib/terminfo \
-- /usr/share/lib/terminfo \
-- /usr/local/lib/terminfo"
--TERMCAP=yes
--AC_MSG_CHECKING(for terminfo)
--for terminfo_dir in $Terminfo_Dirs
--do
-- if test -d $terminfo_dir; then
-- AC_MSG_RESULT(found)
-- TERMCAP=""
-- break
-- fi
--done
--if test "$TERMCAP"; then
-- AC_MSG_RESULT(not found)
-- AC_CHECK_LIB(termcap,tgetent)
-- # Note that if this fails, we continue and make probably dies with
-- # an error. Unless terminfo is hiding somewhere else..
- fi
-
- AC_CHECK_PROG(DATE_PROG,date,yes,no)
diff --git a/misc/pdmenu/files/patch-ab b/misc/pdmenu/files/patch-ab
index 3df93e8da844..6047ba0dd4ba 100644
--- a/misc/pdmenu/files/patch-ab
+++ b/misc/pdmenu/files/patch-ab
@@ -1,146 +1,184 @@
---- configure.orig Tue Sep 7 01:19:45 1999
-+++ configure Fri Sep 10 13:26:38 1999
-@@ -890,6 +890,73 @@
- rmdir ./test/test2 2>/dev/null
- rmdir ./test 2>/dev/null
+--- configure.orig Sun Mar 9 00:32:55 2003
++++ configure Tue Aug 19 20:04:36 2003
+@@ -6062,6 +6062,92 @@
+ CFLAGS="-L$SLANG_LIB_LOC $CFLAGS"
+ fi
+Terminfo_Dirs="/usr/lib/terminfo \
+ /usr/share/lib/terminfo \
+ /usr/local/lib/terminfo"
+TERMCAP=yes
-+echo $ac_n "checking for terminfo""... $ac_c" 1>&6
-+echo "configure:840: checking for terminfo" >&5
++echo "$as_me:$LINENO: checking for terminfo" >&5
++echo $ECHO_N "checking for terminfo... $ECHO_C" >&6
+for terminfo_dir in $Terminfo_Dirs
+do
+ if test -d $terminfo_dir; then
-+ echo "$ac_t""found" 1>&6
++ echo "$as_me:$LINENO: result: found" >&5
++echo "${ECHO_T}found" >&6
+ TERMCAP=""
+ break
+ fi
+done
+if test "$TERMCAP"; then
-+ echo "$ac_t""not found" 1>&6
-+ echo $ac_n "checking for tgetent in -ltermcap""... $ac_c" 1>&6
-+echo "configure:852: checking for tgetent in -ltermcap" >&5
-+ac_lib_var=`echo termcap'_'tgetent | sed 'y%./+-%__p_%'`
-+if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
-+ echo $ac_n "(cached) $ac_c" 1>&6
++ echo "$as_me:$LINENO: result: not found" >&5
++echo "${ECHO_T}not found" >&6
++
++echo "$as_me:$LINENO: checking for tgetent in -ltermcap" >&5
++echo $ECHO_N "checking for tgetent in -ltermcap... $ECHO_C" >&6
++if test "${ac_cv_lib_termcap_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
+else
-+ ac_save_LIBS="$LIBS"
++ ac_check_lib_save_LIBS=$LIBS
+LIBS="-ltermcap $LIBS"
-+cat > conftest.$ac_ext <<EOF
-+#line 860 "configure"
-+#include "confdefs.h"
++cat >conftest.$ac_ext <<_ACEOF
++#line $LINENO "configure"
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
+/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
+/* We use char because int might match the return type of a gcc2
-+ builtin and then its argument prototype would still apply. */
-+char tgetent();
-+
-+int main() {
-+tgetent()
-+; return 0; }
-+EOF
-+if { (eval echo configure:871: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest; then
-+ rm -rf conftest*
-+ eval "ac_cv_lib_$ac_lib_var=yes"
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_termcap_tgetent=yes
+else
-+ echo "configure: failed program was:" >&5
-+ cat conftest.$ac_ext >&5
-+ rm -rf conftest*
-+ eval "ac_cv_lib_$ac_lib_var=no"
-+fi
-+rm -f conftest*
-+LIBS="$ac_save_LIBS"
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
+
++ac_cv_lib_termcap_tgetent=no
++fi
++rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
+fi
-+if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
-+ echo "$ac_t""yes" 1>&6
-+ ac_tr_lib=HAVE_LIB`echo termcap | sed -e 's/[^a-zA-Z0-9_]/_/g' \
-+ -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
-+ cat >> confdefs.h <<EOF
-+#define $ac_tr_lib 1
-+EOF
++echo "$as_me:$LINENO: result: $ac_cv_lib_termcap_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_termcap_tgetent" >&6
++if test $ac_cv_lib_termcap_tgetent = yes; then
++ cat >>confdefs.h <<_ACEOF
++#define HAVE_LIBTERMCAP 1
++_ACEOF
+
+ LIBS="-ltermcap $LIBS"
+
-+else
-+ echo "$ac_t""no" 1>&6
+fi
+
+ # Note that if this fails, we continue and make probably dies with
+ # an error. Unless terminfo is hiding somewhere else..
+fi
+
- if test "$SLANG_LIB_LOC" != "" ; then
- CFLAGS="-L$SLANG_LIB_LOC $CFLAGS"
- fi
-@@ -1756,73 +1823,6 @@
+
+ echo "$as_me:$LINENO: checking for SLsig_block_signals in -lslang" >&5
+ echo $ECHO_N "checking for SLsig_block_signals in -lslang... $ECHO_C" >&6
+@@ -7563,92 +7649,6 @@
+ { echo "$as_me:$LINENO: WARNING: pdmenu will be built without GPM mouse support." >&5
+ echo "$as_me: WARNING: pdmenu will be built without GPM mouse support." >&2;}
fi
- else
- echo "configure: warning: pdmenu will be built without GPM mouse support." 1>&2
-fi
-
-Terminfo_Dirs="/usr/lib/terminfo \
- /usr/share/lib/terminfo \
- /usr/local/lib/terminfo"
-TERMCAP=yes
--echo $ac_n "checking for terminfo""... $ac_c" 1>&6
--echo "configure:1767: checking for terminfo" >&5
+-echo "$as_me:$LINENO: checking for terminfo" >&5
+-echo $ECHO_N "checking for terminfo... $ECHO_C" >&6
-for terminfo_dir in $Terminfo_Dirs
-do
- if test -d $terminfo_dir; then
-- echo "$ac_t""found" 1>&6
+- echo "$as_me:$LINENO: result: found" >&5
+-echo "${ECHO_T}found" >&6
- TERMCAP=""
- break
- fi
-done
-if test "$TERMCAP"; then
-- echo "$ac_t""not found" 1>&6
-- echo $ac_n "checking for tgetent in -ltermcap""... $ac_c" 1>&6
--echo "configure:1779: checking for tgetent in -ltermcap" >&5
--ac_lib_var=`echo termcap'_'tgetent | sed 'y%./+-%__p_%'`
--if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
-- echo $ac_n "(cached) $ac_c" 1>&6
+- echo "$as_me:$LINENO: result: not found" >&5
+-echo "${ECHO_T}not found" >&6
+-
+-echo "$as_me:$LINENO: checking for tgetent in -ltermcap" >&5
+-echo $ECHO_N "checking for tgetent in -ltermcap... $ECHO_C" >&6
+-if test "${ac_cv_lib_termcap_tgetent+set}" = set; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
-else
-- ac_save_LIBS="$LIBS"
+- ac_check_lib_save_LIBS=$LIBS
-LIBS="-ltermcap $LIBS"
--cat > conftest.$ac_ext <<EOF
--#line 1787 "configure"
--#include "confdefs.h"
+-cat >conftest.$ac_ext <<_ACEOF
+-#line $LINENO "configure"
+-/* confdefs.h. */
+-_ACEOF
+-cat confdefs.h >>conftest.$ac_ext
+-cat >>conftest.$ac_ext <<_ACEOF
+-/* end confdefs.h. */
+-
-/* Override any gcc2 internal prototype to avoid an error. */
+-#ifdef __cplusplus
+-extern "C"
+-#endif
-/* We use char because int might match the return type of a gcc2
-- builtin and then its argument prototype would still apply. */
--char tgetent();
--
--int main() {
--tgetent()
--; return 0; }
--EOF
--if { (eval echo configure:1798: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
-- rm -rf conftest*
-- eval "ac_cv_lib_$ac_lib_var=yes"
+- builtin and then its argument prototype would still apply. */
+-char tgetent ();
+-int
+-main ()
+-{
+-tgetent ();
+- ;
+- return 0;
+-}
+-_ACEOF
+-rm -f conftest.$ac_objext conftest$ac_exeext
+-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); } &&
+- { ac_try='test -s conftest$ac_exeext'
+- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+- (eval $ac_try) 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; }; then
+- ac_cv_lib_termcap_tgetent=yes
-else
-- echo "configure: failed program was:" >&5
-- cat conftest.$ac_ext >&5
-- rm -rf conftest*
-- eval "ac_cv_lib_$ac_lib_var=no"
--fi
--rm -f conftest*
--LIBS="$ac_save_LIBS"
+- echo "$as_me: failed program was:" >&5
+-sed 's/^/| /' conftest.$ac_ext >&5
-
+-ac_cv_lib_termcap_tgetent=no
-fi
--if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
-- echo "$ac_t""yes" 1>&6
-- ac_tr_lib=HAVE_LIB`echo termcap | sed -e 's/[^a-zA-Z0-9_]/_/g' \
-- -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
-- cat >> confdefs.h <<EOF
--#define $ac_tr_lib 1
--EOF
+-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
+-LIBS=$ac_check_lib_save_LIBS
+-fi
+-echo "$as_me:$LINENO: result: $ac_cv_lib_termcap_tgetent" >&5
+-echo "${ECHO_T}$ac_cv_lib_termcap_tgetent" >&6
+-if test $ac_cv_lib_termcap_tgetent = yes; then
+- cat >>confdefs.h <<_ACEOF
+-#define HAVE_LIBTERMCAP 1
+-_ACEOF
-
- LIBS="-ltermcap $LIBS"
-
--else
-- echo "$ac_t""no" 1>&6
-fi
-
- # Note that if this fails, we continue and make probably dies with
diff --git a/misc/pdmenu/files/patch-ac b/misc/pdmenu/files/patch-ac
deleted file mode 100644
index fa58b25bd8ae..000000000000
--- a/misc/pdmenu/files/patch-ac
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./autoconf/makeinfo.in.orig Sun Oct 20 13:39:21 2002
-+++ ./autoconf/makeinfo.in Sun Oct 20 13:39:28 2002
-@@ -16,7 +16,7 @@
- VER = @VER@
- DEFINES = -DETCDIR=\"${SYSCONFDIR}/\" -DVER=\"${VER}\" @DEFS@ \
- $(PROFILE) -D__USE_FIXED_PROTOTYPES__ -D_GNU_SOURCE
--CFLAGS_FOR_GCC = -Wall -fstrict-prototypes
-+CFLAGS_FOR_GCC = -Wall
- CFLAGS = $(DEFINES) @gcc_cflags@ @CFLAGS@
- LIBS = @LIBS@ $(EFENCE)
- SRCDIR = src
diff --git a/misc/pdmenu/files/patch-ad b/misc/pdmenu/files/patch-ad
new file mode 100644
index 000000000000..d5a368d79274
--- /dev/null
+++ b/misc/pdmenu/files/patch-ad
@@ -0,0 +1,11 @@
+--- Makefile.orig Tue Aug 19 20:22:23 2003
++++ Makefile Tue Aug 19 20:22:35 2003
+@@ -11,7 +11,7 @@
+ $(SRCDIR)/window.o $(SRCDIR)/error.o $(SRCDIR)/pdgetline.o
+
+ pdmenu: .dep $(OBJFILES)
+- ${CC} -o pdmenu $(OBJFILES) $(CFLAGS) $(LIBS)
++ ${CC} -o pdmenu $(OBJFILES) $(CFLAGS) $(LIBS) -lintl
+
+ depend: .dep
+ dep: .dep