aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2007-03-26 01:07:40 +0800
committerhrs <hrs@FreeBSD.org>2007-03-26 01:07:40 +0800
commit5d7304e9f1085bbd6727faa540f1402891ad8820 (patch)
treead851fd0847ce64b0e7b91c2ddf6a4c1003d919c
parentf79b8c3335c87ea1ddc5f1c64dd1965a6861f75f (diff)
downloadfreebsd-ports-gnome-5d7304e9f1085bbd6727faa540f1402891ad8820.tar.gz
freebsd-ports-gnome-5d7304e9f1085bbd6727faa540f1402891ad8820.tar.zst
freebsd-ports-gnome-5d7304e9f1085bbd6727faa540f1402891ad8820.zip
- Split the etc/fonts/conf.d/2.ipa-ttfonts.conf file into
20-unhint-ipattfonts.conf and 62-fonts-ipattfonts.conf[1]. - Fix wrong handling of fonts.dir in pkg-install[2]. - Bump PORTREVISION. PR: ports/110539[1] Submitted by: NIIMI Satoshi[1] Spotted by: nork[2]
-rw-r--r--japanese/font-ipa/Makefile5
-rw-r--r--japanese/font-ipa/files/20-unhint-ipattfonts.conf23
-rw-r--r--japanese/font-ipa/files/62-fonts-ipattfonts.conf (renamed from japanese/font-ipa/files/2.ipa-ttfonts.conf)21
-rw-r--r--japanese/font-ipa/files/pkg-install.in2
-rw-r--r--japanese/font-ipa/pkg-plist3
-rw-r--r--japanese/font-mplus-ipa/Makefile5
-rw-r--r--japanese/font-mplus-ipa/files/20-unhint-ipattfonts.conf23
-rw-r--r--japanese/font-mplus-ipa/files/62-fonts-ipattfonts.conf (renamed from japanese/font-mplus-ipa/files/2.ipa-ttfonts.conf)21
-rw-r--r--japanese/font-mplus-ipa/files/pkg-install.in2
-rw-r--r--japanese/font-mplus-ipa/pkg-plist3
-rw-r--r--japanese/ipa-ttfonts/Makefile5
-rw-r--r--japanese/ipa-ttfonts/files/20-unhint-ipattfonts.conf23
-rw-r--r--japanese/ipa-ttfonts/files/62-fonts-ipattfonts.conf (renamed from japanese/ipa-ttfonts/files/2.ipa-ttfonts.conf)21
-rw-r--r--japanese/ipa-ttfonts/files/pkg-install.in2
-rw-r--r--japanese/ipa-ttfonts/pkg-plist3
15 files changed, 87 insertions, 75 deletions
diff --git a/japanese/font-ipa/Makefile b/japanese/font-ipa/Makefile
index 97db34b95d31..62b81470db7d 100644
--- a/japanese/font-ipa/Makefile
+++ b/japanese/font-ipa/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ipa-ttfonts
PORTVERSION= 1.0.20060520
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= japanese x11-fonts
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
@@ -62,7 +62,8 @@ do-install:
${DATADIR}/fonts/M+*.ttf \
${PREFIX}/${X_FONTSDIR}/TrueType/
${MKDIR} ${PREFIX}/etc/fonts/conf.d
- ${INSTALL_DATA} ${FILESDIR}/2.ipa-ttfonts.conf \
+ ${INSTALL_DATA} ${FILESDIR}/20-unhint-ipattfonts.conf \
+ ${FILESDIR}/62-fonts-ipattfonts.conf \
${PREFIX}/etc/fonts/conf.d
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/japanese/font-ipa/files/20-unhint-ipattfonts.conf b/japanese/font-ipa/files/20-unhint-ipattfonts.conf
new file mode 100644
index 000000000000..d5d14d634b35
--- /dev/null
+++ b/japanese/font-ipa/files/20-unhint-ipattfonts.conf
@@ -0,0 +1,23 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<!-- $FreeBSD$ -->
+<fontconfig>
+ <match target="font">
+ <test name="family">
+ <string>IPAMincho</string>
+ <string>IPAGothic</string>
+ <string>IPAPMincho</string>
+ <string>IPAPGothic</string>
+ <string>IPAUIGothic</string>
+ <family>M+1P+IPAG</family>
+ <family>M+2P+IPAG</family>
+ <family>M+1P+IPAG circle</family>
+ <family>M+2P+IPAG circle</family>
+ <family>M+1VM+IPAG circle</family>
+ <family>M+2VM+IPAG circle</family>
+ </test>
+ <edit name="autohint">
+ <bool>false</bool>
+ </edit>
+ </match>
+</fontconfig>
diff --git a/japanese/font-ipa/files/2.ipa-ttfonts.conf b/japanese/font-ipa/files/62-fonts-ipattfonts.conf
index 88bcb42d4b9e..6f433bc8d232 100644
--- a/japanese/font-ipa/files/2.ipa-ttfonts.conf
+++ b/japanese/font-ipa/files/62-fonts-ipattfonts.conf
@@ -28,25 +28,4 @@
<family>M+2VM+IPAG circle</family>
</prefer>
</alias>
- <match target="font">
- <test name="family">
- <string>IPAMincho</string>
- <string>IPAGothic</string>
- <string>IPAPMincho</string>
- <string>IPAPGothic</string>
- <string>IPAUIGothic</string>
- <family>M+1P+IPAG</family>
- <family>M+2P+IPAG</family>
- <family>M+1P+IPAG circle</family>
- <family>M+2P+IPAG circle</family>
- <family>M+1VM+IPAG circle</family>
- <family>M+2VM+IPAG circle</family>
- </test>
- <edit name="hintstyle">
- <const>hintslight</const>
- </edit>
- <edit name="autohint">
- <bool>false</bool>
- </edit>
- </match>
</fontconfig>
diff --git a/japanese/font-ipa/files/pkg-install.in b/japanese/font-ipa/files/pkg-install.in
index 89333b5f81c8..2d0b746d890e 100644
--- a/japanese/font-ipa/files/pkg-install.in
+++ b/japanese/font-ipa/files/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
# $FreeBSD$
-X_FONTSDIR=%%X_FONTSDIR%%
+X_FONTSDIR=%%X_FONTSDIR%%/TrueType
catfontsdir ()
{
diff --git a/japanese/font-ipa/pkg-plist b/japanese/font-ipa/pkg-plist
index 65819fa03c92..6c8fbac6bca4 100644
--- a/japanese/font-ipa/pkg-plist
+++ b/japanese/font-ipa/pkg-plist
@@ -83,7 +83,8 @@
@dirrmtry %%LOCAL_FONTSDIR%%/TrueType
@dirrmtry %%LOCAL_FONTSDIR%%
@cwd %%X11BASE%%
-etc/fonts/conf.d/2.ipa-ttfonts.conf
+etc/fonts/conf.d/20-unhint-ipattfonts.conf
+etc/fonts/conf.d/62-fonts-ipattfonts.conf
%%X_FONTSDIR%%/TrueType/ipag.ttf
%%X_FONTSDIR%%/TrueType/ipagp.ttf
%%X_FONTSDIR%%/TrueType/ipagui.ttf
diff --git a/japanese/font-mplus-ipa/Makefile b/japanese/font-mplus-ipa/Makefile
index 97db34b95d31..62b81470db7d 100644
--- a/japanese/font-mplus-ipa/Makefile
+++ b/japanese/font-mplus-ipa/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ipa-ttfonts
PORTVERSION= 1.0.20060520
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= japanese x11-fonts
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
@@ -62,7 +62,8 @@ do-install:
${DATADIR}/fonts/M+*.ttf \
${PREFIX}/${X_FONTSDIR}/TrueType/
${MKDIR} ${PREFIX}/etc/fonts/conf.d
- ${INSTALL_DATA} ${FILESDIR}/2.ipa-ttfonts.conf \
+ ${INSTALL_DATA} ${FILESDIR}/20-unhint-ipattfonts.conf \
+ ${FILESDIR}/62-fonts-ipattfonts.conf \
${PREFIX}/etc/fonts/conf.d
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/japanese/font-mplus-ipa/files/20-unhint-ipattfonts.conf b/japanese/font-mplus-ipa/files/20-unhint-ipattfonts.conf
new file mode 100644
index 000000000000..d5d14d634b35
--- /dev/null
+++ b/japanese/font-mplus-ipa/files/20-unhint-ipattfonts.conf
@@ -0,0 +1,23 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<!-- $FreeBSD$ -->
+<fontconfig>
+ <match target="font">
+ <test name="family">
+ <string>IPAMincho</string>
+ <string>IPAGothic</string>
+ <string>IPAPMincho</string>
+ <string>IPAPGothic</string>
+ <string>IPAUIGothic</string>
+ <family>M+1P+IPAG</family>
+ <family>M+2P+IPAG</family>
+ <family>M+1P+IPAG circle</family>
+ <family>M+2P+IPAG circle</family>
+ <family>M+1VM+IPAG circle</family>
+ <family>M+2VM+IPAG circle</family>
+ </test>
+ <edit name="autohint">
+ <bool>false</bool>
+ </edit>
+ </match>
+</fontconfig>
diff --git a/japanese/font-mplus-ipa/files/2.ipa-ttfonts.conf b/japanese/font-mplus-ipa/files/62-fonts-ipattfonts.conf
index 88bcb42d4b9e..6f433bc8d232 100644
--- a/japanese/font-mplus-ipa/files/2.ipa-ttfonts.conf
+++ b/japanese/font-mplus-ipa/files/62-fonts-ipattfonts.conf
@@ -28,25 +28,4 @@
<family>M+2VM+IPAG circle</family>
</prefer>
</alias>
- <match target="font">
- <test name="family">
- <string>IPAMincho</string>
- <string>IPAGothic</string>
- <string>IPAPMincho</string>
- <string>IPAPGothic</string>
- <string>IPAUIGothic</string>
- <family>M+1P+IPAG</family>
- <family>M+2P+IPAG</family>
- <family>M+1P+IPAG circle</family>
- <family>M+2P+IPAG circle</family>
- <family>M+1VM+IPAG circle</family>
- <family>M+2VM+IPAG circle</family>
- </test>
- <edit name="hintstyle">
- <const>hintslight</const>
- </edit>
- <edit name="autohint">
- <bool>false</bool>
- </edit>
- </match>
</fontconfig>
diff --git a/japanese/font-mplus-ipa/files/pkg-install.in b/japanese/font-mplus-ipa/files/pkg-install.in
index 89333b5f81c8..2d0b746d890e 100644
--- a/japanese/font-mplus-ipa/files/pkg-install.in
+++ b/japanese/font-mplus-ipa/files/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
# $FreeBSD$
-X_FONTSDIR=%%X_FONTSDIR%%
+X_FONTSDIR=%%X_FONTSDIR%%/TrueType
catfontsdir ()
{
diff --git a/japanese/font-mplus-ipa/pkg-plist b/japanese/font-mplus-ipa/pkg-plist
index 65819fa03c92..6c8fbac6bca4 100644
--- a/japanese/font-mplus-ipa/pkg-plist
+++ b/japanese/font-mplus-ipa/pkg-plist
@@ -83,7 +83,8 @@
@dirrmtry %%LOCAL_FONTSDIR%%/TrueType
@dirrmtry %%LOCAL_FONTSDIR%%
@cwd %%X11BASE%%
-etc/fonts/conf.d/2.ipa-ttfonts.conf
+etc/fonts/conf.d/20-unhint-ipattfonts.conf
+etc/fonts/conf.d/62-fonts-ipattfonts.conf
%%X_FONTSDIR%%/TrueType/ipag.ttf
%%X_FONTSDIR%%/TrueType/ipagp.ttf
%%X_FONTSDIR%%/TrueType/ipagui.ttf
diff --git a/japanese/ipa-ttfonts/Makefile b/japanese/ipa-ttfonts/Makefile
index 97db34b95d31..62b81470db7d 100644
--- a/japanese/ipa-ttfonts/Makefile
+++ b/japanese/ipa-ttfonts/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ipa-ttfonts
PORTVERSION= 1.0.20060520
-PORTREVISION= 0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= japanese x11-fonts
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
@@ -62,7 +62,8 @@ do-install:
${DATADIR}/fonts/M+*.ttf \
${PREFIX}/${X_FONTSDIR}/TrueType/
${MKDIR} ${PREFIX}/etc/fonts/conf.d
- ${INSTALL_DATA} ${FILESDIR}/2.ipa-ttfonts.conf \
+ ${INSTALL_DATA} ${FILESDIR}/20-unhint-ipattfonts.conf \
+ ${FILESDIR}/62-fonts-ipattfonts.conf \
${PREFIX}/etc/fonts/conf.d
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/japanese/ipa-ttfonts/files/20-unhint-ipattfonts.conf b/japanese/ipa-ttfonts/files/20-unhint-ipattfonts.conf
new file mode 100644
index 000000000000..d5d14d634b35
--- /dev/null
+++ b/japanese/ipa-ttfonts/files/20-unhint-ipattfonts.conf
@@ -0,0 +1,23 @@
+<?xml version="1.0"?>
+<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
+<!-- $FreeBSD$ -->
+<fontconfig>
+ <match target="font">
+ <test name="family">
+ <string>IPAMincho</string>
+ <string>IPAGothic</string>
+ <string>IPAPMincho</string>
+ <string>IPAPGothic</string>
+ <string>IPAUIGothic</string>
+ <family>M+1P+IPAG</family>
+ <family>M+2P+IPAG</family>
+ <family>M+1P+IPAG circle</family>
+ <family>M+2P+IPAG circle</family>
+ <family>M+1VM+IPAG circle</family>
+ <family>M+2VM+IPAG circle</family>
+ </test>
+ <edit name="autohint">
+ <bool>false</bool>
+ </edit>
+ </match>
+</fontconfig>
diff --git a/japanese/ipa-ttfonts/files/2.ipa-ttfonts.conf b/japanese/ipa-ttfonts/files/62-fonts-ipattfonts.conf
index 88bcb42d4b9e..6f433bc8d232 100644
--- a/japanese/ipa-ttfonts/files/2.ipa-ttfonts.conf
+++ b/japanese/ipa-ttfonts/files/62-fonts-ipattfonts.conf
@@ -28,25 +28,4 @@
<family>M+2VM+IPAG circle</family>
</prefer>
</alias>
- <match target="font">
- <test name="family">
- <string>IPAMincho</string>
- <string>IPAGothic</string>
- <string>IPAPMincho</string>
- <string>IPAPGothic</string>
- <string>IPAUIGothic</string>
- <family>M+1P+IPAG</family>
- <family>M+2P+IPAG</family>
- <family>M+1P+IPAG circle</family>
- <family>M+2P+IPAG circle</family>
- <family>M+1VM+IPAG circle</family>
- <family>M+2VM+IPAG circle</family>
- </test>
- <edit name="hintstyle">
- <const>hintslight</const>
- </edit>
- <edit name="autohint">
- <bool>false</bool>
- </edit>
- </match>
</fontconfig>
diff --git a/japanese/ipa-ttfonts/files/pkg-install.in b/japanese/ipa-ttfonts/files/pkg-install.in
index 89333b5f81c8..2d0b746d890e 100644
--- a/japanese/ipa-ttfonts/files/pkg-install.in
+++ b/japanese/ipa-ttfonts/files/pkg-install.in
@@ -1,7 +1,7 @@
#!/bin/sh
# $FreeBSD$
-X_FONTSDIR=%%X_FONTSDIR%%
+X_FONTSDIR=%%X_FONTSDIR%%/TrueType
catfontsdir ()
{
diff --git a/japanese/ipa-ttfonts/pkg-plist b/japanese/ipa-ttfonts/pkg-plist
index 65819fa03c92..6c8fbac6bca4 100644
--- a/japanese/ipa-ttfonts/pkg-plist
+++ b/japanese/ipa-ttfonts/pkg-plist
@@ -83,7 +83,8 @@
@dirrmtry %%LOCAL_FONTSDIR%%/TrueType
@dirrmtry %%LOCAL_FONTSDIR%%
@cwd %%X11BASE%%
-etc/fonts/conf.d/2.ipa-ttfonts.conf
+etc/fonts/conf.d/20-unhint-ipattfonts.conf
+etc/fonts/conf.d/62-fonts-ipattfonts.conf
%%X_FONTSDIR%%/TrueType/ipag.ttf
%%X_FONTSDIR%%/TrueType/ipagp.ttf
%%X_FONTSDIR%%/TrueType/ipagui.ttf