aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordumbbell <dumbbell@FreeBSD.org>2014-06-02 02:52:21 +0800
committerdumbbell <dumbbell@FreeBSD.org>2014-06-02 02:52:21 +0800
commit63c1d21467f1606c55dcf81d59fb83dc6cb9c24e (patch)
tree8ec2ca33804839c04e009318f68190bcbed91f64
parent0fe0f7dcc54c69991e35937db2ef56c747549dcb (diff)
downloadfreebsd-ports-gnome-63c1d21467f1606c55dcf81d59fb83dc6cb9c24e.tar.gz
freebsd-ports-gnome-63c1d21467f1606c55dcf81d59fb83dc6cb9c24e.tar.zst
freebsd-ports-gnome-63c1d21467f1606c55dcf81d59fb83dc6cb9c24e.zip
graphics/darktable: Update to 1.4.2
The following changes were made to options: o Remove GCC option (see below) o Remove KWALLET option (unused) o Rename FACEBOOK option to FB_PICASA, because both export features depend on json-glib. o Add COLORD option (color management) o Add GRAPHMAGICK option (support GraphicsMagick's image formats) o Add LUA option (embed Lua to add scripting) o Add OPENEXR option (support HDR image format) o Add SQUISH option (use libsquish to compress thumbnails) o Add WEBP option (support WebP image format) The patch enables more options by default, because I think it's more sensible for a photographer using binary packages: o COLORD o FB_PICASA o FLICKR o GEO o GPHOTO (already on) o LUA o NLS o OPENEXR o OPENJPEG o RAWSPEED (already on) o WEBP The GCC option was removed because the usage of GCC along with libc++ in FreeBSD 10 and -CURRENT is unstable (this isn't a general truth, just valid in the case of darktable). In FreeBSD up-to 9, the usage of lang/gcc is mandatory anyway, because GCC 4.2.1 support is best effort only (upstream). Ninja is now used to build darktable, instead of make. This is not mandatory of course, but brings a 33% build time improvement (at least for me). pkg-plist is generated with "make makeplist" this time. That's why the diff seems large. In fact most of the content remains the same, just with a different order. All patches were committed upstream and are removed, except one which comes from upstream but isn't part of release 1.4.2. The port is now "stagified". Finally, I take maintainership of it. PR: ports/186979 Phabricator: D107 Reviewed by: danfe@ (previous version), antoine@ Approved by: antoine@
-rw-r--r--Mk/bsd.options.desc.mk1
-rw-r--r--graphics/darktable/Makefile101
-rw-r--r--graphics/darktable/distinfo4
-rw-r--r--graphics/darktable/files/patch-cmake_modules_FindFreetype.cmake11
-rw-r--r--graphics/darktable/files/patch-src-CMakeLists.txt15
-rw-r--r--graphics/darktable/files/patch-src-common-imageio_exr.hh24
-rw-r--r--graphics/darktable/pkg-plist245
7 files changed, 213 insertions, 188 deletions
diff --git a/Mk/bsd.options.desc.mk b/Mk/bsd.options.desc.mk
index 5e8108853270..6426668be801 100644
--- a/Mk/bsd.options.desc.mk
+++ b/Mk/bsd.options.desc.mk
@@ -46,6 +46,7 @@ CDIO_DESC?= CDIO support via libcdio
CDPARANOIA_DESC?= CD ripping support (cdparanoia)
CELT_DESC?= CELT audio codec support
CFITSIO_DESC?= FITS support via CFITSIO
+COLORD_DESC?= Color management via colord
COMPOSITE_DESC?= X11 Composite extension support
COOKIE_DESC?= Cookie support
CUE_DESC?= Embedded CUE sheets support
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 8829f6997619..7c0abb73da92 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -2,19 +2,17 @@
# $FreeBSD$
PORTNAME= darktable
-PORTVERSION= 1.2.3
-PORTREVISION= 6
+PORTVERSION= 1.4.2
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:R}
-MAINTAINER= danfe@FreeBSD.org
+MAINTAINER= dumbbell@FreeBSD.org
COMMENT= Virtual lighttable and darkroom for photographers
LICENSE= GPLv3
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2 \
- libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
liblensfun.so:${PORTSDIR}/graphics/lensfun \
liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libcurl.so:${PORTSDIR}/ftp/curl
@@ -22,27 +20,29 @@ LIB_DEPENDS= libexiv2.so:${PORTSDIR}/graphics/exiv2 \
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= uses SSE extensions
-USES= cmake:outsource pkgconfig tar:xz
+USES= cmake:outsource pkgconfig tar:xz ninja desktop-file-utils
USE_GNOME= librsvg2
USE_SQLITE= yes
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
INSTALLS_ICONS= yes
-MAN1= ${PORTNAME}.1
LDFLAGS+= -L${LOCALBASE}/lib -lintl
-OPTIONS_DEFINE= GPHOTO GEO FLICKR FACEBOOK KWALLET GNOMEKEYRING RAWSPEED \
- OPENJPEG SLIDESHOW NLS GCC
+OPTIONS_DEFINE= COLORD DOCS FB_PICASA FLICKR GEO GNOMEKEYRING GPHOTO \
+ GRAPHMAGICK LUA NLS OPENEXR OPENJPEG RAWSPEED SLIDESHOW \
+ SQUISH WEBP
-GEO_DESC= Geotagging support
-FACEBOOK_DESC= Support images export to Facebook
+GEO_DESC= Support geotagging
+FB_PICASA_DESC= Support export to Facebook and Picasa
+SQUISH_DESC= Compress thumbnail via libsquish
RAWSPEED_DESC= Compile with rawspeed backend
SLIDESHOW_DESC= Build OpenGL/SDL slideshow viewer
-GCC_DESC= Build with modern GCC (better OpenMP support)
-OPTIONS_DEFAULT= GPHOTO RAWSPEED #GCC
+OPTIONS_DEFAULT=COLORD FB_PICASA FLICKR GEO GPHOTO LUA NLS OPENEXR \
+ OPENJPEG RAWSPEED WEBP
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+CMAKE_ARGS+= -DBINARY_PACKAGE_BUILD=1
+
+.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MGPHOTO}
LIB_DEPENDS+= libgphoto2.so:${PORTSDIR}/graphics/libgphoto2
@@ -71,19 +71,14 @@ PLIST_FILES+= lib/darktable/plugins/imageio/storage/libflickr.so
CMAKE_ARGS+= -DUSE_FLICKR:BOOL=OFF
.endif
-.if ${PORT_OPTIONS:MFACEBOOK}
+.if ${PORT_OPTIONS:MFB_PICASA}
LIB_DEPENDS+= libjson-glib-1.0.so:${PORTSDIR}/devel/json-glib
-PLIST_FILES+= lib/darktable/plugins/imageio/storage/libfacebook.so
+PLIST_FILES+= lib/darktable/plugins/imageio/storage/libfacebook.so \
+ lib/darktable/plugins/imageio/storage/libpicasa.so
.else
CMAKE_ARGS+= -DUSE_GLIBJSON:BOOL=OFF
.endif
-.if ${PORT_OPTIONS:MKWALLET}
-LIB_DEPENDS+= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
-.else
-CMAKE_ARGS+= -DUSE_KWALLET:BOOL=OFF
-.endif
-
.if ${PORT_OPTIONS:MGNOMEKEYRING}
LIB_DEPENDS+= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring
.else
@@ -94,6 +89,13 @@ CMAKE_ARGS+= -DUSE_GNOME_KEYRING:BOOL=OFF
CMAKE_ARGS+= -DDONT_USE_RAWSPEED:BOOL=ON
.endif
+.if ${PORT_OPTIONS:MOPENEXR}
+LIB_DEPENDS+= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR
+PLIST_FILES+= lib/darktable/plugins/imageio/format/libexr.so
+.else
+CMAKE_ARGS+= -DUSE_OPENEXR:BOOL=OFF
+.endif
+
.if ${PORT_OPTIONS:MOPENJPEG}
LIB_DEPENDS+= libopenjpeg.so:${PORTSDIR}/graphics/openjpeg15
PLIST_FILES+= lib/darktable/plugins/imageio/format/libj2k.so
@@ -101,6 +103,34 @@ PLIST_FILES+= lib/darktable/plugins/imageio/format/libj2k.so
CMAKE_ARGS+= -DUSE_OPENJPEG:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MCOLORD}
+# darktable 1.4 can use colord but provides its own libcolord,
+# statically linked to libdarktable.so.
+LIB_DEPENDS+= libcolord.so:${PORTSDIR}/graphics/colord
+.else
+CMAKE_ARGS+= -DUSE_COLORD:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MGRAPHMAGICK}
+LIB_DEPENDS+= libGraphicsMagick.so:${PORTSDIR}/graphics/GraphicsMagick13
+.else
+CMAKE_ARGS+= -DUSE_GRAPHICSMAGICK:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MLUA}
+USES+= lua
+PLIST_FILES+= %%DATADIR%%/lua/darktable/debug.lua \
+ %%DATADIR%%/luarc
+.else
+CMAKE_ARGS+= -DUSE_LUA:BOOL=OFF
+.endif
+
+.if ${PORT_OPTIONS:MSQUISH}
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libsquish.a:${PORTSDIR}/graphics/squish
+.else
+CMAKE_ARGS+= -DUSE_SQUISH:BOOL=OFF
+.endif
+
.if ${PORT_OPTIONS:MSLIDESHOW}
USE_GL= gl
USE_SDL= sdl
@@ -109,22 +139,21 @@ PLIST_FILES+= bin/darktable-viewer
CMAKE_ARGS+= -DBUILD_SLIDESHOW:BOOL=OFF
.endif
+.if ${PORT_OPTIONS:MWEBP}
+LIB_DEPENDS+= libwebp.so:${PORTSDIR}/graphics/webp
+PLIST_FILES+= lib/darktable/plugins/imageio/format/libwebp.so
+.else
+CMAKE_ARGS+= -DUSE_WEBP:BOOL=OFF
+.endif
+
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
.else
CMAKE_ARGS+= -DUSE_NLS:BOOL=OFF
.endif
-.if ${PORT_OPTIONS:MGCC}
+.if ${OSVERSION} < 1000000
USE_GCC= yes
-# libdarktable.so has parts written in C++ (built-in rawspeed and libraw)
-# and is linked to GCC 4.6's libstdc++. However CMake removes RPATH from
-# this library, and libstdc++ from base (GCC 4.2.1) is pulled at runtime,
-# preventing darktable from starting.
-#
-# To workaround this, link darktable executable with libstdc++ explicitly;
-# it still has the RPATH and the correct libstdc++ is pulled.
-LDFLAGS+= -lstdc++
.endif
post-patch:
@@ -133,12 +162,12 @@ post-patch:
# Do not install useless (to end-user) documentation; adjust manpages path
@${REINPLACE_CMD} -e '/DOC_FILES/d ; s,share/man/man1,man/man1,' \
${WRKSRC}/doc/CMakeLists.txt
-# Respect CFLAGS for release builds; remove `-g' from common CFLAGS which
-# are used for release builds as well
- @${REINPLACE_CMD} -e '/-O3/s,^,#, ; /-msse2/s, -g,,' \
- ${WRKSRC}/src/CMakeLists.txt
post-install:
+.if ! ${PORT_OPTIONS:MDOCS}
+ @${RM} ${STAGEDIR}${DOCSDIR}/darktablerc.html
+ @${RMDIR} ${STAGEDIR}${DOCSDIR}
+.endif
.if ! ${PORT_OPTIONS:MRAWSPEED}
@${REINPLACE_CMD} -e '/rawspeed/d' ${TMPPLIST}
.endif
@@ -146,4 +175,4 @@ post-install:
@${REINPLACE_CMD} -e '/LC_MESSAGES/d' ${TMPPLIST}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/darktable/distinfo b/graphics/darktable/distinfo
index 314f5bd1b123..3325393cd12c 100644
--- a/graphics/darktable/distinfo
+++ b/graphics/darktable/distinfo
@@ -1,2 +1,2 @@
-SHA256 (darktable-1.2.3.tar.xz) = 686b62e020c13e64d18c9b465742ddec8604cfee36e06c8858301735c29f7316
-SIZE (darktable-1.2.3.tar.xz) = 2348864
+SHA256 (darktable-1.4.2.tar.xz) = c1311a6e336007b85d21647652ebec3e26840248a968eab04ab5f0a56c2e0709
+SIZE (darktable-1.4.2.tar.xz) = 2836340
diff --git a/graphics/darktable/files/patch-cmake_modules_FindFreetype.cmake b/graphics/darktable/files/patch-cmake_modules_FindFreetype.cmake
deleted file mode 100644
index 5a85775d425e..000000000000
--- a/graphics/darktable/files/patch-cmake_modules_FindFreetype.cmake
+++ /dev/null
@@ -1,11 +0,0 @@
---- cmake/modules/FindFreetype.cmake.orig 2013-12-13 12:47:10.000000000 +0100
-+++ cmake/modules/FindFreetype.cmake 2013-12-13 12:47:42.000000000 +0100
-@@ -12,7 +12,7 @@
-
- # Include dir
- find_path(Freetype_INCLUDE_DIR
-- NAMES freetype/freetype.h
-+ NAMES freetype.h
- PATHS ${Freetype_PKGCONF_INCLUDE_DIRS}
- PATH_SUFFIXES freetype2
- )
diff --git a/graphics/darktable/files/patch-src-CMakeLists.txt b/graphics/darktable/files/patch-src-CMakeLists.txt
new file mode 100644
index 000000000000..bcd7473d43e3
--- /dev/null
+++ b/graphics/darktable/files/patch-src-CMakeLists.txt
@@ -0,0 +1,15 @@
+--- src/CMakeLists.txt
++++ src/CMakeLists.txt
+@@ -438,10 +438,10 @@ else()
+ endif()
+
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -msse2 -g")
+-set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -ffast-math ${MARCH}")
++set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -O3 -ffast-math -fno-finite-math-only ${MARCH}")
+ set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O0 -g")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -msse2 -g")
+-set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3 -ffast-math ${MARCH}")
++set(CMAKE_CXX_FLAGS_RELEASE "${CMAKE_CXX_FLAGS_RELEASE} -O3 -ffast-math -fno-finite-math-only ${MARCH}")
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O0 -g")
+ if(CMAKE_COMPILER_IS_GNUCC)
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mfpmath=sse")
diff --git a/graphics/darktable/files/patch-src-common-imageio_exr.hh b/graphics/darktable/files/patch-src-common-imageio_exr.hh
deleted file mode 100644
index 8e5a320a754b..000000000000
--- a/graphics/darktable/files/patch-src-common-imageio_exr.hh
+++ /dev/null
@@ -1,24 +0,0 @@
---- src/common/imageio_exr.hh.orig
-+++ src/common/imageio_exr.hh
-@@ -21,7 +21,11 @@
- #include "common/image.h"
- #include "common/mipmap_cache.h"
-
-+#if __cplusplus >= 201103L || defined(__clang__)
-+#include <memory>
-+#else
- #include <tr1/memory>
-+#endif
-
- #include <OpenEXR/ImfFrameBuffer.h>
- #include <OpenEXR/ImfTestFile.h>
-@@ -56,7 +60,11 @@ public:
- }
-
- uint32_t size;
-+#if __cplusplus >= 201103L || defined(__clang__)
-+ std::shared_ptr<uint8_t> data;
-+#else
- std::tr1::shared_ptr<uint8_t> data;
-+#endif
- };
diff --git a/graphics/darktable/pkg-plist b/graphics/darktable/pkg-plist
index ba3a80e46def..60858fc37fb4 100644
--- a/graphics/darktable/pkg-plist
+++ b/graphics/darktable/pkg-plist
@@ -1,105 +1,8 @@
bin/darktable
bin/darktable-cli
bin/darktable-cltest
-share/appdata/darktable.appdata.xml
-%%DATADIR%%/darktable.gtkrc
-%%DATADIR%%/darktablerc
-%%DATADIR%%/gdb_commands
-%%DATADIR%%/js/builder.js
-%%DATADIR%%/js/effects.js
-%%DATADIR%%/js/lightbox-web.js
-%%DATADIR%%/js/lightbox.js
-%%DATADIR%%/js/prototype.js
-%%DATADIR%%/js/scriptaculous.js
-%%DATADIR%%/kernels/atrous.cl
-%%DATADIR%%/kernels/basic.cl
-%%DATADIR%%/kernels/bilateral.cl
-%%DATADIR%%/kernels/blendop.cl
-%%DATADIR%%/kernels/colorspace.cl
-%%DATADIR%%/kernels/common.h
-%%DATADIR%%/kernels/demosaic_ppg.cl
-%%DATADIR%%/kernels/denoiseprofile.cl
-%%DATADIR%%/kernels/extended.cl
-%%DATADIR%%/kernels/gaussian.cl
-%%DATADIR%%/kernels/highpass.cl
-%%DATADIR%%/kernels/nlmeans.cl
-%%DATADIR%%/kernels/programs.conf
-%%DATADIR%%/kernels/sharpen.cl
-%%DATADIR%%/kernels/soften.cl
-%%DATADIR%%/latex/photobook.cls
-%%DATADIR%%/pixmaps/dt_logo_128x128.png
-%%DATADIR%%/pixmaps/idbutton.png
-%%DATADIR%%/pixmaps/off.png
-%%DATADIR%%/pixmaps/plugins/darkroom/anlfyeni.png
-%%DATADIR%%/pixmaps/plugins/darkroom/atrous.png
-%%DATADIR%%/pixmaps/plugins/darkroom/basecurve.png
-%%DATADIR%%/pixmaps/plugins/darkroom/bilateral.png
-%%DATADIR%%/pixmaps/plugins/darkroom/bloom.png
-%%DATADIR%%/pixmaps/plugins/darkroom/borders.png
-%%DATADIR%%/pixmaps/plugins/darkroom/cacorrect.png
-%%DATADIR%%/pixmaps/plugins/darkroom/channelmixer.png
-%%DATADIR%%/pixmaps/plugins/darkroom/clahe.png
-%%DATADIR%%/pixmaps/plugins/darkroom/clipping.png
-%%DATADIR%%/pixmaps/plugins/darkroom/colorcorrection.png
-%%DATADIR%%/pixmaps/plugins/darkroom/colorin.png
-%%DATADIR%%/pixmaps/plugins/darkroom/colorout.png
-%%DATADIR%%/pixmaps/plugins/darkroom/colortransfer.png
-%%DATADIR%%/pixmaps/plugins/darkroom/colorzones.png
-%%DATADIR%%/pixmaps/plugins/darkroom/demosaic.png
-%%DATADIR%%/pixmaps/plugins/darkroom/dither.png
-%%DATADIR%%/pixmaps/plugins/darkroom/exposure.png
-%%DATADIR%%/pixmaps/plugins/darkroom/flip.png
-%%DATADIR%%/pixmaps/plugins/darkroom/graduatednd.png
-%%DATADIR%%/pixmaps/plugins/darkroom/grain.png
-%%DATADIR%%/pixmaps/plugins/darkroom/highlights.png
-%%DATADIR%%/pixmaps/plugins/darkroom/highpass.png
-%%DATADIR%%/pixmaps/plugins/darkroom/hotpixels.png
-%%DATADIR%%/pixmaps/plugins/darkroom/invert.png
-%%DATADIR%%/pixmaps/plugins/darkroom/lens.png
-%%DATADIR%%/pixmaps/plugins/darkroom/levels.png
-%%DATADIR%%/pixmaps/plugins/darkroom/lowlight.png
-%%DATADIR%%/pixmaps/plugins/darkroom/lowpass.png
-%%DATADIR%%/pixmaps/plugins/darkroom/monochrome.png
-%%DATADIR%%/pixmaps/plugins/darkroom/nlmeans.png
-%%DATADIR%%/pixmaps/plugins/darkroom/overexposed.png
-%%DATADIR%%/pixmaps/plugins/darkroom/profile_gamma.png
-%%DATADIR%%/pixmaps/plugins/darkroom/rawdenoise.png
-%%DATADIR%%/pixmaps/plugins/darkroom/rawimport.png
-%%DATADIR%%/pixmaps/plugins/darkroom/relight.png
-%%DATADIR%%/pixmaps/plugins/darkroom/shadhi.png
-%%DATADIR%%/pixmaps/plugins/darkroom/sharpen.png
-%%DATADIR%%/pixmaps/plugins/darkroom/soften.png
-%%DATADIR%%/pixmaps/plugins/darkroom/splittoning.png
-%%DATADIR%%/pixmaps/plugins/darkroom/spots.png
-%%DATADIR%%/pixmaps/plugins/darkroom/temperature.png
-%%DATADIR%%/pixmaps/plugins/darkroom/template.png
-%%DATADIR%%/pixmaps/plugins/darkroom/tonecurve.png
-%%DATADIR%%/pixmaps/plugins/darkroom/tonemap.png
-%%DATADIR%%/pixmaps/plugins/darkroom/velvia.png
-%%DATADIR%%/pixmaps/plugins/darkroom/vignette.png
-%%DATADIR%%/pixmaps/plugins/darkroom/watermark.png
-%%DATADIR%%/pixmaps/plugins/darkroom/zonesystem.png
-%%DATADIR%%/rawspeed/cameras.xml
-%%DATADIR%%/rawspeed/showcameras.xsl
-%%DATADIR%%/style/bullet.gif
-%%DATADIR%%/style/close.gif
-%%DATADIR%%/style/closelabel.gif
-%%DATADIR%%/style/donate-button.gif
-%%DATADIR%%/style/download-icon.gif
-%%DATADIR%%/style/favicon.ico
-%%DATADIR%%/style/image-1.jpg
-%%DATADIR%%/style/lightbox.css
-%%DATADIR%%/style/loading.gif
-%%DATADIR%%/style/nextlabel.gif
-%%DATADIR%%/style/prevlabel.gif
-%%DATADIR%%/style/style.css
-%%DATADIR%%/style/thumb-1.jpg
-%%DATADIR%%/watermarks/darktable.svg
-%%DATADIR%%/watermarks/hasselblad.svg
-%%DATADIR%%/watermarks/promo.svg
lib/darktable/libdarktable.so
lib/darktable/plugins/imageio/format/libcopy.so
-lib/darktable/plugins/imageio/format/libexr.so
lib/darktable/plugins/imageio/format/libjpeg.so
lib/darktable/plugins/imageio/format/libpfm.so
lib/darktable/plugins/imageio/format/libpng.so
@@ -119,10 +22,13 @@ lib/darktable/plugins/libcacorrect.so
lib/darktable/plugins/libchannelmixer.so
lib/darktable/plugins/libclahe.so
lib/darktable/plugins/libclipping.so
+lib/darktable/plugins/libcolisa.so
+lib/darktable/plugins/libcolorbalance.so
lib/darktable/plugins/libcolorcontrast.so
lib/darktable/plugins/libcolorcorrection.so
lib/darktable/plugins/libcolorin.so
lib/darktable/plugins/libcolorize.so
+lib/darktable/plugins/libcolormapping.so
lib/darktable/plugins/libcolorout.so
lib/darktable/plugins/libcolortransfer.so
lib/darktable/plugins/libcolorzones.so
@@ -178,8 +84,8 @@ lib/darktable/plugins/lighttable/libhistogram.so
lib/darktable/plugins/lighttable/libhistory.so
lib/darktable/plugins/lighttable/libimage.so
lib/darktable/plugins/lighttable/libimport.so
-lib/darktable/plugins/lighttable/libkeywords.so
lib/darktable/plugins/lighttable/liblighttable_mode.so
+lib/darktable/plugins/lighttable/libmasks.so
lib/darktable/plugins/lighttable/libmetadata.so
lib/darktable/plugins/lighttable/libmetadata_view.so
lib/darktable/plugins/lighttable/libmodule_toolbox.so
@@ -196,7 +102,110 @@ lib/darktable/plugins/lighttable/libview_toolbox.so
lib/darktable/plugins/lighttable/libviewswitcher.so
lib/darktable/views/libdarkroom.so
lib/darktable/views/liblighttable.so
+man/man1/darktable-cli.1.gz
+man/man1/darktable.1.gz
+share/appdata/darktable.appdata.xml
share/applications/darktable.desktop
+%%DATADIR%%/darktable.gtkrc
+%%DATADIR%%/darktablerc
+%%DATADIR%%/gdb_commands
+%%DATADIR%%/js/builder.js
+%%DATADIR%%/js/effects.js
+%%DATADIR%%/js/lightbox-web.js
+%%DATADIR%%/js/lightbox.js
+%%DATADIR%%/js/prototype.js
+%%DATADIR%%/js/scriptaculous.js
+%%DATADIR%%/kernels/atrous.cl
+%%DATADIR%%/kernels/basic.cl
+%%DATADIR%%/kernels/bilateral.cl
+%%DATADIR%%/kernels/blendop.cl
+%%DATADIR%%/kernels/bloom.cl
+%%DATADIR%%/kernels/colorspace.cl
+%%DATADIR%%/kernels/common.h
+%%DATADIR%%/kernels/demosaic_ppg.cl
+%%DATADIR%%/kernels/denoiseprofile.cl
+%%DATADIR%%/kernels/extended.cl
+%%DATADIR%%/kernels/gaussian.cl
+%%DATADIR%%/kernels/highpass.cl
+%%DATADIR%%/kernels/nlmeans.cl
+%%DATADIR%%/kernels/programs.conf
+%%DATADIR%%/kernels/sharpen.cl
+%%DATADIR%%/kernels/soften.cl
+%%DATADIR%%/latex/photobook.cls
+%%DATADIR%%/pixmaps/dt_logo_128x128.png
+%%DATADIR%%/pixmaps/idbutton-2.png
+%%DATADIR%%/pixmaps/idbutton.png
+%%DATADIR%%/pixmaps/off.png
+%%DATADIR%%/pixmaps/plugins/darkroom/anlfyeni.png
+%%DATADIR%%/pixmaps/plugins/darkroom/atrous.png
+%%DATADIR%%/pixmaps/plugins/darkroom/basecurve.png
+%%DATADIR%%/pixmaps/plugins/darkroom/bilateral.png
+%%DATADIR%%/pixmaps/plugins/darkroom/bloom.png
+%%DATADIR%%/pixmaps/plugins/darkroom/borders.png
+%%DATADIR%%/pixmaps/plugins/darkroom/cacorrect.png
+%%DATADIR%%/pixmaps/plugins/darkroom/channelmixer.png
+%%DATADIR%%/pixmaps/plugins/darkroom/clahe.png
+%%DATADIR%%/pixmaps/plugins/darkroom/clipping.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colisa.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colorcorrection.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colorin.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colormapping.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colorout.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colortransfer.png
+%%DATADIR%%/pixmaps/plugins/darkroom/colorzones.png
+%%DATADIR%%/pixmaps/plugins/darkroom/demosaic.png
+%%DATADIR%%/pixmaps/plugins/darkroom/dither.png
+%%DATADIR%%/pixmaps/plugins/darkroom/exposure.png
+%%DATADIR%%/pixmaps/plugins/darkroom/flip.png
+%%DATADIR%%/pixmaps/plugins/darkroom/graduatednd.png
+%%DATADIR%%/pixmaps/plugins/darkroom/grain.png
+%%DATADIR%%/pixmaps/plugins/darkroom/highlights.png
+%%DATADIR%%/pixmaps/plugins/darkroom/highpass.png
+%%DATADIR%%/pixmaps/plugins/darkroom/hotpixels.png
+%%DATADIR%%/pixmaps/plugins/darkroom/invert.png
+%%DATADIR%%/pixmaps/plugins/darkroom/lens.png
+%%DATADIR%%/pixmaps/plugins/darkroom/levels.png
+%%DATADIR%%/pixmaps/plugins/darkroom/lowlight.png
+%%DATADIR%%/pixmaps/plugins/darkroom/lowpass.png
+%%DATADIR%%/pixmaps/plugins/darkroom/monochrome.png
+%%DATADIR%%/pixmaps/plugins/darkroom/nlmeans.png
+%%DATADIR%%/pixmaps/plugins/darkroom/overexposed.png
+%%DATADIR%%/pixmaps/plugins/darkroom/profile_gamma.png
+%%DATADIR%%/pixmaps/plugins/darkroom/rawdenoise.png
+%%DATADIR%%/pixmaps/plugins/darkroom/rawimport.png
+%%DATADIR%%/pixmaps/plugins/darkroom/relight.png
+%%DATADIR%%/pixmaps/plugins/darkroom/shadhi.png
+%%DATADIR%%/pixmaps/plugins/darkroom/sharpen.png
+%%DATADIR%%/pixmaps/plugins/darkroom/soften.png
+%%DATADIR%%/pixmaps/plugins/darkroom/splittoning.png
+%%DATADIR%%/pixmaps/plugins/darkroom/spots.png
+%%DATADIR%%/pixmaps/plugins/darkroom/temperature.png
+%%DATADIR%%/pixmaps/plugins/darkroom/template.png
+%%DATADIR%%/pixmaps/plugins/darkroom/tonecurve.png
+%%DATADIR%%/pixmaps/plugins/darkroom/tonemap.png
+%%DATADIR%%/pixmaps/plugins/darkroom/velvia.png
+%%DATADIR%%/pixmaps/plugins/darkroom/vignette.png
+%%DATADIR%%/pixmaps/plugins/darkroom/watermark.png
+%%DATADIR%%/pixmaps/plugins/darkroom/zonesystem.png
+%%DATADIR%%/rawspeed/cameras.xml
+%%DATADIR%%/rawspeed/showcameras.xsl
+%%DATADIR%%/style/bullet.gif
+%%DATADIR%%/style/close.gif
+%%DATADIR%%/style/closelabel.gif
+%%DATADIR%%/style/donate-button.gif
+%%DATADIR%%/style/download-icon.gif
+%%DATADIR%%/style/favicon.ico
+%%DATADIR%%/style/image-1.jpg
+%%DATADIR%%/style/lightbox.css
+%%DATADIR%%/style/loading.gif
+%%DATADIR%%/style/nextlabel.gif
+%%DATADIR%%/style/prevlabel.gif
+%%DATADIR%%/style/style.css
+%%DATADIR%%/style/thumb-1.jpg
+%%DATADIR%%/watermarks/darktable.svg
+%%DATADIR%%/watermarks/hasselblad.svg
+%%DATADIR%%/watermarks/promo.svg
+%%PORTDOCS%%%%DOCSDIR%%/darktablerc.html
share/icons/hicolor/16x16/apps/darktable.png
share/icons/hicolor/22x22/apps/darktable.png
share/icons/hicolor/24x24/apps/darktable.png
@@ -204,9 +213,12 @@ share/icons/hicolor/256x256/apps/darktable.png
share/icons/hicolor/32x32/apps/darktable.png
share/icons/hicolor/48x48/apps/darktable.png
share/icons/hicolor/64x64/apps/darktable.png
+share/icons/hicolor/scalable/apps/darktable-2.svg
share/icons/hicolor/scalable/apps/darktable.svg
+share/locale/cs/LC_MESSAGES/darktable.mo
share/locale/da/LC_MESSAGES/darktable.mo
share/locale/de/LC_MESSAGES/darktable.mo
+share/locale/el/LC_MESSAGES/darktable.mo
share/locale/es/LC_MESSAGES/darktable.mo
share/locale/fr/LC_MESSAGES/darktable.mo
share/locale/it/LC_MESSAGES/darktable.mo
@@ -219,21 +231,24 @@ share/locale/ru/LC_MESSAGES/darktable.mo
share/locale/sq/LC_MESSAGES/darktable.mo
share/locale/sv/LC_MESSAGES/darktable.mo
share/locale/uk/LC_MESSAGES/darktable.mo
-@dirrm lib/darktable/views
-@dirrm lib/darktable/plugins/lighttable
-@dirrm lib/darktable/plugins/imageio/storage
-@dirrm lib/darktable/plugins/imageio/format
-@dirrm lib/darktable/plugins/imageio
-@dirrm lib/darktable/plugins
-@dirrm lib/darktable
-@dirrm %%DATADIR%%/watermarks
-@dirrm %%DATADIR%%/style
-@dirrm %%DATADIR%%/rawspeed
-@dirrm %%DATADIR%%/pixmaps/plugins/darkroom
-@dirrm %%DATADIR%%/pixmaps/plugins
-@dirrm %%DATADIR%%/pixmaps
-@dirrm %%DATADIR%%/latex
-@dirrm %%DATADIR%%/kernels
-@dirrm %%DATADIR%%/js
-@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry %%DATADIR%%/watermarks
+@dirrmtry %%DATADIR%%/style
+@dirrmtry %%DATADIR%%/rawspeed
+@dirrmtry %%DATADIR%%/pixmaps/plugins/darkroom
+@dirrmtry %%DATADIR%%/pixmaps/plugins
+@dirrmtry %%DATADIR%%/pixmaps
+@dirrmtry %%DATADIR%%/lua/darktable
+@dirrmtry %%DATADIR%%/lua
+@dirrmtry %%DATADIR%%/latex
+@dirrmtry %%DATADIR%%/kernels
+@dirrmtry %%DATADIR%%/js
+@dirrmtry %%DATADIR%%
@dirrmtry share/appdata
+@dirrmtry lib/darktable/views
+@dirrmtry lib/darktable/plugins/lighttable
+@dirrmtry lib/darktable/plugins/imageio/storage
+@dirrmtry lib/darktable/plugins/imageio/format
+@dirrmtry lib/darktable/plugins/imageio
+@dirrmtry lib/darktable/plugins
+@dirrmtry lib/darktable