aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-10-21 10:10:23 +0800
committerswills <swills@FreeBSD.org>2013-10-21 10:10:23 +0800
commit65ef383c62c9202a318f6a04cb5d442ee27476da (patch)
tree992bd27dbe756d41249c4651b8b484d1ffc68c30
parent940f9005fff7fa1ac0e8f6b584caa509c3964118 (diff)
downloadfreebsd-ports-gnome-65ef383c62c9202a318f6a04cb5d442ee27476da.tar.gz
freebsd-ports-gnome-65ef383c62c9202a318f6a04cb5d442ee27476da.tar.zst
freebsd-ports-gnome-65ef383c62c9202a318f6a04cb5d442ee27476da.zip
A Google OAuth2 strategy for OmniAuth 1.x
WWW: https://rubygems.org/gems/omniauth-google-oauth2 PR: ports/182700 Submitted by: Loic Blot <loic.blot@unix-experience.fr>
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-omniauth-google-oauth2/Makefile20
-rw-r--r--net/rubygem-omniauth-google-oauth2/distinfo2
-rw-r--r--net/rubygem-omniauth-google-oauth2/pkg-descr3
4 files changed, 26 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index b233c2535a1f..e6dfb6573903 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1041,6 +1041,7 @@
SUBDIR += rubygem-oauth
SUBDIR += rubygem-oauth2
SUBDIR += rubygem-omniauth-github
+ SUBDIR += rubygem-omniauth-google-oauth2
SUBDIR += rubygem-omniauth-oauth
SUBDIR += rubygem-omniauth-oauth2
SUBDIR += rubygem-open-uri-cached
diff --git a/net/rubygem-omniauth-google-oauth2/Makefile b/net/rubygem-omniauth-google-oauth2/Makefile
new file mode 100644
index 000000000000..ce25a7f1dfab
--- /dev/null
+++ b/net/rubygem-omniauth-google-oauth2/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= omniauth-google-oauth2
+PORTVERSION= 0.2.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Google OAuth2 strategy for OmniAuth 1.x
+
+RUN_DEPENDS= rubygem-omniauth-oauth2>=0:${PORTSDIR}/net/rubygem-omniauth-oauth2 \
+ rubygem-omniauth>=1.0:${PORTSDIR}/security/rubygem-omniauth
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-omniauth-google-oauth2/distinfo b/net/rubygem-omniauth-google-oauth2/distinfo
new file mode 100644
index 000000000000..eedb1ab02d6c
--- /dev/null
+++ b/net/rubygem-omniauth-google-oauth2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/omniauth-google-oauth2-0.2.1.gem) = 0d2565e1c2b40a55e243aa237ba94b93ff095225735f4db25740b91ef8c60d85
+SIZE (rubygem/omniauth-google-oauth2-0.2.1.gem) = 12288
diff --git a/net/rubygem-omniauth-google-oauth2/pkg-descr b/net/rubygem-omniauth-google-oauth2/pkg-descr
new file mode 100644
index 000000000000..c28ada53c212
--- /dev/null
+++ b/net/rubygem-omniauth-google-oauth2/pkg-descr
@@ -0,0 +1,3 @@
+A Google OAuth2 strategy for OmniAuth 1.x
+
+WWW: https://rubygems.org/gems/omniauth-google-oauth2