aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-11-08 10:48:07 +0800
committermnag <mnag@FreeBSD.org>2005-11-08 10:48:07 +0800
commit6e176a6de2f5c894449faeb329e29da7ad74cab5 (patch)
tree769e286477bd860492ca04f71496d6e317e26217
parent24d077046fef54493c98c34197db76a677f99f29 (diff)
downloadfreebsd-ports-gnome-6e176a6de2f5c894449faeb329e29da7ad74cab5.tar.gz
freebsd-ports-gnome-6e176a6de2f5c894449faeb329e29da7ad74cab5.tar.zst
freebsd-ports-gnome-6e176a6de2f5c894449faeb329e29da7ad74cab5.zip
Use mkstemp() instead of mktemp()
Bump PORTREVISION PR: 88633 Submitted by: chinsan <chinsan.tw@gmail.com>
-rw-r--r--ftp/pftpd/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/ftp/pftpd/Makefile b/ftp/pftpd/Makefile
index f67361a767ac..31f069b2475d 100644
--- a/ftp/pftpd/Makefile
+++ b/ftp/pftpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pftpd
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= ftp
MASTER_SITES= ftp://ftp.lysator.liu.se/pub/unix/pftpd/ \
ftp://ftp.ifm.liu.se/pub/unix/pftpd/
@@ -16,6 +17,7 @@ COMMENT= Multithreaded anonymous FTP daemon
GNU_CONFIGURE= yes
USE_REINPLACE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= pftpd.1 rpad.1
PLIST_FILES= sbin/pftpd
@@ -26,6 +28,8 @@ post-extract:
.endfor
post-patch:
+ @${REINPLACE_CMD} -e 's|mktemp|mkstemp|g' \
+ ${WRKSRC}/src/rpa.c
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/configure \
${WRKSRC}/plib/configure