aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-07-27 03:20:45 +0800
committerjylefort <jylefort@FreeBSD.org>2005-07-27 03:20:45 +0800
commit6e7d6c75640f6da8365f53999c96315c6ee6002e (patch)
tree579d2795e3168de9e3cbf6ca0d086918f160e390
parent9162d43987cca8255dee5f18c084ba17585e2df3 (diff)
downloadfreebsd-ports-gnome-6e7d6c75640f6da8365f53999c96315c6ee6002e.tar.gz
freebsd-ports-gnome-6e7d6c75640f6da8365f53999c96315c6ee6002e.tar.zst
freebsd-ports-gnome-6e7d6c75640f6da8365f53999c96315c6ee6002e.zip
- Fix build when WITH_GNOMEVFS2 is set [1]
- Install the GnomeVFS module in ${X11BASE}, where GnomeVFS will look for it - Use USE_GCC=3.4+ rather than USE_GCC=3.4 - Remove useless USE_CONFIGURE - Fix the GnomeVFS spelling in the OPTIONS help Submitted by: John Merryweather Cooper <john_m_cooper@yahoo.com> [1]
-rw-r--r--sysutils/ntfsprogs/Makefile10
-rw-r--r--sysutils/ntfsprogs/pkg-plist11
2 files changed, 13 insertions, 8 deletions
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index 5604b80b7d84..41890c299763 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -16,15 +16,15 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Utilities and library to manipulate NTFS partitions
GNU_CONFIGURE= yes
-USE_GCC= 3.4
+USE_GCC= 3.4+
USE_REINPLACE= yes
USE_GETOPT_LONG=yes
-USE_CONFIGURE= yes
+WANT_GNOME= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-OPTIONS= GNOMEVFS2 "Install Gnome-VFS-2.0 libntfs interface" off
+OPTIONS= GNOMEVFS2 "Install GnomeVFS 2.0 libntfs interface" off
MAN8= libntfs-gnomevfs.8 \
mkntfs.8 \
@@ -53,5 +53,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|^transform.*||' ${WRKSRC}/Makefile.in \
${WRKSRC}/libntfs/Makefile.in \
${WRKSRC}/ntfsprogs/Makefile.in
+ @${REINPLACE_CMD} -e \
+ 's|$$(libdir)/\(gnome-vfs-2.0/modules\)|${X11BASE}/lib/\1|; \
+ s|$$(sysconfdir)/\(gnome-vfs-2.0/modules\)|${X11BASE}/etc/\1|' \
+ ${WRKSRC}/libntfs/Makefile.in
.include <bsd.port.post.mk>
diff --git a/sysutils/ntfsprogs/pkg-plist b/sysutils/ntfsprogs/pkg-plist
index 4a022e935b87..92ebb1a25e0c 100644
--- a/sysutils/ntfsprogs/pkg-plist
+++ b/sysutils/ntfsprogs/pkg-plist
@@ -3,7 +3,6 @@ bin/ntfscluster
bin/ntfsfix
bin/ntfsinfo
bin/ntfsls
-%%GNOMEVFS2%%etc/gnome-vfs-2.0/modules/libntfs.conf
include/ntfs/attrib.h
include/ntfs/attrlist.h
include/ntfs/bitmap.h
@@ -30,10 +29,6 @@ include/ntfs/support.h
include/ntfs/types.h
include/ntfs/unistr.h
include/ntfs/volume.h
-%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.a
-%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.la
-%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.so
-%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.so.1
lib/libntfs.a
lib/libntfs.la
lib/libntfs.so
@@ -44,3 +39,9 @@ sbin/ntfslabel
sbin/ntfsresize
sbin/ntfsundelete
@dirrm include/ntfs
+%%GNOMEVFS2%%@cwd %%X11BASE%%
+%%GNOMEVFS2%%etc/gnome-vfs-2.0/modules/libntfs.conf
+%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.a
+%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.la
+%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.so
+%%GNOMEVFS2%%lib/gnome-vfs-2.0/modules/libntfs-gnomevfs.so.1