aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorroberto <roberto@FreeBSD.org>2002-07-18 20:55:14 +0800
committerroberto <roberto@FreeBSD.org>2002-07-18 20:55:14 +0800
commit709c1865ed4ecc99d0c07bdbc262a03cf6ee1fe3 (patch)
tree08c55404264eecf2e477d9fb2b964e5b292708a3
parent54c26368f0d755c7287b576a8f43dcc393a14573 (diff)
downloadfreebsd-ports-gnome-709c1865ed4ecc99d0c07bdbc262a03cf6ee1fe3.tar.gz
freebsd-ports-gnome-709c1865ed4ecc99d0c07bdbc262a03cf6ee1fe3.tar.zst
freebsd-ports-gnome-709c1865ed4ecc99d0c07bdbc262a03cf6ee1fe3.zip
Alarm Pinger (apinger) is a little tool which monitors various IP
devices by simple ICMP echo requests. Unlike most Perl or shell script tools, it does not spawn processes or use much CPU time, and is ideal for when one wants continuous monitoring and fast response upon target failure. It is written in C and supports both IPv4 and IPv6. PR: ports/40688 Submitted by: Michael L. Hostbaek (mich@freebsdcluster.org)
-rw-r--r--net/apinger/Makefile37
-rw-r--r--net/apinger/distinfo1
-rw-r--r--net/apinger/pkg-comment1
-rw-r--r--net/apinger/pkg-descr12
-rw-r--r--net/apinger/pkg-plist6
5 files changed, 57 insertions, 0 deletions
diff --git a/net/apinger/Makefile b/net/apinger/Makefile
new file mode 100644
index 000000000000..067380ab78fd
--- /dev/null
+++ b/net/apinger/Makefile
@@ -0,0 +1,37 @@
+# ex:ts=8
+# Ports collection makefile for: apinger
+# Date created: Tue Jul 17, 2002
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= apinger
+PORTVERSION= 0.2
+CATEGORIES= net
+MASTER_SITES= http://www.bnet.pl/~jajcus/apinger/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mich@freebsdcluster.org
+
+GNU_CONFIGURE= yes
+
+DOCSDIR?= ${PREFIX}/share/doc/${PORTNAME}
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/src/apinger.conf ${PREFIX}/etc/
+.if !defined(BATCH)
+ @${ECHO} ""
+ @${ECHO} "###############################################################################"
+ @${ECHO} "# Please edit ${PREFIX}/etc/apinger.conf to your needs. #"
+ @${ECHO} "###############################################################################"
+.endif
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/README
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}/NEWS
+ ${INSTALL_DATA} ${WRKSRC}/AUTHORS ${DOCSDIR}/AUTHORS
+.endif
+.include <bsd.port.mk>
diff --git a/net/apinger/distinfo b/net/apinger/distinfo
new file mode 100644
index 000000000000..aaba0f15c4fe
--- /dev/null
+++ b/net/apinger/distinfo
@@ -0,0 +1 @@
+MD5 (apinger-0.2.tar.gz) = 4f8bca345c0c198b29e82252b9cca04d
diff --git a/net/apinger/pkg-comment b/net/apinger/pkg-comment
new file mode 100644
index 000000000000..aa173bc84bb6
--- /dev/null
+++ b/net/apinger/pkg-comment
@@ -0,0 +1 @@
+An IP device monitoring tool
diff --git a/net/apinger/pkg-descr b/net/apinger/pkg-descr
new file mode 100644
index 000000000000..0d0a4f2866f2
--- /dev/null
+++ b/net/apinger/pkg-descr
@@ -0,0 +1,12 @@
+Alarm Pinger (apinger) is a little tool which monitors various IP
+devices by simple ICMP echo requests. Unlike most Perl or shell
+script tools, it does not spawn processes or use much CPU time,
+and is ideal for when one wants continuous monitoring and fast
+response upon target failure. It is written in C and supports both
+IPv4 and IPv6.
+
+AUTHOR: Jacek Konieczny <jajcus@pld.org.pl>
+WWW: http://www.bnet.pl/~jajcus/apinger/
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/net/apinger/pkg-plist b/net/apinger/pkg-plist
new file mode 100644
index 000000000000..b92708299b23
--- /dev/null
+++ b/net/apinger/pkg-plist
@@ -0,0 +1,6 @@
+sbin/apinger
+etc/apinger.conf
+share/doc/apinger/README
+share/doc/apinger/NEWS
+share/doc/apinger/AUTHORS
+@dirrm share/doc/apinger