aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2017-01-22 20:50:08 +0800
committertcberner <tcberner@FreeBSD.org>2017-01-22 20:50:08 +0800
commit76f2c6eb11ee5117763824656f3b1af20bb0d00a (patch)
tree827322b9ddfac8cde006015de22267be471f0537
parentbc40b2d3b031e7a3a555e8176df5f811a3fed26b (diff)
downloadfreebsd-ports-gnome-76f2c6eb11ee5117763824656f3b1af20bb0d00a.tar.gz
freebsd-ports-gnome-76f2c6eb11ee5117763824656f3b1af20bb0d00a.tar.zst
freebsd-ports-gnome-76f2c6eb11ee5117763824656f3b1af20bb0d00a.zip
Update math/gmm++ to 5.1
Due to it requiring c++11 features now, the consumers audio/csound and audio/csound6 we're version bumped, and set USE_CXXSTD. * http://download.gna.org/getfem/html/homepage/whatsnew/5.0.html * http://download.gna.org/getfem/html/homepage/whatsnew/5.1.html Reviewed by: rakuco Approved by: rakuco (mentor) Differential Revision: https://reviews.freebsd.org/D7730
-rw-r--r--audio/csound/Makefile4
-rw-r--r--audio/csound6/Makefile4
-rw-r--r--math/gmm++/Makefile2
-rw-r--r--math/gmm++/distinfo5
-rw-r--r--math/gmm++/pkg-plist1
5 files changed, 11 insertions, 5 deletions
diff --git a/audio/csound/Makefile b/audio/csound/Makefile
index a7e6f6af6356..883b8fc95629 100644
--- a/audio/csound/Makefile
+++ b/audio/csound/Makefile
@@ -3,7 +3,7 @@
PORTNAME= csound
PORTVERSION= 5.19.01
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R} \
SF/${PORTNAME}/${PORTNAME}5/${PORTNAME}${PORTVERSION:R}/manual:manual
@@ -28,6 +28,8 @@ CONFLICTS_INSTALL= outguess-* csound6
WRKSRC= ${WRKDIR}/${PORTNAME:S/c/C/}${PORTVERSION}
USES= bison cpe gettext scons compiler:openmp python
+# math/gmm++ requires c++11
+USE_CXXSTD= c++11
CPE_VENDOR= csounds
MAKE_ARGS= instdir="${STAGEDIR}" prefix="${PREFIX}" \
CC="${CC}" CXX="${CXX}" \
diff --git a/audio/csound6/Makefile b/audio/csound6/Makefile
index 155739cd16c1..ef30a7f4ed12 100644
--- a/audio/csound6/Makefile
+++ b/audio/csound6/Makefile
@@ -3,7 +3,7 @@
PORTNAME= csound
PORTVERSION= 6.06
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= audio lang
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}6/${PORTNAME:S/c/C/}${PORTVERSION}
PKGNAMESUFFIX= 6
@@ -24,6 +24,8 @@ LIB_DEPENDS= libsamplerate.so:audio/libsamplerate \
libsndfile.so:audio/libsndfile
USES= alias bison cmake:outsource localbase python:2
+# math/gmm++ requires c++11
+USE_CXXSTD= c++11
CMAKE_ARGS= -DBUILD_CSOUNDVST:BOOL=OFF \
-DBUILD_JAVA_INTERFACE:BOOL=OFF \
-DBUILD_P5GLOVE_OPCODES:BOOL=OFF \
diff --git a/math/gmm++/Makefile b/math/gmm++/Makefile
index 3652566c5156..f6cda6e27479 100644
--- a/math/gmm++/Makefile
+++ b/math/gmm++/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= gmm++
-PORTVERSION= 4.3
+PORTVERSION= 5.1
CATEGORIES= math
MASTER_SITES= http://download.gna.org/getfem/stable/
DISTNAME= ${PORTNAME:S/+//g}-${PORTVERSION}
diff --git a/math/gmm++/distinfo b/math/gmm++/distinfo
index fd2f25c21e4a..26d46a958dc0 100644
--- a/math/gmm++/distinfo
+++ b/math/gmm++/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gmm-4.3.tar.gz) = 09ee01312df1eb11cace9839e6006d842ac492f0e62f0c22bcab6181ef2d5c1b
-SIZE (gmm-4.3.tar.gz) = 488181
+TIMESTAMP = 1472681977
+SHA256 (gmm-5.1.tar.gz) = 90e6bf309b81f496b401a375fe99826ad4b5c6ba99db6c92b37f9261db462636
+SIZE (gmm-5.1.tar.gz) = 537290
diff --git a/math/gmm++/pkg-plist b/math/gmm++/pkg-plist
index 160ad08d6d1f..95663760fb52 100644
--- a/math/gmm++/pkg-plist
+++ b/math/gmm++/pkg-plist
@@ -8,6 +8,7 @@ include/gmm/gmm_conjugated.h
include/gmm/gmm_def.h
include/gmm/gmm_dense_Householder.h
include/gmm/gmm_dense_lu.h
+include/gmm/gmm_dense_matrix_functions.h
include/gmm/gmm_dense_qr.h
include/gmm/gmm_dense_sylvester.h
include/gmm/gmm_domain_decomp.h