aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-05-02 18:14:50 +0800
committeredwin <edwin@FreeBSD.org>2003-05-02 18:14:50 +0800
commit77f8841743b1f6cc9b8a82289515836c6bcd4bf2 (patch)
treebaaa5e1a8c54776fd863000787acb62caea4cd4e
parent50b2e2f6464f0f9a95bd811cfc1bc5b54641f560 (diff)
downloadfreebsd-ports-gnome-77f8841743b1f6cc9b8a82289515836c6bcd4bf2.tar.gz
freebsd-ports-gnome-77f8841743b1f6cc9b8a82289515836c6bcd4bf2.tar.zst
freebsd-ports-gnome-77f8841743b1f6cc9b8a82289515836c6bcd4bf2.zip
Make sure that the conditional check on libdb4 actually happens.
Submitted by: Oliver Eikemeier <eikemeier@fillmore-labs.com>
-rw-r--r--net/openldap20-server/Makefile16
-rw-r--r--net/openldap20/Makefile16
2 files changed, 16 insertions, 16 deletions
diff --git a/net/openldap20-server/Makefile b/net/openldap20-server/Makefile
index b837fa924728..e6950a3f242e 100644
--- a/net/openldap20-server/Makefile
+++ b/net/openldap20-server/Makefile
@@ -30,14 +30,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source LDAP client and server software
-.if exists(${LOCALBASE}/lib/libdb4.so)
-DB_CFLAGS= -I${LOCALBASE}/include/db4
-LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4
-.else
-DB_CFLAGS= -I${LOCALBASE}/include/db3
-LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
-.endif
-
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
USE_OPENSSL= yes
@@ -98,6 +90,14 @@ BINS= bin/ldapadd \
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
+.if exists(${LOCALBASE}/lib/libdb4.so)
+DB_CFLAGS= -I${LOCALBASE}/include/db4
+LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4
+.else
+DB_CFLAGS= -I${LOCALBASE}/include/db3
+LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's@%LOCALSTATEDIR%/slapd[.]pid@/var/run/slapd.pid@g; \
s@%LOCALSTATEDIR%/slapd[.]args@/var/run/slapd.args@g' ${WRKSRC}/servers/slapd/slapd.conf
diff --git a/net/openldap20/Makefile b/net/openldap20/Makefile
index b837fa924728..e6950a3f242e 100644
--- a/net/openldap20/Makefile
+++ b/net/openldap20/Makefile
@@ -30,14 +30,6 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Open source LDAP client and server software
-.if exists(${LOCALBASE}/lib/libdb4.so)
-DB_CFLAGS= -I${LOCALBASE}/include/db4
-LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4
-.else
-DB_CFLAGS= -I${LOCALBASE}/include/db3
-LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
-.endif
-
USE_AUTOCONF_VER=213
USE_LIBTOOL= yes
USE_OPENSSL= yes
@@ -98,6 +90,14 @@ BINS= bin/ldapadd \
.include <bsd.port.pre.mk>
.include "${FILESDIR}/manpages"
+.if exists(${LOCALBASE}/lib/libdb4.so)
+DB_CFLAGS= -I${LOCALBASE}/include/db4
+LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4
+.else
+DB_CFLAGS= -I${LOCALBASE}/include/db3
+LIB_DEPENDS= db3.3:${PORTSDIR}/databases/db3
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's@%LOCALSTATEDIR%/slapd[.]pid@/var/run/slapd.pid@g; \
s@%LOCALSTATEDIR%/slapd[.]args@/var/run/slapd.args@g' ${WRKSRC}/servers/slapd/slapd.conf