aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-04-27 08:45:47 +0800
committerzi <zi@FreeBSD.org>2012-04-27 08:45:47 +0800
commit7c114abb7210b4dc7faf656816152b9ffd10892c (patch)
treef4fc567da3be7c9a3eb6694a80287951ba2bd4fc
parent033a163c20a67111431495dccb91ca19fe00a382 (diff)
downloadfreebsd-ports-gnome-7c114abb7210b4dc7faf656816152b9ffd10892c.tar.gz
freebsd-ports-gnome-7c114abb7210b4dc7faf656816152b9ffd10892c.tar.zst
freebsd-ports-gnome-7c114abb7210b4dc7faf656816152b9ffd10892c.zip
New port: www/rubygem-nanoc
nanoc is a simple but very flexible static site generator written in Ruby. It operates on local files, and therefore does not run on the server. nanoc "compiles" the local source files into HTML (usually), by evaluating eRuby, Markdown, etc.
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-nanoc/Makefile24
-rw-r--r--www/rubygem-nanoc/distinfo2
-rw-r--r--www/rubygem-nanoc/pkg-descr6
4 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3031bf1a834e..9de85c3c45ba 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1692,6 +1692,7 @@
SUBDIR += rubygem-mongrel
SUBDIR += rubygem-mongrel_cluster
SUBDIR += rubygem-multipart-post
+ SUBDIR += rubygem-nanoc
SUBDIR += rubygem-net-http-digest_auth
SUBDIR += rubygem-net-http-persistent
SUBDIR += rubygem-nicovideo
diff --git a/www/rubygem-nanoc/Makefile b/www/rubygem-nanoc/Makefile
new file mode 100644
index 000000000000..4ae2e6267b25
--- /dev/null
+++ b/www/rubygem-nanoc/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: gem-nanoc
+# Date created: 26 Apr 2012
+# Whom: Ryan Steinmetz <zi@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= nanoc
+PORTVERSION= 3.3.5
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= zi@FreeBSD.org
+COMMENT= A simple but very flexible static site generator
+
+RUN_DEPENDS= rubygem-cri>=2.2:${PORTSDIR}/devel/rubygem-cri
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+USE_RAKE= yes
+RUBYGEM_AUTOPLIST= yes
+
+PLIST_FILES= bin/nanoc
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-nanoc/distinfo b/www/rubygem-nanoc/distinfo
new file mode 100644
index 000000000000..fb5c18cbbf63
--- /dev/null
+++ b/www/rubygem-nanoc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/nanoc-3.3.5.gem) = 06cf9397f7d80ebcaa886a8bfa4ca22798a9d0a16c2b9cc59049e997a2cc98ef
+SIZE (rubygem/nanoc-3.3.5.gem) = 148992
diff --git a/www/rubygem-nanoc/pkg-descr b/www/rubygem-nanoc/pkg-descr
new file mode 100644
index 000000000000..a28fc0cf8829
--- /dev/null
+++ b/www/rubygem-nanoc/pkg-descr
@@ -0,0 +1,6 @@
+nanoc is a simple but very flexible static site generator written in Ruby.
+It operates on local files, and therefore does not run on the server.
+nanoc "compiles" the local source files into HTML (usually), by evaluating
+eRuby, Markdown, etc.
+
+WWW: https://rubygems.org/gems/nanoc