aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlofi <lofi@FreeBSD.org>2004-06-28 04:58:21 +0800
committerlofi <lofi@FreeBSD.org>2004-06-28 04:58:21 +0800
commit7c39032ebfdbaa6eb801a325179d0ba5ec2546d8 (patch)
tree867e000fe7c50a5e5a5dda28107f17d4ef6d8c45
parent0866a6eff09d0c46c453830fa5f7b1a785586a40 (diff)
downloadfreebsd-ports-gnome-7c39032ebfdbaa6eb801a325179d0ba5ec2546d8.tar.gz
freebsd-ports-gnome-7c39032ebfdbaa6eb801a325179d0ba5ec2546d8.tar.zst
freebsd-ports-gnome-7c39032ebfdbaa6eb801a325179d0ba5ec2546d8.zip
Add warppipe, online multi-player gaming for the Nintendo GameCube.
Submitted by: Chris Howells <howells@kde.org>
-rw-r--r--net/Makefile1
-rw-r--r--net/warppipe/Makefile26
-rw-r--r--net/warppipe/distinfo2
-rw-r--r--net/warppipe/pkg-descr11
-rw-r--r--net/warppipe/pkg-plist2
5 files changed, 42 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ad2501206d35..2406bcdadeeb 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -713,6 +713,7 @@
SUBDIR += vtun
SUBDIR += wais
SUBDIR += wakeonlan
+ SUBDIR += warppipe
SUBDIR += whois
SUBDIR += widentd
SUBDIR += wistumbler2
diff --git a/net/warppipe/Makefile b/net/warppipe/Makefile
new file mode 100644
index 000000000000..fb2a4ae4d02a
--- /dev/null
+++ b/net/warppipe/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: warppipe
+# Date created: 27 June 2004
+# Whom: Chris Howells <howells@kde.org>
+#
+# $FreeBSD$
+
+PORTNAME= warppipe
+PORTVERSION= 0.3.5b
+CATEGORIES= net games
+MASTER_SITES= http://www.warppipe.com/download/
+DISTNAME= WarpPipe-0.3.5-bsd
+
+MAINTAINER= howells@kde.org
+COMMENT= Online multi-player gaming for the Nintendo GameCube
+
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+
+USE_XLIB= YES
+WRKSRC= ${WRKDIR}/WarpPipe-0.3.5-bsd
+NO_BUILD= YES
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/WarpPipe ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/soshell ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/warppipe/distinfo b/net/warppipe/distinfo
new file mode 100644
index 000000000000..699871139190
--- /dev/null
+++ b/net/warppipe/distinfo
@@ -0,0 +1,2 @@
+MD5 (WarpPipe-0.3.5-bsd.tar.gz) = 692bbf7ffa0ef57c5ac2063f1c58f2bf
+SIZE (WarpPipe-0.3.5-bsd.tar.gz) = 2232448
diff --git a/net/warppipe/pkg-descr b/net/warppipe/pkg-descr
new file mode 100644
index 000000000000..e5655942e5ff
--- /dev/null
+++ b/net/warppipe/pkg-descr
@@ -0,0 +1,11 @@
+Warp Pipe is free software that runs on your PC or Mac and is
+available for Windows, Mac OSX, Linux, and BSD operating systems.
+While running on your PC or Mac, Warp Pipe allows you to play
+LAN-enabled Nintendo GameCube games over the Internet with other
+GameCube gamers. While Warp Pipe software runs on your PC or Mac,
+it talks to the GameCube connected on the same network, allowing
+the GameCube to communicate with other GameCubes over the Internet.
+
+WWW: http://www.warppipe.com
+
+Chris Howells howells@kde.org
diff --git a/net/warppipe/pkg-plist b/net/warppipe/pkg-plist
new file mode 100644
index 000000000000..9238748738cd
--- /dev/null
+++ b/net/warppipe/pkg-plist
@@ -0,0 +1,2 @@
+bin/WarpPipe
+bin/soshell