aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2003-01-28 22:20:01 +0800
committertobez <tobez@FreeBSD.org>2003-01-28 22:20:01 +0800
commit7d4456eb7138a0f3d906491a6d91c696bf575ba6 (patch)
tree2d4353762c576f565f64f752dcc7098d0c86c5d5
parent24b972f1c60ad3b456b954c00e4c750207afc64e (diff)
downloadfreebsd-ports-gnome-7d4456eb7138a0f3d906491a6d91c696bf575ba6.tar.gz
freebsd-ports-gnome-7d4456eb7138a0f3d906491a6d91c696bf575ba6.tar.zst
freebsd-ports-gnome-7d4456eb7138a0f3d906491a6d91c696bf575ba6.zip
Add p5-Sub-Uplevel 0.06, a perl module to apparently run a function in a
higher stack frame. PR: 47582 Submitted by: Erwin Lansing <erwin@lansing.dk>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Sub-Uplevel/Makefile31
-rw-r--r--devel/p5-Sub-Uplevel/distinfo1
-rw-r--r--devel/p5-Sub-Uplevel/pkg-comment1
-rw-r--r--devel/p5-Sub-Uplevel/pkg-descr5
-rw-r--r--devel/p5-Sub-Uplevel/pkg-plist6
6 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a334b70d7393..93fc79430190 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -607,6 +607,7 @@
SUBDIR += p5-String-Random
SUBDIR += p5-String-RexxParse
SUBDIR += p5-String-Similarity
+ SUBDIR += p5-Sub-Uplevel
SUBDIR += p5-System2
SUBDIR += p5-Term-ANSIColor
SUBDIR += p5-Term-ProgressBar
diff --git a/devel/p5-Sub-Uplevel/Makefile b/devel/p5-Sub-Uplevel/Makefile
new file mode 100644
index 000000000000..7722c1701cc7
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Sub-Uplevel
+# Date created: January 27th 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sub-Uplevel
+PORTVERSION= 0.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sub
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Sub::Uplevel.3
+
+.include <bsd.port.pre.mk>
+
+##
+## this port requires PERL 5.6.x or later
+##
+.if ${PERL_LEVEL} < 500600
+BROKEN= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Sub-Uplevel/distinfo b/devel/p5-Sub-Uplevel/distinfo
new file mode 100644
index 000000000000..645068b468ec
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/distinfo
@@ -0,0 +1 @@
+MD5 (Sub-Uplevel-0.06.tar.gz) = 1436ca7aa406c1f8096ca6f56f0c69ed
diff --git a/devel/p5-Sub-Uplevel/pkg-comment b/devel/p5-Sub-Uplevel/pkg-comment
new file mode 100644
index 000000000000..12c5d1135e0b
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/pkg-comment
@@ -0,0 +1 @@
+Sub::Uplevel - apparently run a function in a higher stack frame
diff --git a/devel/p5-Sub-Uplevel/pkg-descr b/devel/p5-Sub-Uplevel/pkg-descr
new file mode 100644
index 000000000000..099dd384f107
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/pkg-descr
@@ -0,0 +1,5 @@
+Like Tcl's uplevel() function, but not quite so
+dangerous. The idea is just to fool caller().
+All the really naughty bits of Tcl's uplevel() are avoided.
+
+WWW: http://search.cpan.org/dist/Sub-Uplevel/
diff --git a/devel/p5-Sub-Uplevel/pkg-plist b/devel/p5-Sub-Uplevel/pkg-plist
new file mode 100644
index 000000000000..0133b0cc9ae1
--- /dev/null
+++ b/devel/p5-Sub-Uplevel/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Sub/Uplevel/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Sub/Uplevel.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Sub/Uplevel
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Sub 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/mach/auto 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Sub 2>/dev/null || true