aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornaddy <naddy@FreeBSD.org>2002-06-05 05:35:59 +0800
committernaddy <naddy@FreeBSD.org>2002-06-05 05:35:59 +0800
commit7f15aa289a508edba1a5add2776837d09af71d55 (patch)
treed3758c73ee1f4de15b389d55e17533d889fbe789
parent881e3f4bb87ac09632ccf22e6446e6c7e654ead5 (diff)
downloadfreebsd-ports-gnome-7f15aa289a508edba1a5add2776837d09af71d55.tar.gz
freebsd-ports-gnome-7f15aa289a508edba1a5add2776837d09af71d55.tar.zst
freebsd-ports-gnome-7f15aa289a508edba1a5add2776837d09af71d55.zip
Upstream fix for decimal point stack push in RPN mode.
-rw-r--r--math/calcoo/Makefile1
-rw-r--r--math/calcoo/files/patch-src_c__input.c23
2 files changed, 24 insertions, 0 deletions
diff --git a/math/calcoo/Makefile b/math/calcoo/Makefile
index fe60663de3af..69d378fa0c90 100644
--- a/math/calcoo/Makefile
+++ b/math/calcoo/Makefile
@@ -6,6 +6,7 @@
PORTNAME= calcoo
PORTVERSION= 1.3.8
+PORTREVISION= 1
CATEGORIES= math
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.physics.umn.edu/~kaminski/calcoo/
diff --git a/math/calcoo/files/patch-src_c__input.c b/math/calcoo/files/patch-src_c__input.c
new file mode 100644
index 000000000000..754c26e65658
--- /dev/null
+++ b/math/calcoo/files/patch-src_c__input.c
@@ -0,0 +1,23 @@
+
+$FreeBSD$
+
+--- src/c_input.c.orig Sun Jun 2 20:50:25 2002
++++ src/c_input.c Tue Jun 4 23:28:14 2002
+@@ -118,10 +118,15 @@
+
+ void call_dot(void)
+ {
+- if(cpu->last_action != ACTION_INPUT) {
+- cpu->y = cpu->x;
++ if (cpu->last_action != ACTION_INPUT) {
++ if ((cpu->rpn_mode)
++ && (cpu->last_action == ACTION_ENTER)) {
++ push_stack();
++ cpu->y = cpu->x;
++ }
+ reset_input();
+ cpu->last_action = ACTION_INPUT;
++ cpu_to_output();
+ }
+
+ if (cpu->d->input_field == INPUT_FIELD_INT) {