aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-07-22 10:35:58 +0800
committerpat <pat@FreeBSD.org>2002-07-22 10:35:58 +0800
commit81131f8ff5f00f61dd8bc8c076fcdf7864ed2cf0 (patch)
tree316f9127e9ab00cb0afe365921229d193262d54f
parent2ec0a7295d5e6f2a5c2f8669f83b0ce3cae8607e (diff)
downloadfreebsd-ports-gnome-81131f8ff5f00f61dd8bc8c076fcdf7864ed2cf0.tar.gz
freebsd-ports-gnome-81131f8ff5f00f61dd8bc8c076fcdf7864ed2cf0.tar.zst
freebsd-ports-gnome-81131f8ff5f00f61dd8bc8c076fcdf7864ed2cf0.zip
Update to 1.4
PR: ports/40820 Submitted by: maintainer
-rw-r--r--x11-wm/bbrun/Makefile2
-rw-r--r--x11-wm/bbrun/distinfo2
-rw-r--r--x11-wm/bbrun/files/patch-Makefile14
-rw-r--r--x11-wm/bbrun/files/patch-bbrun.c23
-rw-r--r--x11/bbrun/Makefile2
-rw-r--r--x11/bbrun/distinfo2
-rw-r--r--x11/bbrun/files/patch-Makefile14
-rw-r--r--x11/bbrun/files/patch-bbrun.c23
8 files changed, 68 insertions, 14 deletions
diff --git a/x11-wm/bbrun/Makefile b/x11-wm/bbrun/Makefile
index 0f29c5a1bdec..b0bf647736ae 100644
--- a/x11-wm/bbrun/Makefile
+++ b/x11-wm/bbrun/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bbrun
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= x11-wm
MASTER_SITES= http://www.dwave.net/~jking/bbrun/
diff --git a/x11-wm/bbrun/distinfo b/x11-wm/bbrun/distinfo
index 5fd82e1e13d0..faa359811d8d 100644
--- a/x11-wm/bbrun/distinfo
+++ b/x11-wm/bbrun/distinfo
@@ -1 +1 @@
-MD5 (bbrun-1.3.tar.gz) = ef1a5271b05c4652d78ae034454d6f3b
+MD5 (bbrun-1.4.tar.gz) = d31cecada7d39b894bdf6012c6bae98a
diff --git a/x11-wm/bbrun/files/patch-Makefile b/x11-wm/bbrun/files/patch-Makefile
index 9c48d6f7ce99..bffa640c44f0 100644
--- a/x11-wm/bbrun/files/patch-Makefile
+++ b/x11-wm/bbrun/files/patch-Makefile
@@ -1,25 +1,29 @@
---- Makefile.orig Wed Feb 6 15:05:51 2002
-+++ Makefile Tue Jun 18 01:37:36 2002
-@@ -1,16 +1,17 @@
+--- Makefile.orig Sat Jul 20 12:47:49 2002
++++ Makefile Sat Jul 20 20:24:41 2002
+@@ -1,16 +1,15 @@
-CC = gcc
-LIBS = -lXpm `gtk-config --libs`
-CFLAGS = `gtk-config --cflags`
+LIBS = -lXpm `${GTK_CONFIG} --libs` -L${LOCALBASE}/lib -lgnugetopt
-+CFLAGS += `${GTK_CONFIG} --cflags` -Wall
++CFLAGS = `${GTK_CONFIG} --cflags` -Wall
OBJS = bbrun.o \
../wmgeneral/wmgeneral.o \
../wmgeneral/misc.o \
../wmgeneral/list.o
.c.o:
-- $(CC) -c -O2 -Wall $< -o $*.o $(CFLAGS)
+- $(CC) -g -c -O2 -Wall $< -o $*.o $(CFLAGS)
+ $(CC) -c $< -o $*.o $(CFLAGS)
bbrun: $(OBJS)
- $(CC) -Wall -g -o bbrun $^ $(LIBS)
+ $(CC) -o bbrun $^ $(LIBS)
+ install:
+ cp bbrun /usr/local/bin/
+@@ -18,3 +17,5 @@
clean:
rm -f bbrun $(OBJS)
+ rm -f core
+
+all: bbrun
diff --git a/x11-wm/bbrun/files/patch-bbrun.c b/x11-wm/bbrun/files/patch-bbrun.c
new file mode 100644
index 000000000000..376c2989112b
--- /dev/null
+++ b/x11-wm/bbrun/files/patch-bbrun.c
@@ -0,0 +1,23 @@
+--- bbrun.c.orig Sat Jul 20 13:24:53 2002
++++ bbrun.c Sat Jul 20 20:31:49 2002
+@@ -3,7 +3,11 @@
+ #include <string.h>
+ #include <getopt.h>
+ #include <unistd.h>
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#else
+ #include <linux/types.h>
++#endif
+ #include <X11/xpm.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdkkeysyms.h>
+@@ -20,7 +24,7 @@
+ #define ADVANCED_WINDOW_ROWS 3
+ #define ADVANCED_WINDOW_COLS 10
+
+-#define u32 __u32
++#define u32 u_int32_t
+ #define __DEBUG__ 0
+ #define VERSION "1.4"
+
diff --git a/x11/bbrun/Makefile b/x11/bbrun/Makefile
index 0f29c5a1bdec..b0bf647736ae 100644
--- a/x11/bbrun/Makefile
+++ b/x11/bbrun/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bbrun
-PORTVERSION= 1.3
+PORTVERSION= 1.4
CATEGORIES= x11-wm
MASTER_SITES= http://www.dwave.net/~jking/bbrun/
diff --git a/x11/bbrun/distinfo b/x11/bbrun/distinfo
index 5fd82e1e13d0..faa359811d8d 100644
--- a/x11/bbrun/distinfo
+++ b/x11/bbrun/distinfo
@@ -1 +1 @@
-MD5 (bbrun-1.3.tar.gz) = ef1a5271b05c4652d78ae034454d6f3b
+MD5 (bbrun-1.4.tar.gz) = d31cecada7d39b894bdf6012c6bae98a
diff --git a/x11/bbrun/files/patch-Makefile b/x11/bbrun/files/patch-Makefile
index 9c48d6f7ce99..bffa640c44f0 100644
--- a/x11/bbrun/files/patch-Makefile
+++ b/x11/bbrun/files/patch-Makefile
@@ -1,25 +1,29 @@
---- Makefile.orig Wed Feb 6 15:05:51 2002
-+++ Makefile Tue Jun 18 01:37:36 2002
-@@ -1,16 +1,17 @@
+--- Makefile.orig Sat Jul 20 12:47:49 2002
++++ Makefile Sat Jul 20 20:24:41 2002
+@@ -1,16 +1,15 @@
-CC = gcc
-LIBS = -lXpm `gtk-config --libs`
-CFLAGS = `gtk-config --cflags`
+LIBS = -lXpm `${GTK_CONFIG} --libs` -L${LOCALBASE}/lib -lgnugetopt
-+CFLAGS += `${GTK_CONFIG} --cflags` -Wall
++CFLAGS = `${GTK_CONFIG} --cflags` -Wall
OBJS = bbrun.o \
../wmgeneral/wmgeneral.o \
../wmgeneral/misc.o \
../wmgeneral/list.o
.c.o:
-- $(CC) -c -O2 -Wall $< -o $*.o $(CFLAGS)
+- $(CC) -g -c -O2 -Wall $< -o $*.o $(CFLAGS)
+ $(CC) -c $< -o $*.o $(CFLAGS)
bbrun: $(OBJS)
- $(CC) -Wall -g -o bbrun $^ $(LIBS)
+ $(CC) -o bbrun $^ $(LIBS)
+ install:
+ cp bbrun /usr/local/bin/
+@@ -18,3 +17,5 @@
clean:
rm -f bbrun $(OBJS)
+ rm -f core
+
+all: bbrun
diff --git a/x11/bbrun/files/patch-bbrun.c b/x11/bbrun/files/patch-bbrun.c
new file mode 100644
index 000000000000..376c2989112b
--- /dev/null
+++ b/x11/bbrun/files/patch-bbrun.c
@@ -0,0 +1,23 @@
+--- bbrun.c.orig Sat Jul 20 13:24:53 2002
++++ bbrun.c Sat Jul 20 20:31:49 2002
+@@ -3,7 +3,11 @@
+ #include <string.h>
+ #include <getopt.h>
+ #include <unistd.h>
++#ifdef __FreeBSD__
++#include <sys/types.h>
++#else
+ #include <linux/types.h>
++#endif
+ #include <X11/xpm.h>
+ #include <gtk/gtk.h>
+ #include <gdk/gdkkeysyms.h>
+@@ -20,7 +24,7 @@
+ #define ADVANCED_WINDOW_ROWS 3
+ #define ADVANCED_WINDOW_COLS 10
+
+-#define u32 __u32
++#define u32 u_int32_t
+ #define __DEBUG__ 0
+ #define VERSION "1.4"
+