aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2014-06-27 05:56:18 +0800
committermadpilot <madpilot@FreeBSD.org>2014-06-27 05:56:18 +0800
commit811b689acf99690d56d1e8ca0f04c9b58ae596cb (patch)
treecaa0a3810cb4a3a3f47e1f2051f418a4a5042927
parentb99fb742987807ab0a54d614588654eb35283a57 (diff)
downloadfreebsd-ports-gnome-811b689acf99690d56d1e8ca0f04c9b58ae596cb.tar.gz
freebsd-ports-gnome-811b689acf99690d56d1e8ca0f04c9b58ae596cb.tar.zst
freebsd-ports-gnome-811b689acf99690d56d1e8ca0f04c9b58ae596cb.zip
Pass MAKE_ENV to MAKE_CMD.
Noticed by: bapt (in r359185)
-rw-r--r--net/unison-devel/Makefile2
-rw-r--r--net/unison/Makefile2
-rw-r--r--net/unison232/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/net/unison-devel/Makefile b/net/unison-devel/Makefile
index 4ee2f2e553e5..4423c0dca85a 100644
--- a/net/unison-devel/Makefile
+++ b/net/unison-devel/Makefile
@@ -61,7 +61,7 @@ post-patch:
post-build:
@${ECHO} Building text-only version
@${ECHO} ${WRKSRC}
- @${MAKE_CMD} -C ${WRKSRC} UISTYLE=text NAME=unison-text
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC} CFLAGS="" UISTYLE=text NAME=unison-text
@cd ${WRKSRC}/win32rc && ${LOCALBASE}/bin/icotool -x U.ico
.endif
diff --git a/net/unison/Makefile b/net/unison/Makefile
index 8e69ecac27c5..e43070aebfae 100644
--- a/net/unison/Makefile
+++ b/net/unison/Makefile
@@ -60,7 +60,7 @@ post-patch:
post-build:
@${ECHO} Building text-only version
@${ECHO} ${WRKSRC}
- @${MAKE_CMD} -C ${WRKSRC} UISTYLE=text NAME=unison-text
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC} CFLAGS="" UISTYLE=text NAME=unison-text
@cd ${WRKSRC}/win32rc && ${LOCALBASE}/bin/icotool -x U.ico
.endif
diff --git a/net/unison232/Makefile b/net/unison232/Makefile
index 5727dd3c6f91..0363d9e7483a 100644
--- a/net/unison232/Makefile
+++ b/net/unison232/Makefile
@@ -60,7 +60,7 @@ post-patch:
post-build:
@${ECHO} Building text-only version
@${ECHO} ${WRKSRC}
- ${MAKE_CMD} -C ${WRKSRC} UISTYLE=text NAME=${PORTNAME}-text
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} -C ${WRKSRC} CFLAGS="" UISTYLE=text NAME=${PORTNAME}-text
@cd ${WRKSRC}/win32rc && ${LOCALBASE}/bin/icotool -x U.ico
.endif