aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-05-16 10:07:21 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-05-16 10:07:21 +0800
commit81b67e2bff7eab9938d564c26e63971e3e602d65 (patch)
tree3ba5960eba5cecfed080311d78b0ba852dbaa98a
parent7eeaa278412bad29703494bf0f0be75bfd8dbb08 (diff)
downloadfreebsd-ports-gnome-81b67e2bff7eab9938d564c26e63971e3e602d65.tar.gz
freebsd-ports-gnome-81b67e2bff7eab9938d564c26e63971e3e602d65.tar.zst
freebsd-ports-gnome-81b67e2bff7eab9938d564c26e63971e3e602d65.zip
Pull r760926 from stream to fix CVE-2009-0796
This will be fixed in 2.0.5 and can be removed SVN: http://svn.apache.org/viewvc?rev=760926&view=rev Security: http://www.vuxml.org/freebsd/4a638895-41b7-11de-b1cc-00219b0fc4d8
-rw-r--r--www/mod_perl2/Makefile3
-rw-r--r--www/mod_perl2/files/patch-r76092647
2 files changed, 49 insertions, 1 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 2eb3dba3084a..75f0929db34b 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_perl
PORTVERSION= 2.0.4
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 3
CATEGORIES= www perl5
MASTER_SITES= http://perl.apache.org/dist/ \
@@ -100,6 +100,7 @@ pre-fetch:
pre-configure:
${RM} ${WRKSRC}/lib/ModPerl/BuildMM.pm.orig
+ ${RM} ${WRKSRC}/lib/Apache2/Status.pm.orig
post-install:
${MKDIR} ${PREFIX}/${APACHEINCLUDEDIR}/modules/perl
diff --git a/www/mod_perl2/files/patch-r760926 b/www/mod_perl2/files/patch-r760926
new file mode 100644
index 000000000000..2c72c4eaeed4
--- /dev/null
+++ b/www/mod_perl2/files/patch-r760926
@@ -0,0 +1,47 @@
+--- lib/Apache2/Status.pm 2009/04/01 15:32:12 760925
++++ lib/Apache2/Status.pm 2009/04/01 15:39:56 760926
+@@ -29,7 +29,7 @@
+
+ use Apache2::Const -compile => qw(OK);
+
+-$Apache2::Status::VERSION = '4.00'; # mod_perl 2.0
++$Apache2::Status::VERSION = '4.01'; # mod_perl 2.0
+
+ use constant IS_WIN32 => ($^O eq "MSWin32");
+
+@@ -126,7 +126,7 @@
+ $r->print(symdump($r, $qs));
+ }
+ else {
+- my $uri = $r->uri;
++ my $uri = $r->location;
+ $r->print('<p>');
+ $r->print(
+ map { qq[<a href="$uri?$_">$status{$_}</a><br />\n] } sort { lc $a cmp lc $b } keys %status
+@@ -198,7 +198,7 @@
+ sub status_inc {
+ my ($r) = @_;
+
+- my $uri = $r->uri;
++ my $uri = $r->location;
+ my @retval = (
+ '<table border="1">',
+ "<tr>",
+@@ -289,7 +289,7 @@
+ my ($r) = @_;
+
+ local $_;
+- my $uri = $r->uri;
++ my $uri = $r->location;
+ my $cache = __PACKAGE__->registry_cache;
+
+ my @retval = "<h2>Compiled registry scripts grouped by their handler</h2>";
+@@ -765,7 +765,7 @@
+ my ($self, $package, $r) = @_;
+
+ my @m = qw(<table>);
+- my $uri = $r->uri;
++ my $uri = $r->location;
+ my $is_main = $package eq "main";
+
+ my $do_dump = has($r, "dumper");