aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2010-08-31 15:51:34 +0800
committerehaupt <ehaupt@FreeBSD.org>2010-08-31 15:51:34 +0800
commit8543d7e2bca10b745d6369643912fa1a15bb016a (patch)
treecf1729aa8c97545b62f0122d36143a656da4c675
parent562294cedeca3945ba1cf9247a0350a0099a639f (diff)
downloadfreebsd-ports-gnome-8543d7e2bca10b745d6369643912fa1a15bb016a.tar.gz
freebsd-ports-gnome-8543d7e2bca10b745d6369643912fa1a15bb016a.tar.zst
freebsd-ports-gnome-8543d7e2bca10b745d6369643912fa1a15bb016a.zip
Fix build on FreeBSD prior to OSVERSION 800067 by pulling in devel/libgetline
Notified by: andrew clarke <mail@ozzmosis.com>
-rw-r--r--textproc/uni2ascii/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/textproc/uni2ascii/Makefile b/textproc/uni2ascii/Makefile
index a1f6641f0d51..990803124f7d 100644
--- a/textproc/uni2ascii/Makefile
+++ b/textproc/uni2ascii/Makefile
@@ -18,15 +18,23 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
MAKE_JOBS_SAFE= yes
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= uni2ascii.1 ascii2uni.1
PLIST_FILES= bin/uni2ascii bin/ascii2uni
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800067
+LIB_DEPENDS= getline.1:${PORTSDIR}/devel/libgetline
+LDFLAGS+= -lgetline
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+.endif
+
do-install:
.for f in ${PORTNAME} ascii2uni
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${f}.1 ${MAN1PREFIX}/man/man1
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>