aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2005-01-02 09:07:46 +0800
committerkris <kris@FreeBSD.org>2005-01-02 09:07:46 +0800
commit93c00a6a42b2c063acbc4733a5b3b73af3f0dfa5 (patch)
treee5ad82f91f13b345047652d0e21917cef9912c37
parentc87d9525e7d498622bb1ea08fa6724c5fe012bdb (diff)
downloadfreebsd-ports-gnome-93c00a6a42b2c063acbc4733a5b3b73af3f0dfa5.tar.gz
freebsd-ports-gnome-93c00a6a42b2c063acbc4733a5b3b73af3f0dfa5.tar.zst
freebsd-ports-gnome-93c00a6a42b2c063acbc4733a5b3b73af3f0dfa5.zip
BROKEN on alpha: Does not compile
Approved by: portmgr (self)
-rw-r--r--devel/gdb6/Makefile4
-rw-r--r--devel/gdb66/Makefile4
-rw-r--r--math/GiNaC/Makefile4
-rw-r--r--net/howl/Makefile8
4 files changed, 15 insertions, 5 deletions
diff --git a/devel/gdb6/Makefile b/devel/gdb6/Makefile
index 0914ce2f2209..a8e8ec2f7ecf 100644
--- a/devel/gdb6/Makefile
+++ b/devel/gdb6/Makefile
@@ -34,8 +34,8 @@ CFLAGS+= -DRL_NO_COMPAT -DKGDB
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= "Does not build on ia64 or sparc64"
+.if ${ARCH} == "ia64" || ${ARCH} == "sparc64" || ${ARCH} == "alpha"
+BROKEN= "Does not build on ia64, sparc64 or alpha"
.endif
.if ${OSVERSION} < 500000
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 0914ce2f2209..a8e8ec2f7ecf 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -34,8 +34,8 @@ CFLAGS+= -DRL_NO_COMPAT -DKGDB
.include <bsd.port.pre.mk>
-.if ${ARCH} == "ia64" || ${ARCH} == "sparc64"
-BROKEN= "Does not build on ia64 or sparc64"
+.if ${ARCH} == "ia64" || ${ARCH} == "sparc64" || ${ARCH} == "alpha"
+BROKEN= "Does not build on ia64, sparc64 or alpha"
.endif
.if ${OSVERSION} < 500000
diff --git a/math/GiNaC/Makefile b/math/GiNaC/Makefile
index 8659d4eec907..0fc646eeb3c6 100644
--- a/math/GiNaC/Makefile
+++ b/math/GiNaC/Makefile
@@ -34,6 +34,10 @@ LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
+.if ${ARCH} == "alpha"
+BROKEN= "Does not build on alpha"
+.endif
+
post-extract:
@${RM} -f ${WRKSRC}/doc/tutorial/ginac.info*
diff --git a/net/howl/Makefile b/net/howl/Makefile
index 6ae69894b5c6..f85a031e551d 100644
--- a/net/howl/Makefile
+++ b/net/howl/Makefile
@@ -24,9 +24,15 @@ MAN8= mDNSResponder.8
PLIST_SUB= VERSION="${PORTVERSION}"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "alpha"
+BROKEN= "Does not compile on alpha"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-pthread||g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
-E -e '/^library_includedir[[:space:]]*=/s^\$$[(]includedir[)]/howl^$$(includedir)/howl-${PORTVERSION}^g'
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>